summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Seren <guillaumeseren@gmail.com>2017-12-12 19:47:37 +0100
committerAmadeusz Żołnowski <aidecoe@gentoo.org>2017-12-12 21:12:40 +0000
commitf3472dd789f9403fe71a1bb8dbea1aa8f5ff3ea5 (patch)
tree77d14b039dc811532f2f1737f8bac2b94f51203e /net-mail
parentdev-python/qtconsole: version bump to 4.3.1. (diff)
downloadgentoo-f3472dd789f9403fe71a1bb8dbea1aa8f5ff3ea5.tar.gz
gentoo-f3472dd789f9403fe71a1bb8dbea1aa8f5ff3ea5.tar.bz2
gentoo-f3472dd789f9403fe71a1bb8dbea1aa8f5ff3ea5.zip
net-mail/notmuch: Add version bump 0.25.3
Package-Manager: Portage-2.3.16, Repoman-2.3.6 Closes: https://bugs.gentoo.org/640850
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/notmuch/Manifest1
-rw-r--r--net-mail/notmuch/notmuch-0.25.3.ebuild208
2 files changed, 209 insertions, 0 deletions
diff --git a/net-mail/notmuch/Manifest b/net-mail/notmuch/Manifest
index fc7a646da864..3a40e4fcdc04 100644
--- a/net-mail/notmuch/Manifest
+++ b/net-mail/notmuch/Manifest
@@ -3,4 +3,5 @@ DIST notmuch-0.23.7.tar.gz 692230 BLAKE2B 79e81bde02546589c867d636fd30453beeecfb
DIST notmuch-0.24.2.tar.gz 709272 BLAKE2B 25ef9db21a9fb009db89e472e06d871e92efc5223ef3edd91716db2a7edb5b8d39df000f540aa30762fe64e05fff221158040b2869fb618c89f9fa36cbe1757f SHA512 fcdc4ad5a65c57dd3077d93aeb384378f8dee105362fa8c2755daf14bbeb5376f8d1580fd79c8bd8e8d2d88cd44846ca9972b2f942133a447eb99d08ef9056dc
DIST notmuch-0.25.1.tar.gz 882141 BLAKE2B dfc6c9e62012280e1c72378b39d6b8af3cefa701ed8d147a758864bccfd596ebf464e608daa6e5ce049114d5ad13a6737f4376f6f9d5cf4c5cf115b633b4b57d SHA512 989acc5eda7d2f9512741c8ae850e34c6fbbdd5fa5fa23f25a6096250d414919007c5cfda68d6f48606c0a024692e082a28cb358e6d3fc2afc0502b5bcbf5f54
DIST notmuch-0.25.2.tar.gz 882672 BLAKE2B 8bd90b87cf60a1eac8c331c4d67cfc511db91b5009c051fdf7d2612560ffaf11f1c51ca171f12f1cd9145ffa25ef402a5b2c72ad8efc4c22d68107ad31bb7d16 SHA512 5ee7bded69cbcc980e23f1e1562bf0cc9294c20bddcc3e442030c4f29373ecbbaef79144ad38470bfc97dac87f8dfb3bc7aee2d7eb974f6998f933369aa46006
+DIST notmuch-0.25.3.tar.gz 883151 BLAKE2B 511f93c310e8b82f1b629735cbe626ab1ba8eabf23245ba4aa4c936d4c5d868d9e6d5b0d626f16ce6087245a293cf1acd8bb2e2dd0639729af4b92d558c78051 SHA512 1c0fcfdeb7a7eddcd10a8175676679ef6985407732d5bcc15edd327d9985017696cef3287c0398c628a604ae3fbab5d222d71537e37265cf6a594b4914e4599a
DIST notmuch-0.25.tar.gz 882093 BLAKE2B ea0f5568ec0bf6a1d2c177468f4ec25fabfd416162c01a0d861e78164f15f2cc0176e1a012250a2a6bb45a6c7c2f6ffa651ad15776d44fed8ec191026b0f04c7 SHA512 5f4961818c8c0350e3fbbedd86f407a55fecf211971003a770d99ea2db89bb6b98c2294e114d6abff4d40985f506b7f4b52736a7ee5c78390eb4f2363a65c6f5
diff --git a/net-mail/notmuch/notmuch-0.25.3.ebuild b/net-mail/notmuch/notmuch-0.25.3.ebuild
new file mode 100644
index 000000000000..5c7f9d0860ec
--- /dev/null
+++ b/net-mail/notmuch/notmuch-0.25.3.ebuild
@@ -0,0 +1,208 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DISTUTILS_OPTIONAL=1
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit bash-completion-r1 elisp-common eutils flag-o-matic pax-utils \
+ distutils-r1 toolchain-funcs
+
+DESCRIPTION="Thread-based e-mail indexer, supporting quick search and tagging"
+HOMEPAGE="http://notmuchmail.org/"
+SRC_URI="${HOMEPAGE%/}/releases/${P}.tar.gz
+ test? ( ${HOMEPAGE%/}/releases/test-databases/database-v1.tar.xz )"
+
+LICENSE="GPL-3"
+# Sub-slot corresponds to major wersion of libnotmuch.so.X.Y. Bump of Y is
+# meant to be binary backward compatible.
+SLOT="0/5"
+KEYWORDS="~alpha ~amd64 ~x86 ~x64-solaris"
+REQUIRED_USE="
+ nmbug? ( python )
+ python? ( ${PYTHON_REQUIRED_USE} )
+ test? ( crypt emacs python valgrind )
+ "
+IUSE="crypt doc emacs mutt nmbug python test valgrind"
+
+CDEPEND="
+ !!<app-shells/bash-completion-1.9
+ >=dev-libs/glib-2.22:2
+ >=dev-libs/gmime-2.6.20-r2:2.6
+ >=dev-libs/xapian-1.2.7-r2:=
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ >=sys-libs/zlib-1.2.5.2
+ sys-libs/talloc
+ crypt? ( >=dev-libs/gmime-2.6.20-r2:2.6[smime] )
+ emacs? ( >=virtual/emacs-23 )
+ python? ( ${PYTHON_DEPS} )
+ "
+DEPEND="${CDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+ test? ( app-misc/dtach || ( >=app-editors/emacs-23[libxml2]
+ >=app-editors/emacs-vcs-23[libxml2] ) sys-devel/gdb
+ crypt? ( app-crypt/gnupg dev-libs/openssl ) )
+ valgrind? ( dev-util/valgrind )
+ "
+RDEPEND="${CDEPEND}
+ crypt? ( app-crypt/gnupg )
+ nmbug? ( dev-vcs/git )
+ mutt? ( dev-perl/File-Which dev-perl/Mail-Box dev-perl/MailTools
+ dev-perl/String-ShellQuote dev-perl/Term-ReadLine-Gnu
+ virtual/perl-Digest-SHA virtual/perl-File-Path virtual/perl-Getopt-Long
+ virtual/perl-Pod-Parser )
+ "
+
+DOCS=( AUTHORS NEWS README )
+SITEFILE="50${PN}-gentoo.el"
+MY_LD_LIBRARY_PATH="${WORKDIR}/${P}/lib"
+
+bindings() {
+ local ret=0
+
+ if use $1; then
+ pushd bindings/$1 || die
+ shift
+ "$@"
+ ret=$?
+ popd || die
+ fi
+
+ return $ret
+}
+
+pkg_pretend() {
+ if has_version '<net-mail/notmuch-0.18'; then
+ ewarn
+ ewarn "There are few not backward compatible changes between"
+ ewarn "<notmuch-0.18 and >=notmuch-0.18. See NEWS file"
+ ewarn "(0.18 section) for details before first use!"
+ ewarn
+ fi
+}
+
+pkg_setup() {
+ if use emacs; then
+ elisp-need-emacs 23 || die "Emacs version too low"
+ fi
+}
+
+src_unpack() {
+ unpack "${P}".tar.gz
+ if use test; then
+ mkdir -p "${S}"/test/test-databases || die
+ cp "${DISTDIR}"/database-v1.tar.xz "${S}"/test/test-databases/ || die
+ fi
+}
+
+src_prepare() {
+ default
+
+ bindings python distutils-r1_src_prepare
+ bindings python mv README README-python || die
+ mv contrib/notmuch-mutt/README contrib/notmuch-mutt/README-mutt || die
+
+ # assure that new Makefile.config will be generated
+ rm -f Makefile.config || die
+
+ if use test; then
+ append-cflags -g
+ append-cxxflags -g
+ fi
+
+ [[ ${CHOST} == *-solaris* ]] && append-ldflags -lnsl -lsocket
+}
+
+src_configure() {
+ local myeconfargs=(
+ --bashcompletiondir="$(get_bashcompdir)"
+ --emacslispdir="${EPREFIX}/${SITELISP}/${PN}"
+ --emacsetcdir="${EPREFIX}/${SITEETC}/${PN}"
+ --without-desktop
+ --without-ruby
+ --zshcompletiondir="${EPREFIX}/usr/share/zsh/site-functions"
+ $(use_with emacs)
+ $(use_with doc api-docs)
+ )
+ tc-export CC CXX
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ V=1 default
+ bindings python distutils-r1_src_compile
+
+ if use mutt; then
+ pushd contrib/notmuch-mutt || die
+ emake notmuch-mutt.1
+ popd || die
+ fi
+
+ if use doc; then
+ pydocs() {
+ pushd docs || die
+ emake html
+ rm -r html/_sources || die
+ rm html/{objects.inv,.buildinfo} || die
+ mkdir -p ../html && mv html ../html/python || die
+ popd || die
+ }
+ LD_LIBRARY_PATH="${MY_LD_LIBRARY_PATH}" bindings python pydocs
+ fi
+}
+
+src_test() {
+ pax-mark -m notmuch
+ LD_LIBRARY_PATH="${MY_LD_LIBRARY_PATH}" V=1 default
+ pax-mark -ze notmuch
+}
+
+src_install() {
+ default
+
+ if use emacs; then
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ fi
+
+ if use nmbug; then
+ dobin devel/nmbug/nmbug
+ dobin devel/nmbug/notmuch-report
+ fi
+
+ if use mutt; then
+ pushd contrib/notmuch-mutt || die
+ dobin notmuch-mutt
+ doman notmuch-mutt.1
+ insinto /etc/mutt
+ doins notmuch-mutt.rc
+ dodoc README-mutt
+ popd || die
+ fi
+
+ DOCS="" bindings python distutils-r1_src_install
+ use doc && bindings python dodoc -r html
+}
+
+pkg_preinst() {
+ if use mutt && ! [[ -e ${ROOT}/etc/mutt/notmuch-mutt.rc ]]; then
+ elog "To enable notmuch support in mutt, add the following line into"
+ elog "your mutt config file, please:"
+ elog ""
+ elog " source /etc/mutt/notmuch-mutt.rc"
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+
+ if has_version '<dev-libs/xapian-1.4'; then
+ elog "Regular expression searches supported for from: and subject:"
+ elog "require >=dev-libs/xapian-1.4."
+ fi
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}