summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-mail/libdbx
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-mail/libdbx')
-rw-r--r--net-mail/libdbx/Manifest1
-rw-r--r--net-mail/libdbx/files/bad_c.patch41
-rw-r--r--net-mail/libdbx/libdbx-1.0.3.ebuild32
-rw-r--r--net-mail/libdbx/metadata.xml10
4 files changed, 84 insertions, 0 deletions
diff --git a/net-mail/libdbx/Manifest b/net-mail/libdbx/Manifest
new file mode 100644
index 000000000000..f1df24288480
--- /dev/null
+++ b/net-mail/libdbx/Manifest
@@ -0,0 +1 @@
+DIST libdbx_1.0.3.tgz 24927 SHA256 eb2a6913a9f338164b2b62a9955da974ad44c94d8bb5e7cd68e4cd6ec175a636 SHA512 619f7cb25d5742066be6f2addbd06e433502c45489f973c628ae5d26758fc9ce1185185ae48da0de30d927eae8cbc610f775e0af182b10e72ecf5619ae79ba80 WHIRLPOOL 3f2abab7dd9195978a75412b798702e4ac6460156981e03938be054c78d146404ebb4b90f0e43a6121c7b79c5a59f7fc9f257b18c85cac078f91dd5de26f0018
diff --git a/net-mail/libdbx/files/bad_c.patch b/net-mail/libdbx/files/bad_c.patch
new file mode 100644
index 000000000000..1f7dc6d8ba03
--- /dev/null
+++ b/net-mail/libdbx/files/bad_c.patch
@@ -0,0 +1,41 @@
+diff -ru libdbx_1.0.3/libdbx.c libdbx_1.0.3-new/libdbx.c
+--- libdbx_1.0.3/libdbx.c 2002-10-05 15:07:36.000000000 +0200
++++ libdbx_1.0.3-new/libdbx.c 2006-09-20 08:53:46.000000000 +0200
+@@ -485,11 +485,11 @@
+ switch (blockp.type) {
+ case 0x01: //pointer to flag
+ email->flag = 0;
+- ((int*)bufx) = &(email->flag);
++ bufx = (char **)&(email->flag);
+ readtype = CHAR_TYPE;
+ break;
+ case 0x04: //pointer to dataptr
+- ((int*)bufx) = &(email->data_offset);
++ bufx = (char **)&(email->data_offset);
+ readtype = INT_TYPE;
+ break;
+ case 0x05: //asciiz string of subject (without RE: or FWD: etc...)
+@@ -521,7 +521,7 @@
+ readtype = STRING_TYPE;
+ break;
+ case 0x12: //date - of what i'm not sure. It is in a win32 FILETIME structure. needs converting to something
+- ((struct FILETIME*)bufx) = &(email->date);
++ bufx = (char **)&(email->date);
+ readtype = W32FT_TYPE;
+ break;
+ case 0x13: //recipient's name
+Only in libdbx_1.0.3-new: libdbx.o
+Only in libdbx_1.0.3-new: readdbx
+diff -ru libdbx_1.0.3/readdbx.c libdbx_1.0.3-new/readdbx.c
+--- libdbx_1.0.3/readdbx.c 2002-10-05 15:20:25.000000000 +0200
++++ libdbx_1.0.3-new/readdbx.c 2006-09-20 08:54:10.000000000 +0200
+@@ -19,6 +19,7 @@
+ #include <getopt.h>
+ #include <time.h>
+ #include <string.h>
++#include <stdlib.h>
+
+ #include "libdbx.h"
+ #include "common.h"
+Only in libdbx_1.0.3-new: readoe
+Files libdbx_1.0.3/timeconv.o and libdbx_1.0.3-new/timeconv.o differ
diff --git a/net-mail/libdbx/libdbx-1.0.3.ebuild b/net-mail/libdbx/libdbx-1.0.3.ebuild
new file mode 100644
index 000000000000..aa30a37f8628
--- /dev/null
+++ b/net-mail/libdbx/libdbx-1.0.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+MY_PN="libdbx"
+MYFILE="${MY_PN}_${PV}.tgz"
+
+DESCRIPTION="Tools and library for reading Outlook Express mailboxes (.dbx format)"
+HOMEPAGE="http://sourceforge.net/projects/ol2mbox"
+SRC_URI="mirror://sourceforge/ol2mbox/${MYFILE}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_PN}_${PV}"
+
+src_prepare() {
+ epatch "${FILESDIR}/bad_c.patch"
+ sed -i -e 's/-g/$(CFLAGS) $(LDFLAGS)/;s|gcc|$(CC)|g' Makefile || die
+ tc-export CC
+}
+
+src_install() {
+ dobin readoe readdbx
+ dodoc README* AUTHORS FILE-FORMAT
+}
diff --git a/net-mail/libdbx/metadata.xml b/net-mail/libdbx/metadata.xml
new file mode 100644
index 000000000000..0d3d6f9e04e6
--- /dev/null
+++ b/net-mail/libdbx/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">ol2mbox</remote-id>
+ </upstream>
+</pkgmetadata>