summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2019-08-16 19:18:02 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2019-08-16 19:59:51 -0700
commit7078f6b6e76e8e7e0f4a42601e845e9c84723b28 (patch)
tree31ebb70e88f0267af68a76e578fc15fa6ee459d4 /net-libs/grpc
parentnet-libs/grpc: bump to 1.23.0 (diff)
downloadgentoo-7078f6b6e76e8e7e0f4a42601e845e9c84723b28.tar.gz
gentoo-7078f6b6e76e8e7e0f4a42601e845e9c84723b28.tar.bz2
gentoo-7078f6b6e76e8e7e0f4a42601e845e9c84723b28.zip
net-libs/grpc: bump to 1.22.1
Bug: https://bugs.gentoo.org/692012 Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'net-libs/grpc')
-rw-r--r--net-libs/grpc/Manifest1
-rw-r--r--net-libs/grpc/grpc-1.22.1.ebuild113
2 files changed, 114 insertions, 0 deletions
diff --git a/net-libs/grpc/Manifest b/net-libs/grpc/Manifest
index e210b147a9e4..8c89bc920fad 100644
--- a/net-libs/grpc/Manifest
+++ b/net-libs/grpc/Manifest
@@ -5,4 +5,5 @@ DIST grpc-1.19.0.tar.gz 14793251 BLAKE2B b3a3db91f6c54126a51e27bd474d05bc672c5f7
DIST grpc-1.20.1.tar.gz 14930355 BLAKE2B 5b1bf2250d2b052498cfad9fc96134fd9b0065c98d73957427347aff4fe170f9a3d323c9f8797311c570a25bd9ff79f80da610e32b638c6409d2cd5dfbeb4eef SHA512 e0dd0318d2b4ec07e0eafffa218938d91b1440c5053a557460ea7fceaab3d76f0cccc1d595abe7de9fa79f068b71cfbc5a28a3b688bc9c1e2737086928149583
DIST grpc-1.21.1.tar.gz 15043553 BLAKE2B bed23af6606a69eb02a033d5dd6d92e3e080cc68ddae3c700872b8036cab594fd79c2396eb4ac84df2c5ea9eaf5ec0401d820667a7de0e9e2b376c0df4d4e9c5 SHA512 b9ea81a97416d9c1ef4d49e5f222f309b00d383f643f3bf342b6ad97f88e08e212e19db75e4a74fc5c23799dbe76dd0a9d6d4c9310e8cb1e007622a78d7a7114
DIST grpc-1.22.0.tar.gz 15082718 BLAKE2B 679be0488fc02441d5ba555c9150532e6ceb00bbaee9fe8b22881bef8ab713f45f96283f123576738285cfe8d358eb458cac9252bac7766cfd8ee5ac6e97fda9 SHA512 e8181f01bc44dc7e7a9e8c74c0a9c3f25960bb9c88c239e7c75764105ca24ac173bab663130fb6349c7fa43cd57f35dd7927a369482b1e6a73224cb2174bd336
+DIST grpc-1.22.1.tar.gz 15083781 BLAKE2B 5f1bc2fc638cfa2f97df9dfba3c927ae0c7871b9e56f8012795000c30f20fa4d5c1bad37d117cf8ea54fb372b8b02702a866c027c6e0a467f276a752ee9d17c6 SHA512 086ceb7a4fc1439bd23a2cab8c90ba2542491d5a9c278a0ff6e1b3ad623cf7725b2a7310bb793d9b36882bd9394d02a3616331ac26c78d822e68b305c2ae27f6
DIST grpc-1.23.0.tar.gz 15212436 BLAKE2B 119a62e6573a1c7785934f7752d9bf2fc0f503a268e439ce143d6730994e3fc154ffd558a2fb3776a77f5f36798baac334f50d1c612ae5564c3c2f110df8b42c SHA512 4770651bd73b71735152155327c44d59125442b405157ffea8fb80b6f16406dd388474394e44ef620e2a777018121988a3a7a552a42141650d7cac263ab499a0
diff --git a/net-libs/grpc/grpc-1.22.1.ebuild b/net-libs/grpc/grpc-1.22.1.ebuild
new file mode 100644
index 000000000000..74504ed85626
--- /dev/null
+++ b/net-libs/grpc/grpc-1.22.1.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic toolchain-funcs
+
+MY_PV="${PV//_pre/-pre}"
+
+DESCRIPTION="Modern open source high performance RPC framework"
+HOMEPAGE="https://www.grpc.io"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples doc perftools systemtap static-libs"
+
+DEPEND="
+ >=dev-libs/openssl-1.0.2:0=[-bindist]
+ >=dev-libs/protobuf-3.7.0:=
+ >=net-dns/c-ares-1.15.0:=
+ sys-libs/zlib:=
+ perftools? ( dev-util/google-perftools:= )
+ systemtap? ( dev-util/systemtap )
+"
+
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+# requires network
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}/grpc-1.21.0-fix-host-ar-handling.patch"
+ "${FILESDIR}/grpc-1.3.0-Don-t-run-ldconfig.patch"
+ "${FILESDIR}/grpc-1.11.0-pkgconfig-libdir.patch"
+ "${FILESDIR}/grpc-1.22.0-cxx_arg_list_too_long_forloop.patch" # https://github.com/grpc/grpc/issues/14844
+ "${FILESDIR}/grpc-1.22.1-glibc-2.30-compat.patch" # https://github.com/grpc/grpc/pull/18950
+)
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_prepare() {
+ rm -r third_party/cares || die
+ sed -i 's:-Werror::g' Makefile || die
+ sed -i 's@$(prefix)/lib@$(prefix)/$(INSTALL_LIBDIR)@g' Makefile || die "fix libdir"
+
+ default
+}
+
+src_compile() {
+ tc-export CC CXX PKG_CONFIG
+
+ local myemakeargs=(
+ V=1
+ prefix=/usr
+ INSTALL_LIBDIR="$(get_libdir)"
+ AR="$(tc-getAR)"
+ AROPTS="rcs"
+ CFLAGS="${CFLAGS}"
+ CXXFLAGS="${CXXFLAGS}"
+ LD="${CC}"
+ LDXX="${CXX}"
+ STRIP=/bin/true
+ HOST_AR="$(tc-getBUILD_AR)"
+ HOST_CC="$(tc-getBUILD_CC)"
+ HOST_CXX="$(tc-getBUILD_CXX)"
+ HOST_LD="$(tc-getBUILD_CC)"
+ HOST_LDXX="$(tc-getBUILD_CXX)"
+ HAS_SYSTEM_PERFTOOLS="$(usex perftools true false)"
+ HAS_SYSTEMTAP="$(usex systemtap true false)"
+ )
+
+ emake "${myemakeargs[@]}"
+}
+
+src_install() {
+ local myemakeargs=(
+ V=1
+ prefix="${ED}"/usr
+ INSTALL_LIBDIR="$(get_libdir)"
+ STRIP=/bin/true
+ )
+
+ emake "${myemakeargs[@]}" install
+
+ use static-libs || find "${ED}" -name '*.a' -delete
+
+ if use examples; then
+ find examples -name '.gitignore' -delete || die
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ if use doc; then
+ find doc -name '.gitignore' -delete || die
+ local DOCS=( AUTHORS CONCEPTS.md README.md TROUBLESHOOTING.md doc/. )
+ fi
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ local v
+ for v in ${REPLACING_VERSIONS}; do
+ if ver_test "${v}" -lt 1.16.0; then
+ ewarn "python bindings and tools moved to separate independent packages"
+ ewarn "check dev-python/grpcio and dev-python/grpcio-tools"
+ fi
+ done
+
+}