summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2022-09-05 21:05:18 +0800
committerYixun Lan <dlan@gentoo.org>2022-09-05 21:07:56 +0800
commitb98459dc3ee57409b0f159424a6529f306b863b8 (patch)
tree00f1267c7f8a56466a61ff49aaf42c9d3f73cd4f /net-dns
parentdev-python/tpm2-pytss: drop 1.1.0 (diff)
downloadgentoo-b98459dc3ee57409b0f159424a6529f306b863b8.tar.gz
gentoo-b98459dc3ee57409b0f159424a6529f306b863b8.tar.bz2
gentoo-b98459dc3ee57409b0f159424a6529f306b863b8.zip
net-dns/smartdns: add 37.2
Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/smartdns/Manifest1
-rw-r--r--net-dns/smartdns/smartdns-37.2.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/net-dns/smartdns/Manifest b/net-dns/smartdns/Manifest
index 5ff2c1cde20d..498ecd39dd26 100644
--- a/net-dns/smartdns/Manifest
+++ b/net-dns/smartdns/Manifest
@@ -1,2 +1,3 @@
DIST smartdns-36.1.tar.gz 499257 BLAKE2B c0bca0b8751afd67d7628d993f1093fb95c0864d153e65ebb31d0f9ccf76c7581f98a7fc16cf503cfa83f4d3e9b05e7c21818f34fa34ce770e9e0f0c3eced921 SHA512 88da539f12351bfef256e93d851a08247699ed2f08724abd5d0cc770a6b0475e0540d2aef6f43524edc48cccd9f58db3ad4c68561b26812bf8863b543748c549
+DIST smartdns-37.2.tar.gz 518486 BLAKE2B 3e7855e91b87b2daa5df3e7f9759ed0778afb7326a3649363da2aac899d8f8ada0b95e5ef6296e2d2295e665ea5ae6bf2a88d4d860f432eb82e5e1aff32bbc8e SHA512 16276cc2d1922e6f8657aa86a7bfe6b05d35cd0663bb6934620b5cc45db614594341cc6fa3acfa7d3d59fdd262b56f3bdc0839d97ffde6540c05c54d5c7a40d8
DIST smartdns-37.tar.gz 517246 BLAKE2B c39e46016eeee4c5ecf6bce35a40588f1680ac07bfc70c8beb035bf1e253764c93aead0aa6673246bd52cf42f34c48ec44ab139d76d4c35069675f689d408efc SHA512 469c0d8ed382dce11abc6ac82cc7cff4f88194bac5d32b51afd6c7be10452f20d00eed0e296aac57073ad6624c6441c24d89bc304b3e3c706b214c1a019b9bd8
diff --git a/net-dns/smartdns/smartdns-37.2.ebuild b/net-dns/smartdns/smartdns-37.2.ebuild
new file mode 100644
index 000000000000..b3addca60631
--- /dev/null
+++ b/net-dns/smartdns/smartdns-37.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit systemd
+DESCRIPTION="A local DNS server returns the fastest access results"
+HOMEPAGE="https://github.com/pymumu/smartdns"
+SRC_URI="https://github.com/pymumu/smartdns/archive/refs/tags/Release${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="dev-libs/openssl:0="
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+S="${WORKDIR}/${PN}-Release${PV}"
+
+src_prepare() {
+ default
+ sed -i -e "/install .*default /d" \
+ -e "/install .*init.d /d" Makefile || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" \
+ SYSTEMDSYSTEMUNITDIR="$(systemd_get_systemunitdir)" install
+
+ newconfd "${FILESDIR}"/smartdns.confd smartdns
+ newinitd "${FILESDIR}"/smartdns.initd smartdns
+}