summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-04-12 20:31:50 +0200
committerMichał Górny <mgorny@gentoo.org>2018-04-12 21:12:45 +0200
commite4cb205cd01fdf98d5f8cdb5b304a03229fc7828 (patch)
treef8a4df4a1bf5a92918335d72f4e6c7a281fd9536 /media-video
parentdev-python/pyblake2: Bump to 1.1.2 (big endian fixes) (diff)
downloadgentoo-e4cb205cd01fdf98d5f8cdb5b304a03229fc7828.tar.gz
gentoo-e4cb205cd01fdf98d5f8cdb5b304a03229fc7828.tar.bz2
gentoo-e4cb205cd01fdf98d5f8cdb5b304a03229fc7828.zip
media-video/parole: Bump to 1.0.1 (translation update)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/parole/Manifest1
-rw-r--r--media-video/parole/parole-1.0.1.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/media-video/parole/Manifest b/media-video/parole/Manifest
index 5e741ede83ac..38713eef7bf8 100644
--- a/media-video/parole/Manifest
+++ b/media-video/parole/Manifest
@@ -1,2 +1,3 @@
DIST parole-0.8.1.tar.bz2 814827 BLAKE2B 54c6753da5f9e6e6eef70bfbe13dd6496687fb35905ac8222a8ab96d3a46bc2f718a5d87dc44abec2c15cfde503f839960b0bcb51c8a58b5c978df830eec5207 SHA512 73c27022331828adb7b5805245ce97f03f4848c569125529436e82651da61e28f4d4a834468d6e4c165754f2fd9664eded9a7e15fc86f067d9b2c7c54afff3ee
DIST parole-1.0.0.tar.bz2 900499 BLAKE2B d6a1eb21846426781a712f33b7cf8f412b17b9a3e02b1ef15b6ff742687efc70a3e3f0ae8124ed2226a1cf00022c7ef0650c8e1c1b6e3279b111891e8c3e651e SHA512 0581fed93d2a09a3d9ec9cf1bb68a298ccd47676b22d0824495136ee9d785290b8465af8c12b5ecd34a46936f7433bf96dd559e6252a8f1af46c0e2f9256c864
+DIST parole-1.0.1.tar.bz2 903754 BLAKE2B 2bd8a8892c04bc145d7ba0bc08c29ad1f9c4507cce533d554952553e46c408e9f293a19820790541d0a494052ac6024d415bfef4864fc09b8d851664688ace3e SHA512 026ece62e6a8175976e7ce218edbd6955a0cdb5074996adad5bed3e536f90108e4d1106f22edcb06d213fb09dd47b04f81bff94f4534710b61f0f53cb0395f72
diff --git a/media-video/parole/parole-1.0.1.ebuild b/media-video/parole/parole-1.0.1.ebuild
new file mode 100644
index 000000000000..3fe9a536f39c
--- /dev/null
+++ b/media-video/parole/parole-1.0.1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils xdg-utils
+
+DESCRIPTION="A simple Xfce4 media player using GStreamer"
+HOMEPAGE="https://docs.xfce.org/apps/parole/start"
+SRC_URI="mirror://xfce/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~x86"
+IUSE="clutter libnotify taglib"
+
+COMMON_DEPEND=">=dev-libs/dbus-glib-0.100:=
+ >=dev-libs/glib-2.32:2=
+ media-libs/gstreamer:1.0=
+ media-libs/gst-plugins-base:1.0=
+ sys-apps/dbus:0=
+ >=x11-libs/gtk+-3.20:3=
+ x11-libs/libX11:0=
+ >=xfce-base/libxfce4ui-4.11:0=[gtk3(+)]
+ >=xfce-base/libxfce4util-4.11:0=
+ >=xfce-base/xfconf-4.10:0=
+ clutter? (
+ >=media-libs/clutter-1.16.4:1.0=
+ >=media-libs/clutter-gtk-1.4.4:1.0=
+ <x11-libs/gtk+-3.22:3
+ )
+ libnotify? ( >=x11-libs/libnotify-0.7:0= )
+ taglib? ( >=media-libs/taglib-1.6:0= )"
+RDEPEND="${COMMON_DEPEND}
+ media-plugins/gst-plugins-meta:1.0"
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+ x11-proto/xproto"
+
+DOCS=( AUTHORS ChangeLog README THANKS TODO )
+
+src_configure() {
+ local myconf=(
+ $(use_enable clutter)
+ $(use_enable taglib)
+ $(use_enable libnotify notify-plugin)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+}