summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarlson2k (Evgeny Grin) <k2k@narod.ru>2021-01-13 11:04:14 +0300
committerSam James <sam@gentoo.org>2021-01-14 20:11:35 +0000
commit34d6be2caa78526ef19677318e118465b881f62d (patch)
treea46bb8aca4b4cc789be00851ce33b6d0e3476893 /media-video
parentmedia-video/libva-utils: fixed test in portage sandbox in 2.10.0 (diff)
downloadgentoo-34d6be2caa78526ef19677318e118465b881f62d.tar.gz
gentoo-34d6be2caa78526ef19677318e118465b881f62d.tar.bz2
gentoo-34d6be2caa78526ef19677318e118465b881f62d.zip
media-video/libva-utils: fixed test in portage sandbox in 2.9.1
Closes: https://bugs.gentoo.org/758620 Signed-off-by: Karlson2k (Evgeny Grin) <k2k@narod.ru> Closes: https://github.com/gentoo/gentoo/pull/19048 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/libva-utils/Manifest1
-rw-r--r--media-video/libva-utils/libva-utils-2.9.1-r1.ebuild60
2 files changed, 23 insertions, 38 deletions
diff --git a/media-video/libva-utils/Manifest b/media-video/libva-utils/Manifest
index 20b39622184e..abdad94026d9 100644
--- a/media-video/libva-utils/Manifest
+++ b/media-video/libva-utils/Manifest
@@ -1,5 +1,4 @@
DIST libva-utils-2.4.0.tar.bz2 1030271 BLAKE2B b57947f9bd63f34b27a403484ae6b66e750f854dd87c8448afb3d361581d83b20a5ffd8d7e22c9dbf5fae6f7ff3fd62d70cc248b29a862066ff10928629e4d11 SHA512 c5c674179ed589968fd296a7e33dd57a3476c237d8e15258938b364051d501e156c22b41b98fe59d6bc36805495a934dee602ec9e9bb5350c72aa65d3d300ff6
DIST libva-utils-2.8.0.tar.bz2 1037112 BLAKE2B 9168d7d489e1574d970e9e3a270946de522a4063b80c4cafe38cc6917b99deb6394570592d3ed29a0ff7b92f819b9bbc9eb2a8f3b70077625a2714f70ee1959e SHA512 b3412349234ad2923953296674926ee7cb33c43ce17df8942f751789f0208064a4557ca16e1a5878a4e1b35e5bbbd415a9c9f182ffb24e589ac4757e990576b5
-DIST libva-utils-2.9.1.tar.bz2 1037281 BLAKE2B 862b52ae8b1552e1150fadff9e45371e7065bf1c1fc9244a5ad0466a3109d56e9f3dd4d937f7474e6df2eaf806e93d520b1f2a986a0aa6bad7328f89d458706b SHA512 6573a2aa4844c10fd34fb5ed6edded33e15e65b7bd55d437da45a22dd5ef2116a3f137966433d986177705d544e6ea9a2a6582f49bb2eca6756970f341283d35
DIST libva-utils-2.9.1.tar.gz 1198337 BLAKE2B 58f5a6a537c68eed74aec5dc8f1c4b5a0431062d1d9803d8ccb1e5c3b534edf4f91288009d5940a0ddab49beeadae92bf361bec0bee8a3214f04f3c6767b0992 SHA512 39d79d4eed1fc0890fbf89d5689d4f01f704d3c71b4986e0eaf4c4a2f836cc36338d0a01630092a31b740588426398d0381eae1dc0302b0df94859d9161d8378
DIST libva-utils-2.10.0.tar.gz 1203536 BLAKE2B c7b51e07618204c55e992f57dd2d80b289d2edd7b4f526c3afaaec1081f5497ac86614e097bc14a1e79d380ca2c529359d02cee601502e292ca8f89073d5fdbb SHA512 2d44c5e3f52ff4ce8bfb206af95c4d790b6d31ec21f899f0ec9604391359f55de06c63b446e19cd8f0ea0c36ccb4ac7cc5ae7fe68361eb263c01454682d18402
diff --git a/media-video/libva-utils/libva-utils-2.9.1-r1.ebuild b/media-video/libva-utils/libva-utils-2.9.1-r1.ebuild
index 93c23cd9a5ca..7803d68b4896 100644
--- a/media-video/libva-utils/libva-utils-2.9.1-r1.ebuild
+++ b/media-video/libva-utils/libva-utils-2.9.1-r1.ebuild
@@ -3,29 +3,18 @@
EAPI=7
-if [[ ${PV} = *9999* ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/intel/libva-utils"
-fi
-
-if [[ ${PV} = 2.9.1 ]]; then
- AUTOCONFIGURED="true"
-else
- AUTOCONFIGURED="false"
-fi
-
-if ! ${AUTOCONFIGURED}; then
- inherit autotools
-fi
+inherit autotools
DESCRIPTION="Collection of utilities and tests for VA-API"
HOMEPAGE="https://01.org/linuxmedia/vaapi"
-if [[ ${PV} != *9999* ]] ; then
- if ${AUTOCONFIGURED}; then
- SRC_URI="https://github.com/intel/libva-utils/releases/download/${PV}/${P}.tar.bz2"
- else
- SRC_URI="https://github.com/intel/libva-utils/archive/${PV}.tar.gz -> ${P}.tar.gz"
- fi
+if [[ ${PV} = *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/intel/libva-utils"
+else
+ # Tarball with pre-built 'configure' not always available, portage use tarballs
+ # without pre-built 'configure' as they are always avaialbe upstream.
+ # SRC_URI="https://github.com/intel/libva-utils/releases/download/${PV}/${P}.tar.bz2"
+ SRC_URI="https://github.com/intel/libva-utils/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
fi
@@ -36,27 +25,29 @@ RESTRICT="!test? ( test )"
REQUIRED_USE="|| ( drm wayland X )"
-BDEPEND="
- virtual/pkgconfig
-"
-DEPEND="
- >=x11-libs/libva-2.9.0:=[drm?,wayland?,X?]
+BDEPEND="virtual/pkgconfig"
+
+if [[ ${PV} = *9999 ]] ; then
+ DEPEND="~x11-libs/libva-${PV}:=[drm?,wayland?,X?]"
+else
+ DEPEND=">=x11-libs/libva-$(ver_cut 1-2).0:=[drm?,wayland?,X?]"
+fi
+
+DEPEND+="
wayland? ( >=dev-libs/wayland-1.0.6 )
X? ( >=x11-libs/libX11-1.6.2 )
"
RDEPEND="${DEPEND}"
-DOCS=( NEWS )
+PATCHES=( "${FILESDIR}/${PN}-2.10.0_test_in_sandbox.patch" )
+
+# CONTRIBUTING.md and README.md are avaialbe only in .tar.gz tarballs and in git
+DOCS=( NEWS CONTRIBUTING.md README.md )
src_prepare() {
default
sed -e 's/-Werror//' -i test/Makefile.am || die
- if ${AUTOCONFIGURED}; then
- sed -e 's/-Werror//' -i test/Makefile.in || die
- touch ./configure || die
- else
- eautoreconf
- fi
+ eautoreconf
}
src_configure() {
@@ -68,8 +59,3 @@ src_configure() {
)
econf "${myeconfargs[@]}"
}
-
-src_install() {
- [[ ${PV} = *9999* ]] && DOCS+=( CONTRIBUTING.md README.md )
- default
-}