summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Freeman <rich0@gentoo.org>2019-12-22 21:39:09 -0500
committerRichard Freeman <rich0@gentoo.org>2019-12-22 21:39:30 -0500
commitf1daa4d7f4e7b3965086d3826d84a8bef483c3c2 (patch)
tree619b9b81798cda66bd4044a52b7214bc8cd837d7 /media-radio
parentsci-libs/tensorflow: bump 2.1.0_rc1 (diff)
downloadgentoo-f1daa4d7f4e7b3965086d3826d84a8bef483c3c2.tar.gz
gentoo-f1daa4d7f4e7b3965086d3826d84a8bef483c3c2.tar.bz2
gentoo-f1daa4d7f4e7b3965086d3826d84a8bef483c3c2.zip
media-radio/js8call: bump
Requires patch for current release hamlib. May need to revist for hamlib-3.4. Dep adjusted anticipating this until the new version can be released. Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Richard Freeman <rich0@gentoo.org>
Diffstat (limited to 'media-radio')
-rw-r--r--media-radio/js8call/Manifest1
-rw-r--r--media-radio/js8call/files/js8call-2.1.0-hamlib-type.patch27
-rw-r--r--media-radio/js8call/js8call-2.1.0.ebuild41
3 files changed, 69 insertions, 0 deletions
diff --git a/media-radio/js8call/Manifest b/media-radio/js8call/Manifest
index a57fd58c082b..cf836677f65f 100644
--- a/media-radio/js8call/Manifest
+++ b/media-radio/js8call/Manifest
@@ -1,3 +1,4 @@
DIST js8call-1.0.0.tar.bz2 15923224 BLAKE2B 646fd869e6029d57dfd1d9762ede2407e18a18170088df65d1b16a581709065cf45edb23533b9c89193b01a85ec326638efc99202489db54455298a5033696de SHA512 64f24821c9ffd86123ede2baac46bcefd33b5dc5e0496cd44e594e79706ec2f3fdde5ce13c379addbf2bded3e392a1f0fc0f2df0298ce57a22e434a6ab6a1e7a
DIST js8call-1.1.0.tar.bz2 15993553 BLAKE2B 3538f746b175d0623169d2a13b5c26b334561f604fa25c8dddc15ee2a41319df8bb4c0a905be6340d4d18d87bffd8bd4e9a4eb9ceec3310f33aa22005c0e1c19 SHA512 992408408888a59174811c30fcc07065bcb5e459c355955a59e638ca27da27c2c25df8fa7579ce1c322a76f12780c58821df9fc781cde2cb2b2851312d188787
DIST js8call-2.0.0.tar.bz2 14434190 BLAKE2B 2d016c93175fe41cd4c24b57fc0a6c65ff5d5630aff68aac4e3e941570f315abe9f083f1686cb95e49d90ea41ac82752fcdd37041727e95820d34bcd0e82e2b1 SHA512 58566d4e6009339ef9a1459bdf2902748200b7a002c8be22067ec97eae16cc42465001e7084ebc00b1e406ae47fe45092226e1c6568253a1bbf95c65f040ab75
+DIST js8call-2.1.0.tar.bz2 14432328 BLAKE2B 3f48be58905cf05af8230b715956ecfec71fd792fafb029cba84c799e51bb1189e158c16ef05bd8959572778aad556a11b0896647a47cc1e6b10ddd48bd033cd SHA512 0edfbc8cbbe3df551d7dc97c7362100d2714e2d37934a053233ca8107247f7fdc67a36b59b1fe701154c9348f27171ddab9c21ffc763072d390431f9dd5382a0
diff --git a/media-radio/js8call/files/js8call-2.1.0-hamlib-type.patch b/media-radio/js8call/files/js8call-2.1.0-hamlib-type.patch
new file mode 100644
index 000000000000..5fc71b7f2940
--- /dev/null
+++ b/media-radio/js8call/files/js8call-2.1.0-hamlib-type.patch
@@ -0,0 +1,27 @@
+From af2ed2b67665a4bb891ffa01d45043bb197f06bf Mon Sep 17 00:00:00 2001
+From: Richard Freeman <rich0@gentoo.org>
+Date: Sun, 22 Dec 2019 21:26:27 -0500
+Subject: [PATCH] Revert "Updated hamlib interface to use new unsigned int for
+ vfo_t"
+
+This reverts commit 7728483481975bfe1527eab657cf636c4c3b9181.
+---
+ HamlibTransceiver.hpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/HamlibTransceiver.hpp b/HamlibTransceiver.hpp
+index 509fe4e..c8c0f74 100644
+--- a/HamlibTransceiver.hpp
++++ b/HamlibTransceiver.hpp
+@@ -14,7 +14,7 @@ extern "C"
+ {
+ typedef struct rig RIG;
+ struct rig_caps;
+- typedef unsigned int vfo_t;
++ typedef int vfo_t;
+ }
+
+ // hamlib transceiver and PTT mostly delegated directly to hamlib Rig class
+--
+2.24.1
+
diff --git a/media-radio/js8call/js8call-2.1.0.ebuild b/media-radio/js8call/js8call-2.1.0.ebuild
new file mode 100644
index 000000000000..d886436dd36d
--- /dev/null
+++ b/media-radio/js8call/js8call-2.1.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit cmake-utils vcs-snapshot
+
+MY_P=${P/_/-}
+
+DESCRIPTION="Weak signal ham radio communication"
+HOMEPAGE="https://groups.io/g/js8call"
+SRC_URI="https://bitbucket.org/widefido/js8call/get/v${PV}-ga.tar.bz2 -> ${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+RDEPEND="dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtconcurrent:5
+ dev-qt/qtserialport:5
+ dev-qt/qtprintsupport:5
+ virtual/libusb:1
+ media-libs/portaudio
+ sci-libs/fftw:3.0[threads,fortran]
+ virtual/fortran
+ app-text/asciidoc
+ <media-libs/hamlib-3.4
+ doc? ( dev-ruby/asciidoctor )"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-hamlib-type.patch" )
+
+src_install() {
+ cmake-utils_src_install
+ rm "${D}"/usr/bin/rigctl{,d}-local || die
+ rm "${D}"/usr/share/doc/JS8Call -R || die
+}