summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-05-06 16:28:45 +0200
committerDavid Seifert <soap@gentoo.org>2021-05-06 16:28:45 +0200
commitc86fda60404097d3c625dd1585e6a66a4dc10c10 (patch)
tree890c34f1595a1894e0a92ab07fdc1ffcd640a28d /media-libs/libheif
parentmail-client/neomutt: neomutt-20210205-r1 (diff)
downloadgentoo-c86fda60404097d3c625dd1585e6a66a4dc10c10.tar.gz
gentoo-c86fda60404097d3c625dd1585e6a66a4dc10c10.tar.bz2
gentoo-c86fda60404097d3c625dd1585e6a66a4dc10c10.zip
media-libs/libheif: Bump to 1.12.0
Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'media-libs/libheif')
-rw-r--r--media-libs/libheif/Manifest1
-rw-r--r--media-libs/libheif/libheif-1.12.0.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/media-libs/libheif/Manifest b/media-libs/libheif/Manifest
index f051ee799dee..17219957fbc0 100644
--- a/media-libs/libheif/Manifest
+++ b/media-libs/libheif/Manifest
@@ -1 +1,2 @@
DIST libheif-1.11.0.tar.gz 1680855 BLAKE2B a85ed643bd05cd59a34e9e42c0b8690fc779c06d01aa4925b177c1a36e7a4d11c9dfa798295c9b8215f45802e80119f2a8f5c3876103818c5436358416d97dd8 SHA512 1a5d54a09a5dc581a054052bac4299f7c96ca121650e9238312c426d5261247ce6af1840088b8717c5a53d212b7ec17bfaa109b9245abfaebf1603eaeb77b0ed
+DIST libheif-1.12.0.tar.gz 1684355 BLAKE2B 6d84678b39476f2d797d586c6dcaabc9a82351fe3bad536cd90edab16dabf91cbdcdb291195ff45061c7b0ad164748c53f87cbb2dc1e318b2cd458fcba74f644 SHA512 9e6f74dd52841a33b6021a1581ab28c56123d927caa7972acd284444e90888bbdae983b6d847d20eac7651dacea2193d27eb8df45928cb0774229ef8eea23294
diff --git a/media-libs/libheif/libheif-1.12.0.ebuild b/media-libs/libheif/libheif-1.12.0.ebuild
new file mode 100644
index 000000000000..05d7c5f68ed0
--- /dev/null
+++ b/media-libs/libheif/libheif-1.12.0.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools xdg multilib-minimal
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/strukturag/libheif.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/strukturag/libheif/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+
+DESCRIPTION="ISO/IEC 23008-12:2017 HEIF file format decoder and encoder"
+HOMEPAGE="https://github.com/strukturag/libheif"
+
+LICENSE="GPL-3"
+SLOT="0/1.12"
+IUSE="+aom gdk-pixbuf go libde265 rav1e test +threads x265"
+REQUIRED_USE="test? ( go libde265 )"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( dev-lang/go )"
+DEPEND="
+ media-libs/dav1d:=[${MULTILIB_USEDEP}]
+ media-libs/libpng:0=[${MULTILIB_USEDEP}]
+ sys-libs/zlib:=[${MULTILIB_USEDEP}]
+ virtual/jpeg:0=[${MULTILIB_USEDEP}]
+ aom? ( >=media-libs/libaom-2.0.0:=[${MULTILIB_USEDEP}] )
+ gdk-pixbuf? ( x11-libs/gdk-pixbuf[${MULTILIB_USEDEP}] )
+ go? ( dev-lang/go )
+ libde265? ( media-libs/libde265:=[${MULTILIB_USEDEP}] )
+ rav1e? ( media-video/rav1e:= )
+ x265? ( media-libs/x265:=[${MULTILIB_USEDEP}] )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+
+ sed -i -e 's:-Werror::' configure.ac || die
+
+ eautoreconf
+
+ # prevent "stat heif-test.go: no such file or directory"
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ export GO111MODULE=auto
+ local econf_args=(
+ --disable-static
+ $(multilib_is_native_abi && use go || echo --disable-go)
+ $(use_enable aom)
+ $(use_enable libde265)
+ $(use_enable gdk-pixbuf)
+ $(use_enable rav1e)
+ $(use_enable threads multithreading)
+ $(use_enable x265)
+ )
+ ECONF_SOURCE="${S}" econf "${econf_args[@]}"
+}
+
+multilib_src_test() {
+ default
+ emake -C go test
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${ED}" -name '*.la' -delete || die
+}