summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiogo Pereira <sir.suriv@gmail.com>2020-05-24 16:44:02 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-06-17 20:00:23 +0300
commit1cd0e93b33c417e6dd69847c15dad8741fd82952 (patch)
tree376b9e2228dd8567fd0e24681921b15169cd9a9a /media-gfx/img2pdf
parentsci-mathematics/rkward: KDE project takeover (diff)
downloadgentoo-1cd0e93b33c417e6dd69847c15dad8741fd82952.tar.gz
gentoo-1cd0e93b33c417e6dd69847c15dad8741fd82952.tar.bz2
gentoo-1cd0e93b33c417e6dd69847c15dad8741fd82952.zip
media-gfx/img2pdf: version bump to 0.3.6
- Remove dependency on dev-python/pdfrw Closes: https://bugs.gentoo.org/718690 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Diogo Pereira <sir.suriv@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/15955 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-gfx/img2pdf')
-rw-r--r--media-gfx/img2pdf/Manifest1
-rw-r--r--media-gfx/img2pdf/img2pdf-0.3.6.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/media-gfx/img2pdf/Manifest b/media-gfx/img2pdf/Manifest
index a13f819f5f27..c0670a09f7a9 100644
--- a/media-gfx/img2pdf/Manifest
+++ b/media-gfx/img2pdf/Manifest
@@ -1,2 +1,3 @@
DIST img2pdf-0.3.3.tar.gz 80523 BLAKE2B 39e372f1ab82d9f521cf2c512b173680afe6463dd041283b336af49c41b12d12261fe5947ad9f03d489b7898d3c8d161faedb2b3366cb75bd1bc0666f905f60c SHA512 234e0031d75727d2f5d2b82603bb447d9101ace81e604b6d5eb358d0b4681e209dbd737775b90b44096cf84239aac9e87e2369e0c6112a17f24ccbf10a20cdd5
DIST img2pdf-0.3.4.tar.gz 83729 BLAKE2B c595ca7eebfcb91cfe076822836ce07ec0036a510645aae54e495798765df91cddf5de292245c623b2e23918d7862271cdca5d7b8dd76573dc40d8ba7807865a SHA512 0e81e3ee06c62f0ee732b87776f6bc2d066ebce6c23dbcb85b2497518ba43fa3813b3e15f0c476c1203ae6d2b1f4f3e2f1b70215033dddb889fafd75b3671420
+DIST img2pdf-0.3.6.tar.gz 91006 BLAKE2B ad89b42be4613c30383770f336b07773bf13e87061fca61eb7d5e25d6489662fc2bae94d9a6d61d531a77f41b9e94492d0db1f32570f6d471fa9f8cb0816630d SHA512 2a9d31b9de52123941fd650123a483f4dc0757edda304da994353b5f3167bddbb25fa1ed8fededcf859c5d07b65b9c2d5185000949002a68dcae1e7bf0f1547d
diff --git a/media-gfx/img2pdf/img2pdf-0.3.6.ebuild b/media-gfx/img2pdf/img2pdf-0.3.6.ebuild
new file mode 100644
index 000000000000..612d1425962d
--- /dev/null
+++ b/media-gfx/img2pdf/img2pdf-0.3.6.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Losslessly convert raster images to PDF"
+HOMEPAGE="https://gitlab.mister-muffin.de/josch/img2pdf"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="test? ( dev-python/pillow[${PYTHON_USEDEP},tiff,zlib] )"
+RDEPEND="dev-python/pillow[${PYTHON_USEDEP}]"
+
+distutils_enable_tests setup.py