summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-07-10 23:22:14 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-07-10 23:23:45 +0200
commit98d7c17a5ef2d3ee26265dba57b6ec1b5178394e (patch)
tree0cbe0eaa199643633b50ed827e4ea1cbe29c0b7d /media-gfx/enblend
parentmedia-libs/vigra: Switch to cmake.eclass (diff)
downloadgentoo-98d7c17a5ef2d3ee26265dba57b6ec1b5178394e.tar.gz
gentoo-98d7c17a5ef2d3ee26265dba57b6ec1b5178394e.tar.bz2
gentoo-98d7c17a5ef2d3ee26265dba57b6ec1b5178394e.zip
media-gfx/enblend: Fix build with GCC-10
Thanks-to: Walter Hüttenmeyer <walter.huettenmeyer@gmail.com> Closes: https://bugs.gentoo.org/723306 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-gfx/enblend')
-rw-r--r--media-gfx/enblend/enblend-4.2.0_p20161007-r1.ebuild3
-rw-r--r--media-gfx/enblend/files/enblend-4.2.0_p20161007-gcc-10.patch16
2 files changed, 18 insertions, 1 deletions
diff --git a/media-gfx/enblend/enblend-4.2.0_p20161007-r1.ebuild b/media-gfx/enblend/enblend-4.2.0_p20161007-r1.ebuild
index 9049ae5c5e7b..b72cb407f8d9 100644
--- a/media-gfx/enblend/enblend-4.2.0_p20161007-r1.ebuild
+++ b/media-gfx/enblend/enblend-4.2.0_p20161007-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -49,6 +49,7 @@ DEPEND="${RDEPEND}
PATCHES=(
"${FILESDIR}"/${PN}-4.2-doc-install-dir-fix.patch
"${FILESDIR}"/${P}-cmake.patch
+ "${FILESDIR}"/${P}-gcc-10.patch
)
src_prepare() {
diff --git a/media-gfx/enblend/files/enblend-4.2.0_p20161007-gcc-10.patch b/media-gfx/enblend/files/enblend-4.2.0_p20161007-gcc-10.patch
new file mode 100644
index 000000000000..7203d6b667b1
--- /dev/null
+++ b/media-gfx/enblend/files/enblend-4.2.0_p20161007-gcc-10.patch
@@ -0,0 +1,16 @@
+Fix build with GCC-10.
+
+Thanks-to: Walter Hüttenmeyer
+Bug: https://bugs.gentoo.org/724988
+
+--- a/src/minimizer.cc 2016-09-24 11:29:40.000000000 +0200
++++ b/src/minimizer.cc 2020-05-24 13:09:58.199170984 +0200
+@@ -19,7 +19,7 @@
+ */
+
+ #include <gsl/gsl_errno.h>
+-
++#include <limits>
+ #include "minimizer.h"
+
+