summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-05-09 01:55:03 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-05-09 14:10:02 +0200
commit7e6ce0d94b697c794ca52c9defd4aeecccaa39c2 (patch)
treefeafb555d195e6166b11f2824507597f4a940d73 /kde-plasma/kwallet-pam
parentkde-plasma/ksysguard: 5.21.5 version bump (diff)
downloadgentoo-7e6ce0d94b697c794ca52c9defd4aeecccaa39c2.tar.gz
gentoo-7e6ce0d94b697c794ca52c9defd4aeecccaa39c2.tar.bz2
gentoo-7e6ce0d94b697c794ca52c9defd4aeecccaa39c2.zip
kde-plasma/kwallet-pam: 5.21.5 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/kwallet-pam')
-rw-r--r--kde-plasma/kwallet-pam/Manifest1
-rw-r--r--kde-plasma/kwallet-pam/kwallet-pam-5.21.5.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/kde-plasma/kwallet-pam/Manifest b/kde-plasma/kwallet-pam/Manifest
index fd7cd158b89e..4fb572f93dc9 100644
--- a/kde-plasma/kwallet-pam/Manifest
+++ b/kde-plasma/kwallet-pam/Manifest
@@ -1,2 +1,3 @@
DIST kwallet-pam-5.20.5.tar.xz 19812 BLAKE2B d0ad931e47a35b5589e9c34bce924f697446460bcfbfcceb4e3f0564182bbac822f13488dddc592f7b6a119d774b6176b86df8ddca55fb0c9423d0c7634fa9cc SHA512 5f728c2fbbcbfa7a2b50a2d9b60e557360b48d6a5958ce290ace3e2ae8c253b56f64178942f958d38e7e62e0baf1cad0ddb2aa28e11d145f3b507d58900dcb03
DIST kwallet-pam-5.21.4.tar.xz 19904 BLAKE2B 0d85f8e23240bbd2feb68216ce85e51bd2e91195d77cd3f281dac6534f6cc7b13665ee2fdb078d2d89af063f467084b5a9881ecdc7adc2a0b3eb6fd1b917d790 SHA512 48e3d9d268ca60bca3058eea33e035641ef3fb43c0faa342c96281404f4a829efe49fd0ec75a0476039fd21e18bf66eda14dcc0c3575032d000632e2e9c26d37
+DIST kwallet-pam-5.21.5.tar.xz 19916 BLAKE2B ee0efa7448f7f7d599e83d9a923909fe0de965aa48a8e505b984a5cb54d16c20b3f2f57efb83cd887545e23c3aa9ac4a70c14e9173fff263190c8de5c2c9449f SHA512 4dab0ac4500c6ec01fef71e2197e59afb39c318dfe1e5727832fed2137b5d961bb1aad9c52d356346794ac1dd9e9451f507032aab29028806d9c04c3c566738d
diff --git a/kde-plasma/kwallet-pam/kwallet-pam-5.21.5.ebuild b/kde-plasma/kwallet-pam/kwallet-pam-5.21.5.ebuild
new file mode 100644
index 000000000000..852aef5a0d46
--- /dev/null
+++ b/kde-plasma/kwallet-pam/kwallet-pam-5.21.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KFMIN=5.82.0
+PVCUT=$(ver_cut 1-3)
+inherit ecm kde.org
+
+DESCRIPTION="PAM module to not enter KWallet password again after login"
+
+LICENSE="LGPL-2.1"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-libs/libgcrypt:0=
+ >=kde-frameworks/kwallet-${KFMIN}:5
+ sys-libs/pam
+"
+RDEPEND="${DEPEND}
+ net-misc/socat
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_LIBDIR="/$(get_libdir)"
+ )
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+ elog "This package enables auto-unlocking of kde-frameworks/kwallet:5."
+ elog "See also: https://wiki.gentoo.org/wiki/KDE#KWallet_auto-unlocking"
+}