summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-04-16 21:09:25 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-04-16 21:50:23 +0200
commitc67cc3561d89a47f91e21d2f54dca9c469c7a91d (patch)
tree31f02cea3a2d17d65448ff9729d83984f75975ab /kde-plasma/kinfocenter
parentkde-plasma/kglobalacceld: add 6.0.4 (diff)
downloadgentoo-c67cc3561d89a47f91e21d2f54dca9c469c7a91d.tar.gz
gentoo-c67cc3561d89a47f91e21d2f54dca9c469c7a91d.tar.bz2
gentoo-c67cc3561d89a47f91e21d2f54dca9c469c7a91d.zip
kde-plasma/kinfocenter: add 6.0.4
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/kinfocenter')
-rw-r--r--kde-plasma/kinfocenter/Manifest1
-rw-r--r--kde-plasma/kinfocenter/kinfocenter-6.0.4.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/kde-plasma/kinfocenter/Manifest b/kde-plasma/kinfocenter/Manifest
index 3ae1961d6db5..01414e1fea92 100644
--- a/kde-plasma/kinfocenter/Manifest
+++ b/kde-plasma/kinfocenter/Manifest
@@ -1,3 +1,4 @@
DIST glogo-small.png 24583 BLAKE2B 0af2ceae708e56f217120e5d8b880fb71401e3761ab26c4af5e74c0622368aa4e34b05160fae15fbfbbc832077810ab5c1e424826632748299fd22997cbe665c SHA512 648be463ec3812a2edcdab54d7a230bf2bd7e6895f4ffe72321d8fca28a5e1e0980f6e3b9a32f369c8369943ceb802a65a94b9dad820dcf2c81d4581d814cb48
DIST kinfocenter-5.27.11.tar.xz 1018276 BLAKE2B 921832d3c52abfe35d3b77f34161c630d54c6fe8675eac6b2dcc343ab21b7c30b501216c9762aa90a8f5bfc036d2d8859a7419478ec38a85afcbf90315788cc1 SHA512 24a9df9fb28637e39293669569e4be896956ecfc3a27719821a1498f541aed220e7ebcd0e1a0b63051562690a9400b7fefc9c1217763c87009745e886573205e
DIST kinfocenter-6.0.3.tar.xz 830548 BLAKE2B 2ba9fd5554597c21fe38671fd6c721ad6dfbc8fa6069052b29b4f6878ffafd5acb953fabb8436e782860b593691e2b7d59e04fd86856ad2a226ac625398aef84 SHA512 e34736aeae47de1814bfcbf073cd8814016c9d1dda1de440be14918e9dd44e0d8d00ec8a589a1ddb7d10e31421a27159b4bf05634bba2597f11e6f7d76ac3ef3
+DIST kinfocenter-6.0.4.tar.xz 830724 BLAKE2B a6a9ac461d30f3231d989acb282ddfdabeffa3a2b90793c6f4048634615c6b4affe2494f9c465f6786999a154adac8fd18b76a996b85104d1a9606234c1ab336 SHA512 1c3214d844576a4bcfff49e05d316031688fb76355e302097e68140ffbf20feb33d47b0c3a1db067dc63bf0944e5d49b8f3cafd9cbf6e43aaf8fc9ace81b38a4
diff --git a/kde-plasma/kinfocenter/kinfocenter-6.0.4.ebuild b/kde-plasma/kinfocenter/kinfocenter-6.0.4.ebuild
new file mode 100644
index 000000000000..6514f41e79f6
--- /dev/null
+++ b/kde-plasma/kinfocenter/kinfocenter-6.0.4.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="forceoptional"
+KFMIN=6.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=6.6.2
+inherit ecm plasma.kde.org optfeature
+
+DESCRIPTION="Utility providing information about the computer hardware"
+HOMEPAGE="https://userbase.kde.org/KInfoCenter"
+SRC_URI+=" https://www.gentoo.org/assets/img/logo/gentoo-3d-small.png -> glogo-small.png"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="6"
+KEYWORDS="~amd64"
+IUSE="gles2-only usb"
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[dbus,gles2-only=,gui,widgets]
+ >=dev-qt/qtdeclarative-${QTMIN}:6
+ >=kde-frameworks/kauth-${KFMIN}:6
+ >=kde-frameworks/kcmutils-${KFMIN}:6
+ >=kde-frameworks/kconfig-${KFMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kio-${KFMIN}:6
+ >=kde-frameworks/kservice-${KFMIN}:6
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:6
+ >=kde-frameworks/solid-${KFMIN}:6
+ gles2-only? ( media-libs/mesa[gles2] )
+ usb? ( virtual/libusb:1 )
+"
+RDEPEND="${DEPEND}
+ || (
+ >=dev-qt/qttools-${QTMIN}:6[qdbus]
+ dev-qt/qdbus:*
+ )
+ >=kde-frameworks/kirigami-${KFMIN}:6
+ >=kde-plasma/kde-cli-tools-${PVCUT}:*
+ >=kde-plasma/systemsettings-${PVCUT}:6
+"
+BDEPEND=">=kde-frameworks/kcmutils-${KFMIN}:6"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package usb USB1)
+ -DCMAKE_DISABLE_FIND_PACKAGE_SeleniumWebDriverATSPI=ON # missing
+ )
+
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+
+ # TODO: Make this fully obsolete by /etc/os-release
+ insinto /etc/xdg
+ doins "${FILESDIR}"/kcm-about-distrorc
+
+ insinto /usr/share/${PN}
+ doins "${DISTDIR}"/glogo-small.png
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "NFS information module" net-fs/nfs-utils
+ optfeature "Samba status information module" net-fs/samba
+ optfeature "Vulkan graphics API information module" dev-util/vulkan-tools
+ optfeature "advanced CPU information module" sys-apps/util-linux
+ fi
+ optfeature "Wayland information module" app-misc/wayland-utils
+ optfeature "Firmware security module" "app-text/aha sys-apps/fwupd"
+ optfeature "OpenGL information module" x11-apps/mesa-progs
+ optfeature "PCI devices information module" sys-apps/pciutils
+ optfeature "X Server information module" x11-apps/xdpyinfo
+ ecm_pkg_postinst
+}