summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-07-14 17:13:32 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-07-15 07:36:14 +0200
commite19edabff80707de8772078358c8a9ca1169ca91 (patch)
treeb15a6cde4e36de6ddebe6a9e3d015312dc40dc8d /kde-apps/pimcommon
parentkde5-functions.eclass: Update minimum deps (diff)
downloadgentoo-e19edabff80707de8772078358c8a9ca1169ca91.tar.gz
gentoo-e19edabff80707de8772078358c8a9ca1169ca91.tar.bz2
gentoo-e19edabff80707de8772078358c8a9ca1169ca91.zip
kde-apps: Add KDE Applications 19.04.3
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/pimcommon')
-rw-r--r--kde-apps/pimcommon/Manifest1
-rw-r--r--kde-apps/pimcommon/pimcommon-19.04.3.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/kde-apps/pimcommon/Manifest b/kde-apps/pimcommon/Manifest
index c279aa93bbab..9324785dbbdc 100644
--- a/kde-apps/pimcommon/Manifest
+++ b/kde-apps/pimcommon/Manifest
@@ -1,2 +1,3 @@
DIST pimcommon-18.12.3.tar.xz 295052 BLAKE2B 145329d4fec3b393a1d0b19d54871e9333823e905be491e49f37a5c76b26362100b356780a978a346feb18e27d4422ff77561eb61436683b5c996c335e04f722 SHA512 261c84c206ae9ddea9aff3c0f79436a8c32d060ee018aa7e02c698596a106ba608cacf1198b1b4d0f3df41c301ddeddb6bd6c4e344721ff616d0d0c6dd3fc7f8
DIST pimcommon-19.04.2.tar.xz 295112 BLAKE2B 9386edf4d8fd757efa63dcd547d3a5faa7d7eeaeaaad059c3d040a9ce898ae97d081c2a1927a665bc1a29e3f63c870f340053c31ccb064c30918543812a191f7 SHA512 5c9b3c0e4ea0336a18e8853377e077db96ae090606d3b35f137270d74d5bb496ad9f21b94373d047395529a1e43ce6914c95c559c69bc28c9f7a6f5b322be5ca
+DIST pimcommon-19.04.3.tar.xz 294420 BLAKE2B 87d67b7dd975b0d989b5ca408e478cfed68918b1451f5faf16538d5fdd5033c00b1b98b07c8b75183ee83b21fa929aed94473a2935075886ff78db85c1589881 SHA512 862d240de0b551035eddf03cbbfe381c7a11c0715e4a0159447197525e5f68cf62ddc716726e1229f5be9e99c6c5129db8ed87aa8e8d0b713a23698a81884f27
diff --git a/kde-apps/pimcommon/pimcommon-19.04.3.ebuild b/kde-apps/pimcommon/pimcommon-19.04.3.ebuild
new file mode 100644
index 000000000000..f6917eeb6a78
--- /dev/null
+++ b/kde-apps/pimcommon/pimcommon-19.04.3.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_DESIGNERPLUGIN="true"
+KDE_TEST="forceoptional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Common PIM libraries"
+LICENSE="GPL-2+ LGPL-2.1+"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="share"
+
+BDEPEND="
+ dev-libs/libxslt
+"
+COMMON_DEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemmodels)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_kdeapps_dep akonadi)
+ $(add_kdeapps_dep akonadi-contacts)
+ $(add_kdeapps_dep kcontacts)
+ $(add_kdeapps_dep kimap)
+ $(add_kdeapps_dep kpimtextedit)
+ $(add_kdeapps_dep libkdepim)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtprintsupport)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ dev-libs/grantlee:5
+ share? ( $(add_frameworks_dep purpose) )
+"
+DEPEND="${COMMON_DEPEND}
+ $(add_frameworks_dep kiconthemes)
+ test? ( $(add_kdeapps_dep kmime) )
+"
+RDEPEND="${COMMON_DEPEND}
+ !kde-apps/kdepim-common-libs:4
+ !kde-apps/kdepim-l10n
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package share KF5Purpose)
+ )
+
+ kde5_src_configure
+}
+
+src_test() {
+ # bugs 641730, 661330
+ local myctestargs=(
+ -E "(autocorrectiontest|pimcommon-translator-translatortest)"
+ )
+
+ kde5_src_test
+}