summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-09-20 23:28:02 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-09-20 23:28:25 +0300
commitea3b024f064d565227b7bd536e99e2c73456042f (patch)
tree7b50a83671d330639fbeddff948a8ad8f3c1d9c1 /gui-wm/tinywl
parentgui-libs/wlroots: add 0.18.1 (diff)
downloadgentoo-ea3b024f064d565227b7bd536e99e2c73456042f.tar.gz
gentoo-ea3b024f064d565227b7bd536e99e2c73456042f.tar.bz2
gentoo-ea3b024f064d565227b7bd536e99e2c73456042f.zip
gui-wm/tinywl: add 0.18.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'gui-wm/tinywl')
-rw-r--r--gui-wm/tinywl/Manifest1
-rw-r--r--gui-wm/tinywl/tinywl-0.18.1.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/gui-wm/tinywl/Manifest b/gui-wm/tinywl/Manifest
index e749afe959c7..b7afa43d2aa9 100644
--- a/gui-wm/tinywl/Manifest
+++ b/gui-wm/tinywl/Manifest
@@ -1,2 +1,3 @@
DIST wlroots-0.17.4.tar.gz 609179 BLAKE2B dc5a7749533ab54631d4a26be554b86e5b08b2472cf8f22ccebddb319d571cbd98a5c56e64e7bc762a5918d4272eb6b4261050288f3053c18c824c6a9c32b96b SHA512 35803df9fe68cadb0b9b5e522863535407ba2354ed1ca8f824a9c40b64698a97c579fec0afeb444b05d429adc1e3dfc45b20c3a1b7a2004e4f5a10d2305c9116
DIST wlroots-0.18.0.tar.gz 628190 BLAKE2B b1d725e0397365b69afce24baf5376057a40d225f7cb06ccd5abde3b3da8d5401a6eb5d57ab65154a6faf7961473039833e558e3b25da1210891d34667da5bf9 SHA512 2cf848aa67f41089b60cc7d01c3a344ebaf7f5bbced459675fef885cd4b3e6b99d9a49d6b127518314d0ae38e52e9aff7991611592b2add4cba96f15aa0bf1c6
+DIST wlroots-0.18.1.tar.gz 628648 BLAKE2B 051909ef4cac4c523bb43b42396abe8c18e3835a7a29bde30787829040271720f06579dadf3f03d9569bcc1e25492c6bd383f314aaa10b63c597f08735d30537 SHA512 c4d83ae75aec4f7f4e8aefbff27594d0962c56c4a3a3ef2d7ccd432f92eb56df7edb995cc0fa1f62d9290e988f20e7525d007717f36ce4824dfc41061a697fbb
diff --git a/gui-wm/tinywl/tinywl-0.18.1.ebuild b/gui-wm/tinywl/tinywl-0.18.1.ebuild
new file mode 100644
index 000000000000..a08f405dff3d
--- /dev/null
+++ b/gui-wm/tinywl/tinywl-0.18.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="\"minimum viable product\" Wayland compositor based on wlroots"
+HOMEPAGE="https://gitlab.freedesktop.org/wlroots/wlroots/-/tree/master/tinywl"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/wlroots/wlroots.git"
+ inherit git-r3
+else
+ SRC_URI="https://gitlab.freedesktop.org/wlroots/wlroots/-/releases/${PV}/downloads/wlroots-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~riscv ~x86"
+ S="${WORKDIR}/wlroots-${PV}"
+fi
+
+LICENSE="CC0-1.0"
+SLOT="0"
+DEPEND="
+ dev-libs/wayland
+ x11-libs/libxkbcommon
+ =gui-libs/wlroots-$(ver_cut 1-2)*:=
+"
+RDEPEND="
+ ${DEPEND}
+ !gui-libs/wlroots[tinywl(-)]
+"
+BDEPEND="
+ dev-libs/wayland-protocols
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ sed -i -e "s/-Werror //" tinywl/Makefile || die
+ default
+}
+
+src_compile() {
+ emake -C tinywl
+}
+
+src_install() {
+ dodoc tinywl/README.md
+ dobin tinywl/tinywl
+}