summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2022-02-26 23:41:00 +0000
committerJames Le Cuirot <chewi@gentoo.org>2022-02-26 23:41:00 +0000
commit073b8681dd0d8df21aaf5b420c696e85f76bf82e (patch)
treebdd1fddbfb7bb3eb0d39d45de23d518f5a257f97 /games-util/lgogdownloader
parentx11-themes/arc-theme: Drop old 20211018 (diff)
downloadgentoo-073b8681dd0d8df21aaf5b420c696e85f76bf82e.tar.gz
gentoo-073b8681dd0d8df21aaf5b420c696e85f76bf82e.tar.bz2
gentoo-073b8681dd0d8df21aaf5b420c696e85f76bf82e.zip
games-util/lgogdownloader: Version bump to 3.9
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-util/lgogdownloader')
-rw-r--r--games-util/lgogdownloader/Manifest1
-rw-r--r--games-util/lgogdownloader/lgogdownloader-3.9.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/games-util/lgogdownloader/Manifest b/games-util/lgogdownloader/Manifest
index 96c2c63cc6b1..f9a2154fc2de 100644
--- a/games-util/lgogdownloader/Manifest
+++ b/games-util/lgogdownloader/Manifest
@@ -1 +1,2 @@
DIST lgogdownloader-3.8.tar.gz 85271 BLAKE2B ff8e9f80dbec849649b4074ab5890f833a5bfaf120246e7ca5eae83f414af469da29302323dc22632eb0a7259e49e9cf3660ea8953adda75fc7a5308204767bd SHA512 ccc6116f22a5c0bff5e4ef650f6386d5bfc507cc667b7154b021ecdbd45e7553ac33ae6b81531e2cea52a5022ee9c810033518a07374d4e9f7c672344e7ccad3
+DIST lgogdownloader-3.9.tar.gz 86351 BLAKE2B 4ba1a39e2c040910cb3fdef908c229ce8a7def70ba430167977ab4eaa7fdcdfd132a314d256300904dd14052aecffceec92652cfa3eba3c2a54d83b1920ed2b7 SHA512 5ac15776c0ab7416013782652fead180f75e3bd075a3b67c9cb672122c13401ebc91e785daa9e7d332011474240dbb4d8383ddadea2abf0d3bddfc13d6892066
diff --git a/games-util/lgogdownloader/lgogdownloader-3.9.ebuild b/games-util/lgogdownloader/lgogdownloader-3.9.ebuild
new file mode 100644
index 000000000000..6e34f09c1bc1
--- /dev/null
+++ b/games-util/lgogdownloader/lgogdownloader-3.9.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Unofficial GOG.com downloader for Linux"
+HOMEPAGE="https://sites.google.com/site/gogdownloader/"
+SRC_URI="https://github.com/Sude-/${PN}/releases/download/v${PV}/${P}.tar.gz"
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gui"
+
+RDEPEND=">=app-crypt/rhash-1.3.3-r2:0=
+ dev-cpp/htmlcxx:0=
+ dev-libs/boost:0=[zlib]
+ >=dev-libs/jsoncpp-1.7:0=
+ dev-libs/tinyxml2:0=
+ >=net-misc/curl-7.32:0=[ssl]
+ gui? ( dev-qt/qtwebengine:5=[widgets] )"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="sys-apps/help2man
+ virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_QT_GUI=$(usex gui)
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ gunzip "${ED}"/usr/share/man/man1/${PN}.1.gz || die
+}