summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarol Wrótniak <karol.wrotniak@droidsonroids.pl>2018-08-19 17:13:23 +0200
committerMichał Górny <mgorny@gentoo.org>2018-08-22 16:35:57 +0200
commit737eb6ff13ea0a765e48ff63e0fb2f5996974a52 (patch)
tree147436fd7c67de7b415d8350608e35431537ed95 /dev-util
parentxfce-base/xfce4-appfinder: Bump to 4.13.1 (diff)
downloadgentoo-737eb6ff13ea0a765e48ff63e0fb2f5996974a52.tar.gz
gentoo-737eb6ff13ea0a765e48ff63e0fb2f5996974a52.tar.bz2
gentoo-737eb6ff13ea0a765e48ff63e0fb2f5996974a52.zip
dev-util/envman: version bump 1.2.1
Closes: https://github.com/gentoo/gentoo/pull/9626
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/envman/Manifest1
-rw-r--r--dev-util/envman/envman-1.2.1.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-util/envman/Manifest b/dev-util/envman/Manifest
index e4ecaa9b6e75..45209dba2555 100644
--- a/dev-util/envman/Manifest
+++ b/dev-util/envman/Manifest
@@ -1 +1,2 @@
DIST envman-1.2.0.tar.gz 2997860 BLAKE2B e49d3b421fb1ab226de4430e90d8c684bc3a2554205c6383a140c0832134eaba338797dca44668fc2473d248940b5499395ab3a6d3359382305fd8a719772257 SHA512 5245aea8c280a6d6022e8132216891f09abee707c0ed736bfe6b4882aa23880a771dce5371b8ba5fcdd41fa951606727e7582442d897058b25985cf9dd5a9d18
+DIST envman-1.2.1.tar.gz 3033981 BLAKE2B a48c46d35a122ad86274867c246f1af998a983a67e8d30214bc6f3a989ad6b435a61ebad7f128803ffb9dcfc05af261b99cf3316fed93412c6ee1da873cc988e SHA512 bbec25964d868077c88a01ab827744633b325eb955809d4ec48a5224f6f8530c31b297b592f0280dabd01007bf75fd6ac3609c4d19be0332ca114d36725c7fb6
diff --git a/dev-util/envman/envman-1.2.1.ebuild b/dev-util/envman/envman-1.2.1.ebuild
new file mode 100644
index 000000000000..6909eb936e5a
--- /dev/null
+++ b/dev-util/envman/envman-1.2.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit golang-build
+
+EGO_ON="github.com/bitrise-io"
+EGO_PN="${EGO_ON}/${PN}"
+
+DESCRIPTION="Environment variable manager for Bitrise CLI"
+HOMEPAGE="https://www.bitrise.io/cli"
+SRC_URI="https://${EGO_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+S="${WORKDIR}/src/${EGO_ON}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ mkdir -p "${WORKDIR}/src/${EGO_ON}" || die "Couldn't create project dir in GOPATH"
+ mv "${WORKDIR}/${P}" "${WORKDIR}/src/${EGO_ON}/envman" || die "Couldn't move sources to GOPATH"
+}
+
+src_compile() {
+ GOPATH="${WORKDIR}" go build -v -o bin/envman || die "Couldn't compile envman"
+}
+
+src_test() {
+ GOPATH="${WORKDIR}" go test ./... || die "Tests failed"
+}
+
+src_install() {
+ dobin bin/envman
+ einstalldocs
+}