summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYiyangWu <xgreenlandforwyy@gmail.com>2021-07-25 14:01:49 +0800
committerBenda Xu <heroxbd@gentoo.org>2021-08-03 09:35:00 +0800
commit2777139222b8f33993bcdb2947f3de5e9cc13901 (patch)
tree6ea78b4a15a5a570bf7a1ee86fb61ce00d583bdf /dev-util
parentprofiles: drop old ppc64le profiles (diff)
downloadgentoo-2777139222b8f33993bcdb2947f3de5e9cc13901.tar.gz
gentoo-2777139222b8f33993bcdb2947f3de5e9cc13901.tar.bz2
gentoo-2777139222b8f33993bcdb2947f3de5e9cc13901.zip
dev-util/hip: cleanup unnecessary patches and sed commands.
hip uses HIP_PLATFORM=amd and HIP_RUNTIME=amd, therefore some sed commands are not necessary anymore. Every patch is checked. Removing hip-3.5.1-hip_vector_types.patch seems to have no impact on compile and running hipcc. Closes: https://github.com/gentoo/gentoo/pull/21863 Bug: https://github.com/justxi/rocm/issues/192 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Yiyang Wu <xgreenlandforwyy@gmail.com> Signed-off-by: Benda Xu <heroxbd@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/hip/hip-4.1.0.ebuild9
1 files changed, 2 insertions, 7 deletions
diff --git a/dev-util/hip/hip-4.1.0.ebuild b/dev-util/hip/hip-4.1.0.ebuild
index e6e6a374a787..c5b5027b241c 100644
--- a/dev-util/hip/hip-4.1.0.ebuild
+++ b/dev-util/hip/hip-4.1.0.ebuild
@@ -26,7 +26,6 @@ PATCHES=(
"${FILESDIR}/${PN}-4.1.0-DisableTest.patch"
"${FILESDIR}/${PN}-3.9.0-add-include-directories.patch"
"${FILESDIR}/${PN}-3.5.1-config-cmake-in.patch"
- "${FILESDIR}/${PN}-3.5.1-hip_vector_types.patch"
"${FILESDIR}/${PN}-3.9.0-lpl_ca-add-include.patch"
)
@@ -40,19 +39,15 @@ src_prepare() {
sed -e "/set (HIP_LIB_VERSION_STRING/cset (HIP_LIB_VERSION_STRING ${PVR})" -i CMakeLists.txt || die
# disable PCH, because it results in a build error in ROCm 4.0.0
- sed -e "s:option(__HIP_ENABLE_PCH:#option(__HIP_ENABLE_PCH:" -i "${S}/CMakeLists.txt" || die
+ sed -e "s:option(__HIP_ENABLE_PCH:#option(__HIP_ENABLE_PCH:" -i CMakeLists.txt || die
# "hcc" is deprecated and not installed, new platform is "rocclr";
# Setting HSA_PATH to "/usr" results in setting "-isystem /usr/include"
# which makes "stdlib.h" not found when using "#include_next" in header files;
- sed -e "/HIP_PLATFORM.*HIP_COMPILER.*clang/s:hcc:rocclr:" \
- -e "/FLAGS .= \" -isystem \$HSA_PATH/d" \
+ sed -e "/FLAGS .= \" -isystem \$HSA_PATH/d" \
-e "s:\$ENV{'DEVICE_LIB_PATH'}:'/usr/lib/amdgcn/bitcode':" \
-i bin/hipcc || die
- # replace hcc remnants with modern rocclr.
- sed -e "/HIP_PLATFORM.*STREQUAL/s:hcc:rocclr:" -i cmake/FindHIP/run_hipcc.cmake || die
-
# correctly find HIP_CLANG_INCLUDE_PATH using cmake
sed -e "/set(HIP_CLANG_ROOT/s:\"\${ROCM_PATH}/llvm\":/usr/lib/llvm/roc:" -i hip-config.cmake.in || die