summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-10-18 11:22:17 +0200
committerHans de Graaff <graaff@gentoo.org>2024-10-18 11:24:21 +0200
commit29285669eef30e8653159a4f4780c446b5054da1 (patch)
tree4441d929f50a112c763646c8c03453cb83218dd2 /dev-ruby/activerecord
parentdev-ruby/actionview: drop 6.1.7.7 (diff)
downloadgentoo-29285669eef30e8653159a4f4780c446b5054da1.tar.gz
gentoo-29285669eef30e8653159a4f4780c446b5054da1.tar.bz2
gentoo-29285669eef30e8653159a4f4780c446b5054da1.zip
dev-ruby/activerecord: drop 6.1.7.7
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/activerecord')
-rw-r--r--dev-ruby/activerecord/Manifest1
-rw-r--r--dev-ruby/activerecord/activerecord-6.1.7.7.ebuild99
2 files changed, 0 insertions, 100 deletions
diff --git a/dev-ruby/activerecord/Manifest b/dev-ruby/activerecord/Manifest
index b006f93c5c21..da0262f73a88 100644
--- a/dev-ruby/activerecord/Manifest
+++ b/dev-ruby/activerecord/Manifest
@@ -1,4 +1,3 @@
-DIST rails-6.1.7.7.tgz 11041447 BLAKE2B 3f59325aa86d3b7d6e0773b9eb2b895a26b644109be8df0b0d9abbab8e6c77f76d316c717ecce4e2d79d3247559504a7452a8037d2d52a6cf95fbacd7f8b8612 SHA512 f9af4eebb3bffec78832f92be6158c71c147e265b54e8e368a06c762bfd1a7992256b3e9286aeb59eee69ba56be28d381a715eb13f99b9babfd9b7ce8051e210
DIST rails-6.1.7.8.tgz 11041890 BLAKE2B 285571972ec1d43ae65f3c4f586679e31d0550263c4778925c5828000d6ba971a791ad1071a7ab5edd8d728cd51ee15bb5cee1261b828a4b5926a54f34887d10 SHA512 8c819da0f46820f05d4128444fb3c3908d5e50f97935b173cdd156a986720dda6bcbb62015884d3142ebd5b17621e3f94ca2c80691564914088e884b9aac3573
DIST rails-6.1.7.9.tgz 11034686 BLAKE2B 12edf62a94e0b504f1db721081ce35a6b7e8f67bded2801ce54872f7cef80fb75120f56b356940a44d943cbd05b4d63778726885ac20dd04a2e5510f54ea06ac SHA512 387cbc5424b16ade97091e3cfc3a5bc0cfe277ee75a7f35cdf5d393c692d2ea17f258e38d8b25c8c8a1be4fb64a39d0f675b23942145929bb7be4783cd95d90b
DIST rails-7.0.8.3.tgz 11080686 BLAKE2B 2d13559e7b7ab752af4fee480ee51f73b4d1f39246e68513e9b63a4769eba7b82e13980ad4a04776476740aca19ed8920dab294299df1bc9cbb78eb5975ffbe1 SHA512 2054191e2bc3ca667e637ccdf3e68bcc3747715cf38f75a9a6e37a1b155286cdfbb4c987f98f3566254878991c3ab0d709ce3d4bf6ff1d4df3d34095576f1db3
diff --git a/dev-ruby/activerecord/activerecord-6.1.7.7.ebuild b/dev-ruby/activerecord/activerecord-6.1.7.7.ebuild
deleted file mode 100644
index eadbf5982b16..000000000000
--- a/dev-ruby/activerecord/activerecord-6.1.7.7.ebuild
+++ /dev/null
@@ -1,99 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-USE_RUBY="ruby31 ruby32"
-
-# this is not null so that the dependencies will actually be filled
-RUBY_FAKEGEM_TASK_TEST="test"
-
-RUBY_FAKEGEM_RECIPE_DOC="none"
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
-
-RUBY_FAKEGEM_GEMSPEC="activerecord.gemspec"
-
-RUBY_FAKEGEM_BINWRAP=""
-
-inherit ruby-fakegem
-
-DESCRIPTION="Implements the ActiveRecord pattern (Fowler, PoEAA) for ORM"
-HOMEPAGE="https://github.com/rails/rails/"
-SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="$(ver_cut 1-2)"
-KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
-IUSE="mysql postgres sqlite"
-
-RUBY_S="rails-${PV}/${PN}"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-6.1.7.4-ruby32-keywords.patch
-)
-
-ruby_add_rdepend "~dev-ruby/activesupport-${PV}
- ~dev-ruby/activemodel-${PV}
- sqlite? ( >=dev-ruby/sqlite3-1.4 )
- mysql? ( dev-ruby/mysql2:0.5 )
- postgres? ( >=dev-ruby/pg-1.1:1 )"
-
-ruby_add_bdepend "
- test? (
- dev-ruby/bundler
- ~dev-ruby/actionpack-${PV}
- ~dev-ruby/railties-${PV}
- >=dev-ruby/sqlite3-1.4.0
- dev-ruby/mocha
- <dev-ruby/minitest-5.16:*
- )"
-
-DEPEND+=" test? ( >=dev-db/sqlite-3.12.1 )"
-
-all_ruby_prepare() {
- # Remove items from the common Gemfile that we don't need for this
- # test run. This also requires handling some gemspecs.
- rm ../Gemfile.lock || die
- sed -i -e "/\(uglifier\|system_timer\|sdoc\|w3c_validators\|pg\|jquery-rails\|execjs\|'mysql'\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|redcarpet\|minitest\|sprockets\|stackprof\)/ s:^:#:" \
- -e '/:job/,/end/ s:^:#:' \
- -e '/group :doc/,/^end/ s:^:#:' ../Gemfile || die
- sed -i -e '/rack-ssl/d' -e 's/~> 3.4/>= 3.4/' ../railties/railties.gemspec || die
- sed -e '/bcrypt/ s/3.0.0/3.0/' \
- -i ../Gemfile || die
- sed -i -e '/byebug/ s:^:#:' test/cases/base_prevent_writes_test.rb || die
-
- # Add back json in the Gemfile because we dropped some dependencies
- # earlier that implicitly required it.
- sed -i -e '$agem "json"' ../Gemfile || die
-
- # Load correct rails version
- sed -e '2igem "activemodel", "~> 6.1.0"; gem "activejob", "~> 6.1.0"; gem "railties", "~> 6.1.0"; gem "minitest", "<5.16"' \
- -i test/cases/helper.rb || die
-
- # Avoid single tests using mysql or postgres dependencies.
- rm test/cases/invalid_connection_test.rb || die
- sed -e '/test_switching_connections_with_database_url/askip "postgres"' \
- -i test/cases/connection_adapters/{,legacy_}connection_handlers_multi_db_test.rb || die
-
- # Avoid failing test that makes bad assumptions on database state.
- sed -i -e '/test_do_not_call_callbacks_for_delete_all/,/^ end/ s:^:#:' \
- test/cases/associations/has_many_associations_test.rb
-
- # Avoid tests that no longer work with newer sqlite versions
- rm -f test/cases/adapters/sqlite3/explain_test.rb || die
- sed -e '/test_references_stays_as_integer_column/askip "Fails on case difference"' \
- -i test/cases/migration/compatibility_test.rb || die
-
- # Avoid test failing to bind limit length in favor of security release
- sed -e '/test_too_many_binds/askip "Fails on Gentoo"' \
- -i test/cases/bind_parameter_test.rb || die
-
- # Avoid test failing related to rubygems
- sed -e '/test_generates_absolute_path_with_given_root/askip "rubygems activation monitor"' \
- -i test/cases/tasks/sqlite_rake_test.rb || die
-}
-
-each_ruby_test() {
- if use sqlite; then
- ${RUBY} -S rake test_sqlite3 || die "sqlite3 tests failed"
- fi
-}