summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-22 14:09:13 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-22 14:09:13 +0200
commitd069b00082b08194d197e9ab9a0435cefa294ac8 (patch)
tree1c3aeb907a181683d71f789e11a646f8cde78819 /dev-ros/roscreate
parentdev-ros/roslib: Initial import. Ebuild by me. (diff)
downloadgentoo-d069b00082b08194d197e9ab9a0435cefa294ac8.tar.gz
gentoo-d069b00082b08194d197e9ab9a0435cefa294ac8.tar.bz2
gentoo-d069b00082b08194d197e9ab9a0435cefa294ac8.zip
dev-ros/roscreate: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/roscreate')
-rw-r--r--dev-ros/roscreate/Manifest1
-rw-r--r--dev-ros/roscreate/metadata.xml5
-rw-r--r--dev-ros/roscreate/roscreate-1.12.3.ebuild24
-rw-r--r--dev-ros/roscreate/roscreate-9999.ebuild24
4 files changed, 54 insertions, 0 deletions
diff --git a/dev-ros/roscreate/Manifest b/dev-ros/roscreate/Manifest
new file mode 100644
index 000000000000..02c7ccc4a2ae
--- /dev/null
+++ b/dev-ros/roscreate/Manifest
@@ -0,0 +1 @@
+DIST ros-1.12.3.tar.gz 162506 SHA256 49b9368e901d69f464b46c9ff0d12843d413fe20c4271225dbb75169bb82a47e SHA512 fe740f357959ed2cabcf0d902c7f1ebe6a7dedd11376ec76e5f47383b0b29b15127306255bea9adb3a48b2872a681a10302f9b0c4da4625c31bcc78522b66d7c WHIRLPOOL d57a877f7b7dc2a6613d3ea07b59e740e25bfffbcec51fa4ce826ccdc9f95dd9aed121736f46338068f9cf06b52a6abc8462ce663bbd4519e7d93f16422995f5
diff --git a/dev-ros/roscreate/metadata.xml b/dev-ros/roscreate/metadata.xml
new file mode 100644
index 000000000000..c42ea5b15cf6
--- /dev/null
+++ b/dev-ros/roscreate/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/dev-ros/roscreate/roscreate-1.12.3.ebuild b/dev-ros/roscreate/roscreate-1.12.3.ebuild
new file mode 100644
index 000000000000..ce4759513568
--- /dev/null
+++ b/dev-ros/roscreate/roscreate-1.12.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Tool that assists in the creation of ROS filesystem resources"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
diff --git a/dev-ros/roscreate/roscreate-9999.ebuild b/dev-ros/roscreate/roscreate-9999.ebuild
new file mode 100644
index 000000000000..ce4759513568
--- /dev/null
+++ b/dev-ros/roscreate/roscreate-9999.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Tool that assists in the creation of ROS filesystem resources"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"