summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-22 13:27:10 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-22 13:27:10 +0200
commitf5785a60bf3c027cf73904ef827534fc21699f2c (patch)
tree22800cd1bc641b583946b9b8f426febc124edc0a /dev-python
parentdev-python/setuptools-scm: Bump to 8.0.3 (diff)
downloadgentoo-f5785a60bf3c027cf73904ef827534fc21699f2c.tar.gz
gentoo-f5785a60bf3c027cf73904ef827534fc21699f2c.tar.bz2
gentoo-f5785a60bf3c027cf73904ef827534fc21699f2c.zip
dev-python/pytest-check: Bump to 2.2.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pytest-check/Manifest1
-rw-r--r--dev-python/pytest-check/pytest-check-2.2.2.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/pytest-check/Manifest b/dev-python/pytest-check/Manifest
index e6c2dc51e95a..9a205cadbaad 100644
--- a/dev-python/pytest-check/Manifest
+++ b/dev-python/pytest-check/Manifest
@@ -1 +1,2 @@
DIST pytest_check-2.2.1.tar.gz 29128 BLAKE2B 758d2f04a5a500367ecca9a95afe21c03e7a52f319403d4bc0af14d27b96b335e5db42ee312217b0788eceab25048266ac135cfeb7d8214908ed5c13ded33b33 SHA512 04843219a1d49385ccac9b60707a6dd595258664b61a0bf31e666502a222d16b7130c8c0ae65ebd6431d58e2e08d90db3ad016dc4591dab7e3c3502296ceff44
+DIST pytest_check-2.2.2.tar.gz 26353 BLAKE2B 90e95aaddfb3f595b7f0ac7fe8f75cc0dbe173dfcd30aa888cebca9e61ddd67a1a25bb5e152151c86c7bd6144f6875622c8c3a53c3453281b94f2e74a4b465e5 SHA512 27f6df34450db762fb6656b255d34bf6656bacefc68cdd050e100dcf53df1406c6983a509c7b7cc3cc37664c06d3798254a350ba9c0ebcf9095cb7aa1bd11557
diff --git a/dev-python/pytest-check/pytest-check-2.2.2.ebuild b/dev-python/pytest-check/pytest-check-2.2.2.ebuild
new file mode 100644
index 000000000000..2b390b088d17
--- /dev/null
+++ b/dev-python/pytest-check/pytest-check-2.2.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="pytest plugin that allows multiple failures per test"
+HOMEPAGE="
+ https://github.com/okken/pytest-check/
+ https://pypi.org/project/pytest-check/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/colorama-0.4.6[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest