summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-16 07:40:42 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-16 08:46:51 +0200
commit5cd38be114ca54656515df3084022f2092320472 (patch)
tree0359fa77380412ef9d3d122c1f4deb31326f56ec /dev-python
parentdev-python/sphinx-issues: Bump to 4.1.0 (diff)
downloadgentoo-5cd38be114ca54656515df3084022f2092320472.tar.gz
gentoo-5cd38be114ca54656515df3084022f2092320472.tar.bz2
gentoo-5cd38be114ca54656515df3084022f2092320472.zip
dev-python/uv: Bump to 0.1.32
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/uv/Manifest2
-rw-r--r--dev-python/uv/files/uv-0.1.32-skip-tests.patch12
-rw-r--r--dev-python/uv/uv-0.1.32.ebuild121
3 files changed, 135 insertions, 0 deletions
diff --git a/dev-python/uv/Manifest b/dev-python/uv/Manifest
index a24d413fc319..1da9f1e5f696 100644
--- a/dev-python/uv/Manifest
+++ b/dev-python/uv/Manifest
@@ -6,3 +6,5 @@ DIST uv-0.1.24-crates.tar.xz 64420840 BLAKE2B 7324461092a07c86aadaddf051aaa7454e
DIST uv-0.1.24.gh.tar.gz 899637 BLAKE2B fab26ba9934fc5f586505b5ac1fa386c11f07e51ca2bb2a79f46d5dec9475ba8d75ad8587223d5149df5f2a225146d020a49b7ff81ed26b949cff55892738c2d SHA512 520b47a096b50fce9e7b7af5bca203df9bf4c2d0aafbe28a3dcfe0592d8ddcaa7b58d52300c67454f6aeecfd196f1592be18e45c95b7c67257361917cdb0154d
DIST uv-0.1.31-crates.tar.xz 64759920 BLAKE2B 9404847d0a4bdaf77778fe7e75de4a6167c43a5f786357653f45f613984b2297f07a30dbd782d49ffd4f936276f2da61ecc543c6942c58ae2f3b6a5cb77212b0 SHA512 8c7440e52649b9a749d36ef5e7ed0a2be5df590d2cd6486559bc0ab289e87f5533927ddd82e86268b8cb86a41056557ec3acb3e4eface63439837243a2ab0b7a
DIST uv-0.1.31.gh.tar.gz 938923 BLAKE2B c6be91911b557260df546bd708e572d4ea6688e40a0c978a598070e71bb989b77fdace1e5507dcc829e9e21714962c8e76ee2ec5dc95ae10a1ccaa562e4c70e7 SHA512 687f622bc93a0b4c967d53ab068d3f5442f7a3566495f89da252d3beb41a17be3dcf410f260f7e68bb1f5595f633ea61da7a68423f190d879e809c25e9e297cb
+DIST uv-0.1.32-crates.tar.xz 64975300 BLAKE2B cb07eb6ed0c65b538554cd2fdf455a25cddbefe07e3718f83820c1faf40795c0da6397a31e138c6f01dad9fb4e48dbe1a2fd4be76f1ab94f096e915d34ec1ac7 SHA512 83e208e54322d467cedd1463157d413ad8a5a6012a8d0219aa31b5213466fc4caef86a22e90bc0695811ab1f5e7428f3306a8845785f472e941a758242e775db
+DIST uv-0.1.32.gh.tar.gz 976905 BLAKE2B c59f4a76a3a9335429ddfa1a6fc96a13ba68ad2950a5664762d6b48c3dc67c78ee075ff723fd049733bc3240924a5ede522ce973ab37b44784f54322f6c8039f SHA512 fefd8cac2630c1c061a54abf5ad7bfe34f93176dd5fa69fc8ba39e6cea6a786527cd7e22481449d987dbd567ee4f59b3ef2a13620de3049f7066aaddb1ee4593
diff --git a/dev-python/uv/files/uv-0.1.32-skip-tests.patch b/dev-python/uv/files/uv-0.1.32-skip-tests.patch
new file mode 100644
index 000000000000..dd672fdd16cf
--- /dev/null
+++ b/dev-python/uv/files/uv-0.1.32-skip-tests.patch
@@ -0,0 +1,12 @@
+diff --git a/crates/uv/tests/pip_sync.rs b/crates/uv/tests/pip_sync.rs
+index 7cecbba5..f7385dbf 100644
+--- a/crates/uv/tests/pip_sync.rs
++++ b/crates/uv/tests/pip_sync.rs
+@@ -1396,7 +1396,6 @@ fn install_git_source_dist_cached() -> Result<()> {
+ }
+
+ /// Check that we show the right messages on cached, registry source distribution installs.
+-#[test]
+ fn install_registry_source_dist_cached() -> Result<()> {
+ let context = TestContext::new("3.12");
+
diff --git a/dev-python/uv/uv-0.1.32.ebuild b/dev-python/uv/uv-0.1.32.ebuild
new file mode 100644
index 000000000000..7287532bc9ca
--- /dev/null
+++ b/dev-python/uv/uv-0.1.32.ebuild
@@ -0,0 +1,121 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CRATES="
+"
+
+declare -A GIT_CRATES=(
+ [async_zip]='https://github.com/charliermarsh/rs-async-zip;1dcb40cfe1bf5325a6fd4bfcf9894db40241f585;rs-async-zip-%commit%'
+ [pubgrub]='https://github.com/astral-sh/pubgrub;c26e485213e39582c6f2e4d45c0328422670e7a7;pubgrub-%commit%'
+)
+
+inherit cargo check-reqs
+
+DESCRIPTION="A Python package installer and resolver, written in Rust"
+HOMEPAGE="
+ https://github.com/astral-sh/uv/
+ https://pypi.org/project/uv/
+"
+# pypi sdist misses scripts/, needed for tests
+SRC_URI="
+ https://github.com/astral-sh/uv/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ ${CARGO_CRATE_URIS}
+"
+if [[ ${PKGBUMPING} != ${PVR} ]]; then
+ CRATE_P=${P}
+ SRC_URI+="
+ https://dev.gentoo.org/~mgorny/dist/${CRATE_P}-crates.tar.xz
+ "
+fi
+
+# most of the code
+LICENSE="|| ( Apache-2.0 MIT )"
+# crates/pep508-rs is || ( Apache-2.0 BSD-2 ) which is covered below
+# Dependent crate licenses
+LICENSE+="
+ 0BSD Apache-2.0 Apache-2.0-with-LLVM-exceptions BSD-2 BSD ISC MIT
+ MPL-2.0 Unicode-DFS-2016
+"
+# ring crate
+LICENSE+=" openssl"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="test"
+RESTRICT="test"
+PROPERTIES="test_network"
+
+DEPEND="
+ dev-libs/libgit2:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ >=virtual/rust-1.77
+ test? (
+ dev-lang/python:3.8
+ dev-lang/python:3.9
+ dev-lang/python:3.10
+ dev-lang/python:3.11
+ dev-lang/python:3.12
+ )
+"
+
+QA_FLAGS_IGNORED="usr/bin/.*"
+
+check_space() {
+ local CHECKREQS_DISK_BUILD=3G
+ use debug && CHECKREQS_DISK_BUILD=9G
+ check-reqs_pkg_setup
+}
+
+pkg_pretend() {
+ check_space
+}
+
+pkg_setup() {
+ check_space
+}
+
+src_prepare() {
+ local PATCHES=(
+ # skip broken test
+ # https://github.com/astral-sh/uv/issues/3051
+ "${FILESDIR}/uv-0.1.32-skip-tests.patch"
+ )
+
+ default
+}
+
+src_configure() {
+ local myfeatures=(
+ # from upstream defaults
+ flate2/zlib-ng
+ python
+ pypi
+ git
+ maturin
+ # skip tests that require specific patch version of the interpreter:
+ # python-patch
+ )
+
+ cargo_src_configure --no-default-features
+}
+
+src_compile() {
+ cd crates/uv || die
+ cargo_src_compile
+}
+
+src_test() {
+ cd crates/uv || die
+ cargo_src_test --no-fail-fast
+}
+
+src_install() {
+ cd crates/uv || die
+ cargo_src_install
+}