summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2016-08-15 14:42:44 +0200
committerPatrice Clement <monsieurp@gentoo.org>2016-08-15 21:45:21 +0200
commit4b3ee710780bf0982efbb4ba3752a4fe3d8704d0 (patch)
tree90be1cf96823468ebc39e1a099160ee5e8d333b0 /dev-python
parentapp-emulation/rkt: fix 1.12.0 to not require git, bug 591314 (diff)
downloadgentoo-4b3ee710780bf0982efbb4ba3752a4fe3d8704d0.tar.gz
gentoo-4b3ee710780bf0982efbb4ba3752a4fe3d8704d0.tar.bz2
gentoo-4b3ee710780bf0982efbb4ba3752a4fe3d8704d0.zip
dev-python/geventhttpclient: new package, v. 1.3.1, dependency of dulwich
Package-Manager: portage-2.3.0 Closes: https://github.com/gentoo/gentoo/pull/2085 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/geventhttpclient/Manifest1
-rw-r--r--dev-python/geventhttpclient/geventhttpclient-1.3.1.ebuild38
-rw-r--r--dev-python/geventhttpclient/metadata.xml17
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/geventhttpclient/Manifest b/dev-python/geventhttpclient/Manifest
new file mode 100644
index 000000000000..cfa49f87b88d
--- /dev/null
+++ b/dev-python/geventhttpclient/Manifest
@@ -0,0 +1 @@
+DIST geventhttpclient-1.3.1.tar.gz 55050 SHA256 84a7d806c764fb89fd4d6cf9c09b2a1c3ba9cd15a1bad3f96e4c6e57c1e79b58 SHA512 79b79ae63d2733771f72d5b96adafbbe3a5133d41e6263913b908266519ba43eb05e86d0e0af8e9e3d21b07a0686888534b058f9ce46a1dbef3a89d8a5ef4f83 WHIRLPOOL 4ca928d00ccb39066d3b927ebeaa3c263717a26b7d4b84df152ff9b2474be7c2b8c481975cee6c070039d1d875b0ac83287608712ffe68acc4163e27bb405c93
diff --git a/dev-python/geventhttpclient/geventhttpclient-1.3.1.ebuild b/dev-python/geventhttpclient/geventhttpclient-1.3.1.ebuild
new file mode 100644
index 000000000000..4544d536236c
--- /dev/null
+++ b/dev-python/geventhttpclient/geventhttpclient-1.3.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="A high performance, concurrent HTTP client library for Python using gevent"
+HOMEPAGE="https://github.com/gwik/geventhttpclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/certifi[${PYTHON_USEDEP}]
+ dev-python/gevent[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ # Ignore tests which require network access
+ py.test src/geventhttpclient/tests --ignore \
+ src/geventhttpclient/tests/test_client.py || \
+ die "Tests failed with ${EPYTHON}"
+}
diff --git a/dev-python/geventhttpclient/metadata.xml b/dev-python/geventhttpclient/metadata.xml
new file mode 100644
index 000000000000..fac88891eb87
--- /dev/null
+++ b/dev-python/geventhttpclient/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sautier.louis@gmail.com</email>
+ <name>Louis Sautier</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">geventhttpclient</remote-id>
+ <remote-id type="github">gwik/geventhttpclient</remote-id>
+ <bugs-to>https://github.com/gwik/geventhttpclient/issues</bugs-to>
+ </upstream>
+</pkgmetadata>