summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-24 06:22:57 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-24 07:14:06 +0200
commit1a9ce26c9e0b4de2297a079fb9f014f97c32f70d (patch)
tree4b79d26ddfdb5dd8c17d7bff5b2efce92cd6bac6 /dev-python/shiboken2
parentnet-dns/libidn2: Bump to 2.3.4 (diff)
downloadgentoo-1a9ce26c9e0b4de2297a079fb9f014f97c32f70d.tar.gz
gentoo-1a9ce26c9e0b4de2297a079fb9f014f97c32f70d.tar.bz2
gentoo-1a9ce26c9e0b4de2297a079fb9f014f97c32f70d.zip
dev-python/shiboken2: Force clang <= 15
No revbump since clang-16 is not keyworded right now, and := will take care of rebuilding with new RDEP once it is. Closes: https://bugs.gentoo.org/873391 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/shiboken2')
-rw-r--r--dev-python/shiboken2/shiboken2-5.15.6.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/dev-python/shiboken2/shiboken2-5.15.6.ebuild b/dev-python/shiboken2/shiboken2-5.15.6.ebuild
index d2d00d980756..02fb51cd1408 100644
--- a/dev-python/shiboken2/shiboken2-5.15.6.ebuild
+++ b/dev-python/shiboken2/shiboken2-5.15.6.ebuild
@@ -40,10 +40,11 @@ RESTRICT="test"
QT_PV="$(ver_cut 1-2):5"
# Since Clang is required at both build- and runtime, BDEPEND is omitted here.
+LLVM_MAX_SLOT=15
RDEPEND="${PYTHON_DEPS}
>=dev-qt/qtcore-${QT_PV}
- sys-devel/clang:=
- sys-devel/clang-runtime:=
+ <sys-devel/clang-16:=
+ <sys-devel/clang-runtime-16:=
docstrings? (
>=dev-libs/libxml2-2.6.32
>=dev-libs/libxslt-1.1.19
@@ -123,7 +124,7 @@ src_configure() {
-DUSE_PYTHON_VERSION="${EPYTHON#python}"
)
# CMakeLists.txt expects LLVM_INSTALL_DIR as an environment variable.
- local -x LLVM_INSTALL_DIR="$(get_llvm_prefix)"
+ local -x LLVM_INSTALL_DIR="$(get_llvm_prefix "${LLVM_MAX_SLOT}")"
cmake_src_configure
}
python_foreach_impl shiboken2_configure