summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-03 06:45:44 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-03 07:37:36 +0200
commit6198c5a8a8b15b26308798ebfe0d9e24f3039660 (patch)
tree8e385a2bcdfd6ce64f99741669afb659b069e4a4 /dev-python/pytest-shell-utilities
parentdev-python/regex: Bump to 2022.6.2 (diff)
downloadgentoo-6198c5a8a8b15b26308798ebfe0d9e24f3039660.tar.gz
gentoo-6198c5a8a8b15b26308798ebfe0d9e24f3039660.tar.bz2
gentoo-6198c5a8a8b15b26308798ebfe0d9e24f3039660.zip
dev-python/pytest-shell-utilities: Bump to 1.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-shell-utilities')
-rw-r--r--dev-python/pytest-shell-utilities/Manifest1
-rw-r--r--dev-python/pytest-shell-utilities/pytest-shell-utilities-1.5.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/pytest-shell-utilities/Manifest b/dev-python/pytest-shell-utilities/Manifest
index 5796acb83aef..84f887ad4850 100644
--- a/dev-python/pytest-shell-utilities/Manifest
+++ b/dev-python/pytest-shell-utilities/Manifest
@@ -4,3 +4,4 @@ DIST pytest-shell-utilities-1.2.0.tar.gz 89881 BLAKE2B 8332f4f6b9b232cc8d17e94ee
DIST pytest-shell-utilities-1.2.1.tar.gz 89975 BLAKE2B 91d0731a2613beef6de98bf7eb61e773659a7047f44558e2ad5cb7c8071761d13f606d04ffb0ac3c6f926f539455cb2a0c2418e398d43d208a028c68bd268576 SHA512 73232844b482f973ad79f2578b434339f34c24cbb36f75ae66217fcd9d06a663d54a6bfcdf390d86d21e6d3b7386fd2f4ce9d6a4b1ce55592be62dbc89f2251f
DIST pytest-shell-utilities-1.3.0.tar.gz 91500 BLAKE2B 88757447378afb334190c6f13406f6a57085bc574728be8965f22b9b17fd92985c044aa9491980d163631eceec634911ea9c67ff85bb9a91ee998e2dab245878 SHA512 1136f4e33c1efb995f7145066af8c71952999975e95c2311ba86ad44c9b18f6f6f5c09acb8211f30cde0f479b3afe92555c125a8f27631f9dd289e4a05bbe761
DIST pytest-shell-utilities-1.4.0.gh.tar.gz 91577 BLAKE2B 33973d3c465918eb71f76497e9c96d3f3f03acfa83e7a116cdef46c67fcf1ba9d1e4b14f50c56c5a20c1bd85e16101f9a98ef93d19099cd97077b336a0aa4954 SHA512 75d8a25d6d607db9697900f36f326d1b86b948da6c83c7840c52a63964ed8cfcf1c54d343f607bcb2b5db3b471e7b59e3aea21d6f4943339f1f2e0388f22b29b
+DIST pytest-shell-utilities-1.5.0.gh.tar.gz 92287 BLAKE2B 015f78838eaff93438cbd7cd395926ac8f61653f6d27275ca87b379e5f27d60165157880e41e603823c17e639dcff91ac4f5fda1e904ad505bb9db0a577b800c SHA512 00cb5fa6979e09c90ba82928a135f644dd4056fd004f6bee8d216ca63e2cf4549f944930bf16e7a124f26a79c1b696d18ecf210bee3273343b9a90f9126f340e
diff --git a/dev-python/pytest-shell-utilities/pytest-shell-utilities-1.5.0.ebuild b/dev-python/pytest-shell-utilities/pytest-shell-utilities-1.5.0.ebuild
new file mode 100644
index 000000000000..a8e84f1cb8c6
--- /dev/null
+++ b/dev-python/pytest-shell-utilities/pytest-shell-utilities-1.5.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="pytest plugin: fixtures and code to help with running shell commands on tests"
+HOMEPAGE="
+ https://pypi.org/project/pytest-shell-utilities/
+ https://github.com/saltstack/pytest-shell-utilities/
+"
+SRC_URI="
+ https://github.com/saltstack/pytest-shell-utilities/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/pytest-6.0.0[${PYTHON_USEDEP}]
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ dev-python/pytest-helpers-namespace[${PYTHON_USEDEP}]
+ dev-python/pytest-skip-markers[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-subtests[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}