summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-25 09:05:17 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-25 09:09:25 +0100
commit34346dc38575b2249fad376ca338f62c067c624b (patch)
treeec21c36f8af1b79e2ca20198dea8b3f1e7af3a2f /dev-python/pytest-plus
parentdev-python/doc8: Bump to 1.1.1 (diff)
downloadgentoo-34346dc38575b2249fad376ca338f62c067c624b.tar.gz
gentoo-34346dc38575b2249fad376ca338f62c067c624b.tar.bz2
gentoo-34346dc38575b2249fad376ca338f62c067c624b.zip
dev-python/pytest-plus: Bump to 0.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-plus')
-rw-r--r--dev-python/pytest-plus/Manifest1
-rw-r--r--dev-python/pytest-plus/pytest-plus-0.4.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pytest-plus/Manifest b/dev-python/pytest-plus/Manifest
index 1b1dc87fd5ca..4895244f6557 100644
--- a/dev-python/pytest-plus/Manifest
+++ b/dev-python/pytest-plus/Manifest
@@ -1 +1,2 @@
DIST pytest-plus-0.2.tar.gz 8210 BLAKE2B b8a28e72cfb4e10daa021528de9b5df2e9eb0bc4e911557c7c14a0825284787e94992132c0b74881867a41b55a67785c60b9b87a1594ad33fb57ebac8de391a6 SHA512 e16a03433cb6eb30b6881bec99482bc65cb7d1fa3d0db855befe666c0645d4b5ec02debde9dec4322ed0a0b77d3ac3f1cabda0cf98f375ffd68dc29fb55f5139
+DIST pytest-plus-0.4.0.tar.gz 9987 BLAKE2B 11b8f17630601f52ebae11b7a660c8d97b4c9f1699096a376c162952a03b9f1b580ead6ac0b040b15c267eec1123bffe07d128eb00aec7414e996275ebc4c4e3 SHA512 4f4258853280cac8e03c0477763fd588d2b3cf11e7746d2b8e7d3cf5774b845412bc8779d74d232e4b3473470c39753dc788ac09faf8e8b7c9fee22d7164bab7
diff --git a/dev-python/pytest-plus/pytest-plus-0.4.0.ebuild b/dev-python/pytest-plus/pytest-plus-0.4.0.ebuild
new file mode 100644
index 000000000000..04fa7dc378ba
--- /dev/null
+++ b/dev-python/pytest-plus/pytest-plus-0.4.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="PyTest Plus Plugin - extends pytest functionality"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-plus/
+ https://pypi.org/project/pytest-plus/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="
+ >=dev-python/pytest-6.0.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools_scm-7.0.5[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest