summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-13 06:33:05 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-13 06:54:54 +0200
commit7faae872df81952c07f90223d5f9eda433bdd872 (patch)
tree344457893d0d98e91b1e538333ff032667f36b85 /dev-python/prettytable
parentdev-python/pygal: Bump to 3.0.5 (diff)
downloadgentoo-7faae872df81952c07f90223d5f9eda433bdd872.tar.gz
gentoo-7faae872df81952c07f90223d5f9eda433bdd872.tar.bz2
gentoo-7faae872df81952c07f90223d5f9eda433bdd872.zip
dev-python/prettytable: Bump to 3.11.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/prettytable')
-rw-r--r--dev-python/prettytable/Manifest1
-rw-r--r--dev-python/prettytable/prettytable-3.11.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/prettytable/Manifest b/dev-python/prettytable/Manifest
index e5999738cc20..faa183a08cd5 100644
--- a/dev-python/prettytable/Manifest
+++ b/dev-python/prettytable/Manifest
@@ -1 +1,2 @@
DIST prettytable-3.10.2.tar.gz 56415 BLAKE2B 0deb8132124f9c19ecaeea46749dda834c758378163646e16e0553b75ad6842b44fe5904ba181d6a2b0c3a822f23cd569977a8168d9245b2e9f08ed16da0089e SHA512 6a71f7d7b6fddca75e4b1bfd96ca6e26301c0c231be4703fe9c59e1c13a1482f814fbbfd661d1fc6bb37346f55a7488b794d5041016faf68711297a8cbdbe5c5
+DIST prettytable-3.11.0.tar.gz 57527 BLAKE2B 494f3ff0802b29a419f58310a0ad50ccd1ae39845ad5167956f68ab674a2b357d098e28426c8df6a889026eaf397593018070d441cff20f0a01b76c51470a482 SHA512 3da3dcaeef1f8ce224381a6a12e56a7220e7bf7bc6a99402cd0ae68703d0630beb42f6575c86981f1ff5f592283a990398d6dd1bbdcc21074f77cab4739683b7
diff --git a/dev-python/prettytable/prettytable-3.11.0.ebuild b/dev-python/prettytable/prettytable-3.11.0.ebuild
new file mode 100644
index 000000000000..21f867b499ce
--- /dev/null
+++ b/dev-python/prettytable/prettytable-3.11.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Easily displaying tabular data in a visually appealing ASCII table format"
+HOMEPAGE="
+ https://github.com/jazzband/prettytable/
+ https://pypi.org/project/prettytable/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ $(python_gen_impl_dep sqlite)
+ dev-python/pytest-lazy-fixtures[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest