summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-31 20:25:47 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-31 20:29:21 +0200
commit52fedd5874bc2e290ef1bee6d230bfac5cc3529d (patch)
tree6c21cba0f6b428f7526be28702fc6830c1157d5d /dev-python/libarchive-c
parentdev-python/latexcodec: Enable py3.12 (diff)
downloadgentoo-52fedd5874bc2e290ef1bee6d230bfac5cc3529d.tar.gz
gentoo-52fedd5874bc2e290ef1bee6d230bfac5cc3529d.tar.bz2
gentoo-52fedd5874bc2e290ef1bee6d230bfac5cc3529d.zip
dev-python/libarchive-c: Modernize
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/libarchive-c')
-rw-r--r--dev-python/libarchive-c/Manifest1
-rw-r--r--dev-python/libarchive-c/libarchive-c-4.0-r1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/libarchive-c/Manifest b/dev-python/libarchive-c/Manifest
index 009a87bd751e..fc8504389ded 100644
--- a/dev-python/libarchive-c/Manifest
+++ b/dev-python/libarchive-c/Manifest
@@ -1 +1,2 @@
DIST libarchive-c-4.0.gh.tar.gz 47743 BLAKE2B c6246b35a9a389c6cd999b32412436f8134737a4cba1c0bf8a905e3ba6e1653c515956f43a580901dd4278cbc00b783ecfa7a4306f0fc7ca2d2666b3af500cb8 SHA512 787b049a5f06d7370369a6bb2d9ebab6e4e5eda0a4f839906e205a7e19a00f9f7e350d4c42e3434e345063dd0ea44e5b0b4c0524033b05a6d8f15758757c5c36
+DIST python-libarchive-c-4.0.gh.tar.gz 47727 BLAKE2B 87f8cfb0adf080b11df85d065fbcc38bf5682592882b3a8a8077e5cfb590cc10a05b98c98a2be41570aa59d06899b2e47815183e563007b1077717cdaa79a21c SHA512 1544713802789859ffa9a0d8f4e490f720bbd4d589aae8899d0d1fb6780f2cde0db96f3023c1c32eacea07ea325ac180797aebdb0e8e37093af53807f2e5c812
diff --git a/dev-python/libarchive-c/libarchive-c-4.0-r1.ebuild b/dev-python/libarchive-c/libarchive-c-4.0-r1.ebuild
new file mode 100644
index 000000000000..522de5a8385b
--- /dev/null
+++ b/dev-python/libarchive-c/libarchive-c-4.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+MY_P=python-libarchive-c-${PV}
+DESCRIPTION="A Python interface to libarchive"
+HOMEPAGE="
+ https://github.com/Changaco/python-libarchive-c/
+ https://pypi.org/project/libarchive-c/
+"
+SRC_URI="
+ https://github.com/Changaco/python-libarchive-c/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="CC0-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc64 ~x86"
+
+RDEPEND="
+ app-arch/libarchive
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest