summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-29 12:12:32 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-29 12:50:20 +0200
commit5c5a45227439408d91db7a1ffb6ecddd90f7c63c (patch)
tree49977997597f2991a50be71fc234e97925a5b00f /dev-python/elementpath
parentmedia-plugins/qmmp-plugin-pack: add 1.6.1, ffmpeg slot op (diff)
downloadgentoo-5c5a45227439408d91db7a1ffb6ecddd90f7c63c.tar.gz
gentoo-5c5a45227439408d91db7a1ffb6ecddd90f7c63c.tar.bz2
gentoo-5c5a45227439408d91db7a1ffb6ecddd90f7c63c.zip
dev-python/elementpath: Enable py3.12
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/elementpath')
-rw-r--r--dev-python/elementpath/elementpath-4.1.2.ebuild17
1 files changed, 15 insertions, 2 deletions
diff --git a/dev-python/elementpath/elementpath-4.1.2.ebuild b/dev-python/elementpath/elementpath-4.1.2.ebuild
index 55532d1d5a5e..93f8579d6754 100644
--- a/dev-python/elementpath/elementpath-4.1.2.ebuild
+++ b/dev-python/elementpath/elementpath-4.1.2.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
inherit distutils-r1 pypi
@@ -25,10 +25,23 @@ BDEPEND="
)
"
-distutils_enable_tests unittest
+distutils_enable_tests pytest
src_prepare() {
# fails for some reason, more fit for upstream testing anyway
rm tests/test_typing.py || die
distutils-r1_src_prepare
}
+
+python_test() {
+ local EPYTEST_DESELECT=()
+ if [[ ${EPYTHON} == python3.12 ]]; then
+ EPYTEST_DESELECT+=(
+ # sometimes fails with precision problems
+ # https://github.com/sissaschool/elementpath/issues/66
+ tests/test_xpath1_parser.py::LxmlXPath1ParserTest::test_sum_function
+ )
+ fi
+
+ epytest
+}