summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-11 18:41:43 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-11 19:25:38 +0200
commit452a22c4ccb88e6eb59dbb8b278d06afd9428a8d (patch)
tree7f72453e99c66535cccd1df129d46d959dd7d2b8 /dev-python/elementpath
parentdev-python/beartype: Bump to 0.13.1 (diff)
downloadgentoo-452a22c4ccb88e6eb59dbb8b278d06afd9428a8d.tar.gz
gentoo-452a22c4ccb88e6eb59dbb8b278d06afd9428a8d.tar.bz2
gentoo-452a22c4ccb88e6eb59dbb8b278d06afd9428a8d.zip
dev-python/elementpath: Bump to 4.1.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/elementpath')
-rw-r--r--dev-python/elementpath/Manifest1
-rw-r--r--dev-python/elementpath/elementpath-4.1.1.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/elementpath/Manifest b/dev-python/elementpath/Manifest
index df0c7587a1cd..e41ed2f39feb 100644
--- a/dev-python/elementpath/Manifest
+++ b/dev-python/elementpath/Manifest
@@ -1,2 +1,3 @@
DIST elementpath-4.0.1.gh.tar.gz 305205 BLAKE2B 0de825213e91c5eb51b8b07973a311e982c0812180ac6bf79ac3357c7a747ff25b2126c5687a71fc06a619309749aee518ecf18bfa64335e0a5a93249579dace SHA512 22f76c028e665282fb81a99939c870c742461f5a107788fde398e88d4e59850161a4a7ab3159ce01076933cf211fcc4ec3e5727719e10520978ba33c9a13903d
DIST elementpath-4.1.0.tar.gz 317239 BLAKE2B 9a8b0832a866ac8cec524dc42ce4fa99c015bc8becd122ebcb13bb297d2aab3267941b0739f30ad4487d3ed405a2b192e29de0134895493c90ba2f360fdcbb75 SHA512 af40c4a2a0b97c4a39b79f12e8d7a1ec6600282684bf3bbb722e88c28a517d24db7795551d06f4b0f2f87113f93e18ff6cfb15fd142cd33b47388e69f66de9ea
+DIST elementpath-4.1.1.tar.gz 318449 BLAKE2B 3e472ad273a64926a3f63038d2cf5a480bf96f1af96675c23e5c3d2208e72a75f4478e10b82c8956509414c477473ec45163e8df58844dd5702804c65668d61f SHA512 95f2c238404718ff425d3f6be727a2620f519ecf41036c03148184225e968ce3b26a0c8247bf30eb1e0a8883febfc604ff38fa01c573cd26b81bd90ac79f6eed
diff --git a/dev-python/elementpath/elementpath-4.1.1.ebuild b/dev-python/elementpath/elementpath-4.1.1.ebuild
new file mode 100644
index 000000000000..55532d1d5a5e
--- /dev/null
+++ b/dev-python/elementpath/elementpath-4.1.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="XPath 1.0/2.0 parsers and selectors for ElementTree and lxml"
+HOMEPAGE="
+ https://github.com/sissaschool/elementpath/
+ https://pypi.org/project/elementpath/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+BDEPEND="
+ test? (
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/xmlschema[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # fails for some reason, more fit for upstream testing anyway
+ rm tests/test_typing.py || die
+ distutils-r1_src_prepare
+}