summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-12 09:45:46 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-12 10:37:02 +0200
commitb368ebb2574cbeb5b70a670a54857ffa455dfb94 (patch)
treeccbab5bb59ae465eed3b4fcc650d1f1c0bbaa24f /dev-python/click
parentdev-python/werkzeug: Bump to 2.0.0 (diff)
downloadgentoo-b368ebb2574cbeb5b70a670a54857ffa455dfb94.tar.gz
gentoo-b368ebb2574cbeb5b70a670a54857ffa455dfb94.tar.bz2
gentoo-b368ebb2574cbeb5b70a670a54857ffa455dfb94.zip
dev-python/click: Bump to 8.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/click')
-rw-r--r--dev-python/click/Manifest1
-rw-r--r--dev-python/click/click-8.0.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/click/Manifest b/dev-python/click/Manifest
index a1e3db9c7a82..d87af49097bb 100644
--- a/dev-python/click/Manifest
+++ b/dev-python/click/Manifest
@@ -1 +1,2 @@
DIST click-7.1.2.tar.gz 295757 BLAKE2B aea76d5378cfa49fe58a83132737d609d48b3d3a71ec65c0a8a144c7a0e244b5bdf0196ffe2150889b82edda20c3f1faa3c84a227fc9ef459a5a9646cff86129 SHA512 d0caf2fb0a258774a18a7b8f83bdfa73abeb70196a70b45a6cc35befaeb862d068d2f2cce4e27201ab2e3adcd02e7e2f099d6c37c497a507010eefa10ad16eba
+DIST click-8.0.0.tar.gz 329520 BLAKE2B a3a5e299390c8223794c31fd0278367ed941923f81e73e2b4ac878ef670b156de9de4b8d539e1d0a968b8ff99764086b34ebf50d3afe3afa7060aeafc7ed8831 SHA512 656509d4eb49ce46738d09499a924a6064857d13995c0ec289b9a731c05165582c30fd4a8a09d0531ace77c217a9d4ba3f305ba2843c7879d90c84a78072046d
diff --git a/dev-python/click/click-8.0.0.ebuild b/dev-python/click/click-8.0.0.ebuild
new file mode 100644
index 000000000000..6d9663b156cc
--- /dev/null
+++ b/dev-python/click/click-8.0.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python package for creating beautiful command line interfaces"
+SRC_URI="https://github.com/pallets/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="https://palletsprojects.com/p/click/ https://pypi.org/project/click/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="examples"
+
+distutils_enable_sphinx docs \
+ '>=dev-python/docutils-0.14' \
+ dev-python/pallets-sphinx-themes
+distutils_enable_tests pytest
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}