summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-05-15 08:34:50 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-05-15 08:34:50 +0200
commitacd83790f473073286a1834a978129c6adc703e1 (patch)
tree0bb092e0cede9bf45c2b166daaad4961d309e131 /dev-python/catkin_pkg
parentdev-ros/interactive_markers: bump to 1.11.4 (diff)
downloadgentoo-acd83790f473073286a1834a978129c6adc703e1.tar.gz
gentoo-acd83790f473073286a1834a978129c6adc703e1.tar.bz2
gentoo-acd83790f473073286a1834a978129c6adc703e1.zip
dev-python/catkin_pkg: bump to 0.4.2 and fix tests
Package-Manager: Portage-2.3.36, Repoman-2.3.9
Diffstat (limited to 'dev-python/catkin_pkg')
-rw-r--r--dev-python/catkin_pkg/Manifest1
-rw-r--r--dev-python/catkin_pkg/catkin_pkg-0.4.2.ebuild47
-rw-r--r--dev-python/catkin_pkg/files/catkin_prefix.patch2
-rw-r--r--dev-python/catkin_pkg/files/ros_packages.patch2
4 files changed, 50 insertions, 2 deletions
diff --git a/dev-python/catkin_pkg/Manifest b/dev-python/catkin_pkg/Manifest
index bdeeb5ed96a9..413b7da1d4b9 100644
--- a/dev-python/catkin_pkg/Manifest
+++ b/dev-python/catkin_pkg/Manifest
@@ -1,2 +1,3 @@
DIST catkin_pkg-0.3.9-gh.tar.gz 48290 BLAKE2B fbba89008946433007f1016addeb73e44108b057609d52d693e80024460c5d77686bde241331845d36068b23e87a4ac33dcc0c6c29af95c4e86e8a30bbe52918 SHA512 39c7dbd7b3bb7d0fd7f37e6931e5de8c76c28ca329db5783d1cf0b01e9a7f58079c45434d937a8edcf29cbdebdcfb4b18480508d688dcefdf58c218838af65c8
DIST catkin_pkg-0.4.1-gh.tar.gz 50886 BLAKE2B 03a5205271fd3f12e4a3bcd093d8e1811d3a1e3197292004e9dd4e255fa10741fdb90a754df4a1fd6705f305e524413cdb7a8dc9f5174a162a20ffa95cfc3b2e SHA512 d7802bbfd0187f1411d36fbecca2afa43dc55f54441a6e0ddc54c2153bf1c553cfa76e5a3d1d08a92fe765c530d1668a762eaaf45e1f68b61c2cf6d1ec49e4a7
+DIST catkin_pkg-0.4.2-gh.tar.gz 52930 BLAKE2B 2b8589441d241197c661975c07c60856c614c4c328e441e6fbb1cb41ea2919f57864f67198b684eba7183004671df0980ddcf0070a53099074433166b5d7db20 SHA512 cb47771172d88792bc7039f072175a6f410aa046e2611ccc75e46bda388d620ac0059e0fa9e087fbb7f2833600a7233d714c1aeeab65e264606d8ae2e64d76bb
diff --git a/dev-python/catkin_pkg/catkin_pkg-0.4.2.ebuild b/dev-python/catkin_pkg/catkin_pkg-0.4.2.ebuild
new file mode 100644
index 000000000000..f74d5f891e53
--- /dev/null
+++ b/dev-python/catkin_pkg/catkin_pkg-0.4.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/ros-infrastructure/catkin_pkg"
+fi
+
+inherit ${SCM} distutils-r1
+
+DESCRIPTION="Standalone Python library for the catkin package system"
+HOMEPAGE="http://wiki.ros.org/catkin_pkg"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/ros-infrastructure/catkin_pkg/archive/${PV}.tar.gz -> ${P}-gh.tar.gz"
+ KEYWORDS="~amd64 ~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-python/mock[${PYTHON_USEDEP}] dev-python/nose[${PYTHON_USEDEP}] )
+"
+PATCHES=(
+ "${FILESDIR}/catkin_prefix.patch"
+ "${FILESDIR}/argparse.patch"
+ "${FILESDIR}/ros_packages.patch"
+ "${FILESDIR}/infinite_loop2.patch"
+)
+
+python_test() {
+ nosetests -s --tests test || die
+}
diff --git a/dev-python/catkin_pkg/files/catkin_prefix.patch b/dev-python/catkin_pkg/files/catkin_prefix.patch
index c5f40db51cd1..fe9cc347882b 100644
--- a/dev-python/catkin_pkg/files/catkin_prefix.patch
+++ b/dev-python/catkin_pkg/files/catkin_prefix.patch
@@ -19,7 +19,7 @@ Index: catkin_pkg-0.2.8/src/catkin_pkg/workspaces.py
if paths is None:
- if 'CMAKE_PREFIX_PATH' not in os.environ:
- raise RuntimeError('Neither the environment variable CMAKE_PREFIX_PATH is set nor was a list of paths passed.')
-+ if 'CMAKE_PREFIX_PATH' not in os.environ and 'CATKIN_PREFIX_PATH' not in os.environ :
++ if 'CMAKE_PREFIX_PATH' not in os.environ and 'CATKIN_PREFIX_PATH' not in os.environ:
+ raise RuntimeError('None of the environment variables CMAKE_PREFIX_PATH or CATKIN_PREFIX_PATH are set nor was a list of paths passed.')
paths = os.environ['CMAKE_PREFIX_PATH'].split(os.pathsep) if os.environ['CMAKE_PREFIX_PATH'] else []
+ paths += os.environ['CATKIN_PREFIX_PATH'].split(os.pathsep) if os.environ['CATKIN_PREFIX_PATH'] else []
diff --git a/dev-python/catkin_pkg/files/ros_packages.patch b/dev-python/catkin_pkg/files/ros_packages.patch
index 6c9855d627c9..06933d69a9fa 100644
--- a/dev-python/catkin_pkg/files/ros_packages.patch
+++ b/dev-python/catkin_pkg/files/ros_packages.patch
@@ -7,7 +7,7 @@ Index: catkin_pkg-0.3.1/src/catkin_pkg/packages.py
continue
elif PACKAGE_MANIFEST_FILENAME in filenames:
- paths.append(os.path.relpath(dirpath, basepath))
-+ paths.append(os.path.relpath(dirpath.replace('ros_packages/',''), basepath))
++ paths.append(os.path.relpath(dirpath.replace('ros_packages/', ''), basepath))
del dirnames[:]
continue
for dirname in dirnames: