summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-05 10:18:36 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-05 10:18:36 +0200
commitf1cb3f334ae3f35334711622a19b37cd833cee99 (patch)
tree3c6d71ee5051756a26396d103da4013df3a22115 /dev-python/autopep8
parentdev-python/roman: Remove old (diff)
downloadgentoo-f1cb3f334ae3f35334711622a19b37cd833cee99.tar.gz
gentoo-f1cb3f334ae3f35334711622a19b37cd833cee99.tar.bz2
gentoo-f1cb3f334ae3f35334711622a19b37cd833cee99.zip
dev-python/autopep8: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/autopep8')
-rw-r--r--dev-python/autopep8/Manifest1
-rw-r--r--dev-python/autopep8/autopep8-2.0.1.ebuild47
2 files changed, 0 insertions, 48 deletions
diff --git a/dev-python/autopep8/Manifest b/dev-python/autopep8/Manifest
index a77ee98909f3..4f71b2b72ab9 100644
--- a/dev-python/autopep8/Manifest
+++ b/dev-python/autopep8/Manifest
@@ -1,2 +1 @@
-DIST autopep8-2.0.1.tar.gz 115905 BLAKE2B 9dde8d702a0b21fb1457e08120dca805e2b46e3e5284e5d98932ff93afc4c0ac8dbc60215f35b64d4a308d6748df1411c2979d8fa1f4949b1dbe213bf19de9dc SHA512 cc0e8e5b7228ba9b37adaa3b2689a5e1ad04eb84366c5300d7a220b1593a64e4f1dc332750f8ca53935dec6a3ea1d07cae5615373e44da357a980d9763bbc3f1
DIST autopep8-2.0.2.tar.gz 116154 BLAKE2B 1b6830f9cb8a4384898273411f6b03cf3e3c0e45e2c56fa2bb134f3567cc06459a8123e660db9252f8d7cd15835d70e54c0155f146191be64ffbafaaa808244d SHA512 09471827d18ca0c691bc524e0639a416d1a4418ddda1cb88f50e5c5302e75e7014751e659e26439c22317db21588fbd956c94299cef44e2c47771df38de94be3
diff --git a/dev-python/autopep8/autopep8-2.0.1.ebuild b/dev-python/autopep8/autopep8-2.0.1.ebuild
deleted file mode 100644
index 807955f05f3e..000000000000
--- a/dev-python/autopep8/autopep8-2.0.1.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Automatically formats Python code to conform to the PEP 8 style guide"
-HOMEPAGE="
- https://github.com/hhatto/autopep8/
- https://pypi.org/project/autopep8/
-"
-if [[ ${PV} == *9999* ]]; then
- EGIT_REPO_URI="https://github.com/hhatto/${PN}.git"
- inherit git-r3
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="~alpha amd64 ~arm64 ~ia64 ppc ~ppc64 sparc x86 ~amd64-linux ~x86-linux"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-
-RDEPEND="
- >=dev-python/pycodestyle-2.10[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/tomli[${PYTHON_USEDEP}]
- ' 3.{8..10})
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=()
-
- [[ ${EPYTHON} == python3.11 ]] && EPYTEST_DESELECT+=(
- # fails due to deprecation warnings
- test/test_autopep8.py::CommandLineTests::test_in_place_no_modifications_no_writes
- test/test_autopep8.py::CommandLineTests::test_in_place_no_modifications_no_writes_with_empty_file
- )
-
- epytest
-}