summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-05-22 03:26:27 +0100
committerSam James <sam@gentoo.org>2024-05-22 03:26:31 +0100
commiteb6d0c1e3724f101f58c262dc6319c068b882974 (patch)
tree72f3d5d33a76d1a0dd0b589b256740df2c51e570 /dev-perl/Bit-Vector
parentdev-lang/perl: fix UnusedLocalUse (diff)
downloadgentoo-eb6d0c1e3724f101f58c262dc6319c068b882974.tar.gz
gentoo-eb6d0c1e3724f101f58c262dc6319c068b882974.tar.bz2
gentoo-eb6d0c1e3724f101f58c262dc6319c068b882974.zip
dev-perl/Bit-Vector: EAPI 8, rely on eclass impls
This covers more variables/args, etc. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-perl/Bit-Vector')
-rw-r--r--dev-perl/Bit-Vector/Bit-Vector-7.400.0-r3.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-perl/Bit-Vector/Bit-Vector-7.400.0-r3.ebuild b/dev-perl/Bit-Vector/Bit-Vector-7.400.0-r3.ebuild
new file mode 100644
index 000000000000..a467fcccf922
--- /dev/null
+++ b/dev-perl/Bit-Vector/Bit-Vector-7.400.0-r3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=STBEY
+DIST_VERSION=7.4
+inherit perl-module
+
+DESCRIPTION="Efficient bit vector, set of integers and big int math library"
+
+# License note: upstream mess, bug #721222, upstream is fine with "perl"
+# https://rt.cpan.org/Public/Bug/Display.html?id=132512
+
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="
+ >=dev-perl/Carp-Clan-5.300.0
+ >=virtual/perl-Storable-2.210.0
+"
+BDEPEND="
+ ${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"