summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-lua/LuaBitOp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-lua/LuaBitOp')
-rw-r--r--dev-lua/LuaBitOp/LuaBitOp-1.0.1-r1.ebuild44
-rw-r--r--dev-lua/LuaBitOp/LuaBitOp-1.0.2-r1.ebuild44
-rw-r--r--dev-lua/LuaBitOp/LuaBitOp-1.0.2.ebuild33
-rw-r--r--dev-lua/LuaBitOp/Manifest2
-rw-r--r--dev-lua/LuaBitOp/files/LuaBitOp-ldflags.patch13
-rw-r--r--dev-lua/LuaBitOp/metadata.xml13
6 files changed, 149 insertions, 0 deletions
diff --git a/dev-lua/LuaBitOp/LuaBitOp-1.0.1-r1.ebuild b/dev-lua/LuaBitOp/LuaBitOp-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..20393e533140
--- /dev/null
+++ b/dev-lua/LuaBitOp/LuaBitOp-1.0.1-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+inherit eutils multilib
+
+DESCRIPTION="Bit Operations Library for the Lua Programming Language"
+HOMEPAGE="http://bitop.luajit.org"
+SRC_URI="http://bitop.luajit.org/download/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="=dev-lang/lua-5.1*"
+RDEPEND="${DEPEND}"
+
+src_prepare()
+{
+ sed -i \
+ -e '/^CFLAGS.*=/s/=/ +=/' \
+ -e '/^CFLAGS/s/-O2 -fomit-frame-pointer //' \
+ Makefile || die "sed failed"
+ epatch "${FILESDIR}/${PN}-ldflags.patch"
+}
+
+src_compile()
+{
+ emake CC="$(tc-getCC)"
+}
+
+src_test()
+{
+ make test
+}
+
+src_install()
+{
+ exeinto /usr/$(get_libdir)/lua/5.1
+doexe bit.so
+ dohtml -r doc/*
+}
diff --git a/dev-lua/LuaBitOp/LuaBitOp-1.0.2-r1.ebuild b/dev-lua/LuaBitOp/LuaBitOp-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..996207a3f95d
--- /dev/null
+++ b/dev-lua/LuaBitOp/LuaBitOp-1.0.2-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+inherit toolchain-funcs multilib-minimal
+
+DESCRIPTION="Bit Operations Library for the Lua Programming Language"
+HOMEPAGE="http://bitop.luajit.org"
+SRC_URI="http://bitop.luajit.org/download/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~hppa ~mips ppc ppc64 sparc x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/lua-5.1.5-r2[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]"
+
+src_prepare() {
+ multilib_copy_sources
+}
+
+multilib_src_compile()
+{
+ emake CC="$(tc-getCC)" INCLUDES= CCOPT=
+}
+
+multilib_src_test() {
+ # tests use native lua interpreter
+ multilib_is_native_abi && default
+}
+
+multilib_src_install()
+{
+ exeinto "$($(tc-getPKG_CONFIG) --variable INSTALL_CMOD lua)"
+ doexe bit.so
+}
+
+multilib_src_install_all() {
+ dodoc README
+ dohtml -r doc/.
+}
diff --git a/dev-lua/LuaBitOp/LuaBitOp-1.0.2.ebuild b/dev-lua/LuaBitOp/LuaBitOp-1.0.2.ebuild
new file mode 100644
index 000000000000..ac44c383267d
--- /dev/null
+++ b/dev-lua/LuaBitOp/LuaBitOp-1.0.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+inherit toolchain-funcs
+
+DESCRIPTION="Bit Operations Library for the Lua Programming Language"
+HOMEPAGE="http://bitop.luajit.org"
+SRC_URI="http://bitop.luajit.org/download/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm hppa ~mips x86"
+IUSE=""
+
+RDEPEND="dev-lang/lua"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_compile()
+{
+ emake CC="$(tc-getCC)" INCLUDES= CCOPT=
+}
+
+src_install()
+{
+ exeinto "$(pkg-config --variable INSTALL_CMOD lua)"
+ doexe bit.so
+
+ dodoc README
+ dohtml -r doc/*
+}
diff --git a/dev-lua/LuaBitOp/Manifest b/dev-lua/LuaBitOp/Manifest
new file mode 100644
index 000000000000..2c09cfe49ecc
--- /dev/null
+++ b/dev-lua/LuaBitOp/Manifest
@@ -0,0 +1,2 @@
+DIST LuaBitOp-1.0.1.tar.gz 22984 SHA256 6afa9984411079a7e109977bc8a28d63890c1489a928b1f61d33ef327e9cb0c9 SHA512 de326ba899b70ea01c41b02d26b1a5afd07bdeee5628be7cbeaa438452ac4343cab01494ac3e5e6758365de15c5cb9c211e17f2e4dd1e0e9258979d06018c71e WHIRLPOOL 166203b5306df2b85ce757fe697f7fa9c4ce185f6d0f8cb2491526b874385d7280c9a91b5d45bada76b28d9e7ca0c7881a97965c646f3c09683e8bc37dcc2998
+DIST LuaBitOp-1.0.2.tar.gz 23127 SHA256 1207c9293dcd52eb9dca6538d1b87352bd510f4e760938f5048433f7f272ce99 SHA512 a652050ea5c6fbeb8a28b05e2bc4a3550c854cc45f7f42c8c1b0a81f5b76773cdf061e6a839cdb339614118169e578b6e3efa5a3efbe59a2f01874b2fa2b4f2e WHIRLPOOL 1c9081e805f0c31dc806e3966d6d2639b3b4f0ff8d81850a78633581c8c975b52caefab80d50985093ed891de1fdefaed0a96c0ab985b23c73fa1e60a873385c
diff --git a/dev-lua/LuaBitOp/files/LuaBitOp-ldflags.patch b/dev-lua/LuaBitOp/files/LuaBitOp-ldflags.patch
new file mode 100644
index 000000000000..2a690cdb5866
--- /dev/null
+++ b/dev-lua/LuaBitOp/files/LuaBitOp-ldflags.patch
@@ -0,0 +1,13 @@
+Index: LuaBitOp-1.0.1/Makefile
+===================================================================
+--- LuaBitOp-1.0.1.orig/Makefile
++++ LuaBitOp-1.0.1/Makefile
+@@ -14,7 +14,7 @@ LUA= lua
+
+ CC= gcc
+ SOCFLAGS= -fPIC
+-SOCC= $(CC) -shared $(SOCFLAGS)
++SOCC= $(CC) -shared $(SOCFLAGS) $(LDFLAGS)
+ CFLAGS += -Wall $(SOCFLAGS) $(DEFINES) $(INCLUDES)
+ RM= rm -f
+ INSTALL= install -p
diff --git a/dev-lua/LuaBitOp/metadata.xml b/dev-lua/LuaBitOp/metadata.xml
new file mode 100644
index 000000000000..b5d15851659b
--- /dev/null
+++ b/dev-lua/LuaBitOp/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>williamh@gentoo.org</email>
+ <name>William Hubbs</name>
+ </maintainer>
+ <longdescription lang="en">
+ This is a library for the Lua programming language which performs bit
+ operations.
+ </longdescription>
+</pkgmetadata>
+