summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/sdformat
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/sdformat')
-rw-r--r--dev-libs/sdformat/Manifest1
-rw-r--r--dev-libs/sdformat/metadata.xml8
-rw-r--r--dev-libs/sdformat/sdformat-2.3.2.ebuild35
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-libs/sdformat/Manifest b/dev-libs/sdformat/Manifest
new file mode 100644
index 000000000000..948c801bf6df
--- /dev/null
+++ b/dev-libs/sdformat/Manifest
@@ -0,0 +1 @@
+DIST sdformat2_2.3.2.tar.bz2 407034 SHA256 6207f90a29e6ba18bdeef116d98e92bfdbdaeb7f2a8cd40345727b6661be5998 SHA512 53e93ad69869072071293d6fc0ed840f84d8fff34f1fdf56465fe7d48f41f8fdb45723611b5be3776790717466883f602396c6eb9510a7e8f71ee1031d42140f WHIRLPOOL 0e592d44c12cd51be3bced7de472e268ba34da3b5ad03f85e0433fb0fd7d789cedfd8c746ad88b79c0fddf92c1bfca9aae4f97742dba293422adfadc1888ca50
diff --git a/dev-libs/sdformat/metadata.xml b/dev-libs/sdformat/metadata.xml
new file mode 100644
index 000000000000..e7dd05f66879
--- /dev/null
+++ b/dev-libs/sdformat/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>aballier@gentoo.org</email>
+<name>Alexis Ballier</name>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-libs/sdformat/sdformat-2.3.2.ebuild b/dev-libs/sdformat/sdformat-2.3.2.ebuild
new file mode 100644
index 000000000000..c569a0af61e3
--- /dev/null
+++ b/dev-libs/sdformat/sdformat-2.3.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils versionator vcs-snapshot
+
+DESCRIPTION="Simulation Description Format (SDF) parser"
+HOMEPAGE="http://sdformat.org/"
+SRC_URI="https://bitbucket.org/osrf/sdformat/get/${PN}$(get_major_version)_${PV}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ dev-libs/urdfdom
+ dev-libs/tinyxml
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+S="${WORKDIR}/${PN}$(get_major_version)_${PV}"
+
+src_configure() {
+ local mycmakeargs=(
+ "-DUSE_UPSTREAM_CFLAGS=OFF"
+ "-DUSE_EXTERNAL_URDF=ON"
+ "-DUSE_EXTERNAL_TINYXML=ON"
+ )
+ cmake-utils_src_configure
+}