summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-01-09 10:11:31 +0100
committerLars Wendler <polynomial-c@gentoo.org>2020-01-09 10:11:31 +0100
commit16e5ce7866f3fb09730adc32e9df1cf56a99cb0a (patch)
treeaee2b76366fc676687f7061485a9d739500129e3 /dev-libs/libgpg-error
parentdev-libs/libgpg-error: Removed old (diff)
downloadgentoo-16e5ce7866f3fb09730adc32e9df1cf56a99cb0a.tar.gz
gentoo-16e5ce7866f3fb09730adc32e9df1cf56a99cb0a.tar.bz2
gentoo-16e5ce7866f3fb09730adc32e9df1cf56a99cb0a.zip
dev-libs/libgpg-error: Simplified ebuild a bit
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'dev-libs/libgpg-error')
-rw-r--r--dev-libs/libgpg-error/libgpg-error-1.36.ebuild22
1 files changed, 12 insertions, 10 deletions
diff --git a/dev-libs/libgpg-error/libgpg-error-1.36.ebuild b/dev-libs/libgpg-error/libgpg-error-1.36.ebuild
index 1c2b8171b08f..973e907a96a1 100644
--- a/dev-libs/libgpg-error/libgpg-error-1.36.ebuild
+++ b/dev-libs/libgpg-error/libgpg-error-1.36.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -38,17 +38,19 @@ src_prepare() {
}
multilib_src_configure() {
- ECONF_SOURCE="${S}" econf \
- $(multilib_is_native_abi || echo --disable-languages) \
- $(use_enable common-lisp languages) \
- $(use_enable nls) \
- $(use_enable static-libs static) \
- --enable-threads \
- CC_FOR_BUILD="$(tc-getBUILD_CC)" \
- $("${S}/configure" --help | grep -- '--without-.*-prefix' | sed -e 's/^ *\([^ ]*\) .*/\1/g')
+ local myeconfargs=(
+ $(multilib_is_native_abi || echo --disable-languages)
+ $(use_enable common-lisp languages)
+ $(use_enable nls)
+ $(use_enable static-libs static)
+ --enable-threads
+ CC_FOR_BUILD="$(tc-getBUILD_CC)"
+ $("${S}/configure" --help | grep -o -- '--without-.*-prefix')
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
}
multilib_src_install_all() {
einstalldocs
- find "${D}" -name '*.la' -delete || die
+ find "${ED}" -type f -name '*.la' -delete || die
}