summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-12-12 03:58:47 +0100
committerLars Wendler <polynomial-c@gentoo.org>2020-12-12 04:02:01 +0100
commit69bbf4d7663ae40e8df4068382510b805cd6cbfc (patch)
tree14887f3a70b798590c872793f10558574288fc2b /dev-libs/inih
parentdev-perl/Alien-Build: Cleanup old 2.2{8,9}0.0 (diff)
downloadgentoo-69bbf4d7663ae40e8df4068382510b805cd6cbfc.tar.gz
gentoo-69bbf4d7663ae40e8df4068382510b805cd6cbfc.tar.bz2
gentoo-69bbf4d7663ae40e8df4068382510b805cd6cbfc.zip
dev-libs/inih: Bump to version 52
Ebuild cleanup and corrections. Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'dev-libs/inih')
-rw-r--r--dev-libs/inih/Manifest1
-rw-r--r--dev-libs/inih/inih-52.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-libs/inih/Manifest b/dev-libs/inih/Manifest
index cbef149096ed..c1568bd6205f 100644
--- a/dev-libs/inih/Manifest
+++ b/dev-libs/inih/Manifest
@@ -1 +1,2 @@
DIST inih-51.tar.gz 16258 BLAKE2B 91a5aee6e0ecadf949fbf0b58bd2596bcb985c76fc9000a671d65cb5325c51dbb8bd945ccd7721b72dafafd11c70a9c84ad910768d0fc479e5491db8b7aacbd8 SHA512 eb2f58979d93e51a09326e6c187828643887ac1a239d4b12205567c7d87a671c9c49ca99db376c031d366bc680e579c30dcea9f3eb130ec802597411b2cb3cf4
+DIST inih-52.tar.gz 16808 BLAKE2B 12d4078ad7b6a4013ea77239c486fb7b5e9165252d4a67ee57d60fc72a98f15ca537b610c7b22841cc660e46bb424aa5c9b7ed1cf2462600a2aa58d40447ba90 SHA512 14c0d0dbd78efc99bec8df12067107d130eef8b124e0616f7d83dc4e14530b57f0c8fcf0b8862d425b5a0b84d6c6a6bff7b3c852c9b2e2364ef56c8f64a1f339
diff --git a/dev-libs/inih/inih-52.ebuild b/dev-libs/inih/inih-52.ebuild
new file mode 100644
index 000000000000..dbf1c3a62e42
--- /dev/null
+++ b/dev-libs/inih/inih-52.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson multilib-minimal
+
+DESCRIPTION="inih (INI not invented here) simple .INI file parser"
+HOMEPAGE="https://github.com/benhoyt/inih"
+
+SRC_URI="https://github.com/benhoyt/inih/archive/r${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="BSD"
+SLOT="0"
+
+S="${WORKDIR}/inih-r${PV}"
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Ddefault_library=shared
+ -Ddistro_install=true
+ -Dwith_INIReader=true
+ )
+
+ meson_src_configure
+}
+
+multilib_src_compile() {
+ meson_src_compile
+}
+
+multilib_src_install() {
+ meson_src_install
+}
+
+multilib_src_install_all() {
+ local DOCS=(
+ LICENSE.txt
+ README.md
+ )
+ einstalldocs
+}