summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-09-04 20:35:51 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-09-04 20:38:15 +0200
commit16a44777bafd458c69e5ed79c3168233a6f0bb16 (patch)
treeecbfd6e98d8b7c4ec9ec90772c3aefb95811f393 /dev-lang
parentapp-arch/bzip3: bump to 1.1.5 (diff)
downloadgentoo-16a44777bafd458c69e5ed79c3168233a6f0bb16.tar.gz
gentoo-16a44777bafd458c69e5ed79c3168233a6f0bb16.tar.bz2
gentoo-16a44777bafd458c69e5ed79c3168233a6f0bb16.zip
dev-lang/eisl: bump to 2.62
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/eisl/Manifest1
-rw-r--r--dev-lang/eisl/eisl-2.62.ebuild40
-rw-r--r--dev-lang/eisl/files/eisl-2.62-Makefile.patch33
3 files changed, 74 insertions, 0 deletions
diff --git a/dev-lang/eisl/Manifest b/dev-lang/eisl/Manifest
index 81b0575f9470..12f2843c8f60 100644
--- a/dev-lang/eisl/Manifest
+++ b/dev-lang/eisl/Manifest
@@ -1,2 +1,3 @@
DIST eisl-2.50.tar.gz 1757697 BLAKE2B 83c68213522320c815d9c7930c58181adba6f7fd3387421b7c7de55aca0fb6cabd78f65543c71adb89408531ea59855aafcf5bafd466bf517626a49cd252641f SHA512 4865c09dbbc0db885af69ec5ef0a731e2f55455f296b343b1cb05d3233e1e18c397b3b0a21eb0a6a86f85f20bf4e62f5e968fdf3cab45f6b5e3e3f9ee27d5e80
DIST eisl-2.60.tar.gz 1858691 BLAKE2B 9fc235c13f8e4c83a19bfffaaf94d19b07ae6cb5b1b60041d45da47451fee535a8153be9c360c5b496e33dba0618cc4d871d50a5f5d044675070ce406d635a0a SHA512 abb30b8b8ac1fe39f40292b3e6393d35f3de0cc736aa70125e86d624f32f8ce2b5cbcbbf417e080afc4dc3d49294c42283bfa3f59665e15a7545c10b245ff723
+DIST eisl-2.62.tar.gz 2004955 BLAKE2B a69651f002d8ca418cb863670ddd5931ac8afbbe8dd922fe71717ec8d9e3edbd802dd70ea9035264bba50f4dbcac2657d59d9fd58733c8fce1572ac95b7693e8 SHA512 69674bab8bbb91ebc27abe319afeb71d6cef4eaa74e969b8c3e174f254422fcdeba006d11454fc9d82f1e96bc9b51e8f4a1c7a8a20f14b0006e596eea680397b
diff --git a/dev-lang/eisl/eisl-2.62.ebuild b/dev-lang/eisl/eisl-2.62.ebuild
new file mode 100644
index 000000000000..3b3256166271
--- /dev/null
+++ b/dev-lang/eisl/eisl-2.62.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Interpreter and compiler compatible with the ISLisp standard"
+HOMEPAGE="https://github.com/sasagawa888/eisl/"
+SRC_URI="https://github.com/sasagawa888/eisl/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test" # Tests run cppcheck (and fail)
+
+DOCS=( README{,-ja}.md documents )
+
+RDEPEND="sys-libs/ncurses:="
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-Makefile.patch )
+
+src_compile() {
+ emake CC="$(tc-getCC)" clean edlis eisl
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe edlis eisl
+
+ # Compilation of ISLisp files on installation fails.
+ # Do not compile them and mimic "make install".
+ insinto /usr/share/${PN}
+ doins -r library
+ doins fast.h ffi.h
+
+ einstalldocs
+}
diff --git a/dev-lang/eisl/files/eisl-2.62-Makefile.patch b/dev-lang/eisl/files/eisl-2.62-Makefile.patch
new file mode 100644
index 000000000000..4cb42997dfc2
--- /dev/null
+++ b/dev-lang/eisl/files/eisl-2.62-Makefile.patch
@@ -0,0 +1,33 @@
+--- a/makefile
++++ b/makefile
+@@ -31,7 +31,7 @@ else
+ endif
+ endif
+ endif
+-CFLAGS := $(INCS) -Wall -Wextra -D_FORTIFY_SOURCE=2 $(CURSES_CFLAGS) -U_XOPEN_SOURCE -D_XOPEN_SOURCE=700 -Inana/src
++CFLAGS += $(INCS) -Wall -Wextra $(CURSES_CFLAGS) -U_XOPEN_SOURCE -D_XOPEN_SOURCE=700 -Inana/src
+ DFLAGS := --preview=all --de -w --O3 --release --betterC
+ SRC_CII := cii/src/except.c cii/src/fmt.c cii/src/str.c cii/src/text.c
+ SRC_D := dextension.d disl.d
+@@ -57,7 +57,7 @@ ifeq ($(DEBUG),1)
+ LDFLAGS := -fsanitize=undefined
+ endif
+ else
+- CFLAGS += -O3 -flto -DNDEBUG=1 -DWITHOUT_NANA=1
++ CFLAGS += -DNDEBUG=1 -DWITHOUT_NANA=1
+ SRC_CII += cii/src/mem.c
+ endif
+ OBJ_CII := $(SRC_CII:.c=.o)
+@@ -75,11 +75,10 @@ ifeq ($(shell uname -n),raspberrypi)
+ CFLAGS += -D__rpi__
+ endif
+ ifneq ($(DEBUG),1)
+- LDFLAGS += -flto
+ ifeq ($(shell uname),Darwin)
+ LDFLAGS += -Wl,-S,-x
+ else
+- LDFLAGS += -s
++ LDFLAGS +=
+ endif
+ endif
+ PREFIX := /usr/local