summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormatoro <matoro@users.noreply.github.com>2022-08-14 17:10:37 -0400
committerSam James <sam@gentoo.org>2022-08-14 22:31:14 +0100
commit837268c60ea049af38f60219cb8361fb066e4df5 (patch)
treeb199645ec4823ddacc6a7bd146584d8a4103824d /dev-lang/ghc
parentdev-haskell/xhtml: clean GHC (diff)
downloadgentoo-837268c60ea049af38f60219cb8361fb066e4df5.tar.gz
gentoo-837268c60ea049af38f60219cb8361fb066e4df5.tar.bz2
gentoo-837268c60ea049af38f60219cb8361fb066e4df5.zip
dev-lang/ghc: sync 8.10.6 from ::haskell
Closes: https://github.com/gentoo/gentoo/pull/26864 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-lang/ghc')
-rw-r--r--dev-lang/ghc/ghc-8.10.6.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/dev-lang/ghc/ghc-8.10.6.ebuild b/dev-lang/ghc/ghc-8.10.6.ebuild
index 1464a3e0dd6c..e1df48a3cd92 100644
--- a/dev-lang/ghc/ghc-8.10.6.ebuild
+++ b/dev-lang/ghc/ghc-8.10.6.ebuild
@@ -13,7 +13,7 @@ if [[ ${CTARGET} = ${CHOST} ]] ; then
fi
fi
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit python-any-r1
inherit autotools bash-completion-r1 eutils flag-o-matic ghc-package
inherit multilib multiprocessing pax-utils toolchain-funcs prefix
@@ -37,6 +37,9 @@ arch_binaries="$arch_binaries amd64? ( https://slyfox.uni.cx/~slyfox/distfiles/g
#arch_binaries="$arch_binaries sparc? ( https://slyfox.uni.cx/~slyfox/distfiles/ghc-bin-${PV}-sparc.tbz2 )"
arch_binaries="$arch_binaries x86? ( https://slyfox.uni.cx/~slyfox/distfiles/ghc-bin-${PV}-i686-pc-linux-gnu.tbz2 )"
+# various ports:
+#arch_binaries="$arch_binaries x86-fbsd? ( https://slyfox.uni.cx/~slyfox/distfiles/ghc-bin-${PV}-x86-fbsd.tbz2 )"
+
# 0 - yet
yet_binary() {
case "${ARCH}" in
@@ -74,7 +77,7 @@ BUMP_LIBRARIES=(
LICENSE="BSD"
SLOT="0/${PV}"
-#KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64 ~x86"
IUSE="big-endian +doc elfutils ghcbootstrap ghcmakebinary +gmp numa profile test"
IUSE+=" binary"
RESTRICT="!test? ( test )"
@@ -408,6 +411,11 @@ src_unpack() {
}
src_prepare() {
+ # Force the use of C.utf8 locale
+ # <https://github.com/gentoo-haskell/gentoo-haskell/issues/1287>
+ # <https://github.com/gentoo-haskell/gentoo-haskell/issues/1289>
+ export LC_ALL=C.utf8
+
ghc_setup_cflags
if ! use ghcbootstrap && [[ ${CHOST} != *-darwin* && ${CHOST} != *-solaris* ]]; then