summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormatoro <matoro@users.noreply.github.com>2022-07-11 21:06:29 -0400
committerSam James <sam@gentoo.org>2022-07-22 22:16:00 +0000
commit970fcbe6e15cb77908bdb33fb09e807b1a91057d (patch)
treee6efcc620227639b910acf652ccc70a97c339914 /dev-haskell/uuid-types
parentdev-haskell/utf8-string: keyword 1.0.1.1 for ~ppc64 (diff)
downloadgentoo-970fcbe6e15cb77908bdb33fb09e807b1a91057d.tar.gz
gentoo-970fcbe6e15cb77908bdb33fb09e807b1a91057d.tar.bz2
gentoo-970fcbe6e15cb77908bdb33fb09e807b1a91057d.zip
dev-haskell/uuid-types: add 1.0.5
Signed-off-by: matoro <matoro@users.noreply.github.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/uuid-types')
-rw-r--r--dev-haskell/uuid-types/Manifest2
-rw-r--r--dev-haskell/uuid-types/uuid-types-1.0.5.ebuild44
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-haskell/uuid-types/Manifest b/dev-haskell/uuid-types/Manifest
index 8f3d853d196f..bbffc29916d5 100644
--- a/dev-haskell/uuid-types/Manifest
+++ b/dev-haskell/uuid-types/Manifest
@@ -1 +1,3 @@
DIST uuid-types-1.0.3.tar.gz 11999 BLAKE2B 71941bf6abf554e2fa4fb64ae2cc5d61354643c07fe757920c19b60f762a7ffdce87c222d1f1a4a993b50f95e58ac4a011e2ae10c73108a6b71f65ebff209600 SHA512 039bccea9ee22388a50e3e233c95afdd3a59f01aa5f552dcd8e8c1ded8f9da210933c58a4d9cc0913c768b587c24ee27fa0eed15e531846ea841b666f513df9e
+DIST uuid-types-1.0.5.cabal 2608 BLAKE2B 93d8b89dd8f369032ef0035db3edc07eb21e0985d59c43f17976e1b9f6136ea75e059e5fb1930f9d0ab450846a160b9a5eda4691b13e6aa3bc00de6bd3008d31 SHA512 e2bc98a0f1ddcec5b5f3d26d6f5ec9a7ba5d9c51be9dc56166d975d28753380024623daf694088030fd8b24f9653ff798ce326931a1e7887adca27c15dbe8649
+DIST uuid-types-1.0.5.tar.gz 11922 BLAKE2B 82da240f63c255be7c64ddaa6b6f49e022446afbf814b6cd3f9607fd43c0bf33e5d92b0586477384d46b4906f15b17f72564227ad090da54c03b1c21608f5fcc SHA512 0e0821a426120ab63d991a6cd39ded65a89472751ada4d5fb5e4f12177d8e797ede3b6b74d6817ce260d6334adeb42de31b0073389f58a27a06ec8ea4a574ef6
diff --git a/dev-haskell/uuid-types/uuid-types-1.0.5.ebuild b/dev-haskell/uuid-types/uuid-types-1.0.5.ebuild
new file mode 100644
index 000000000000..b7f12258b510
--- /dev/null
+++ b/dev-haskell/uuid-types/uuid-types-1.0.5.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.1.1.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+CABAL_HACKAGE_REVISION="2"
+inherit haskell-cabal
+
+DESCRIPTION="Type definitions for Universally Unique Identifiers"
+HOMEPAGE="https://github.com/haskell-hvr/uuid"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz
+ https://hackage.haskell.org/package/${P}/revision/${CABAL_HACKAGE_REVISION}.cabal -> ${PF}.cabal"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+RDEPEND=">=dev-haskell/hashable-1.2.7.0:=[profile?] <dev-haskell/hashable-1.5:=[profile?]
+ >=dev-haskell/random-1.1:=[profile?] <dev-haskell/random-1.3:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+ test? ( >=dev-haskell/ghc-byteorder-4.11 <dev-haskell/ghc-byteorder-4.12
+ >=dev-haskell/quickcheck-2.14.2 <dev-haskell/quickcheck-2.15
+ >=dev-haskell/tasty-1.4.0.1 <dev-haskell/tasty-1.5
+ >=dev-haskell/tasty-hunit-0.10 <dev-haskell/tasty-hunit-0.11
+ >=dev-haskell/tasty-quickcheck-0.10 <dev-haskell/tasty-quickcheck-0.11 )
+"
+BDEPEND="app-text/dos2unix"
+
+src_prepare() {
+ # pull revised cabal from upstream
+ cp "${DISTDIR}/${PF}.cabal" "${S}/${PN}.cabal" || die
+
+ # Convert to unix line endings
+ dos2unix "${S}/${PN}.cabal" || die
+
+ # Apply patches *after* pulling the revised cabal
+ default
+}