summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:10:34 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:10:19 +0100
commit382cefe40465552a69ad6e8570aa22d2572e4bc4 (patch)
treeb7629cec3543593ed1b35137302b54b6a432ef06 /dev-haskell/unix-compat
parentdev-haskell/monad-parallel: new package, add 0.8 (diff)
downloadgentoo-382cefe40465552a69ad6e8570aa22d2572e4bc4.tar.gz
gentoo-382cefe40465552a69ad6e8570aa22d2572e4bc4.tar.bz2
gentoo-382cefe40465552a69ad6e8570aa22d2572e4bc4.zip
dev-haskell/unix-compat: add 0.7
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/unix-compat')
-rw-r--r--dev-haskell/unix-compat/Manifest1
-rw-r--r--dev-haskell/unix-compat/metadata.xml9
-rw-r--r--dev-haskell/unix-compat/unix-compat-0.7.ebuild33
3 files changed, 36 insertions, 7 deletions
diff --git a/dev-haskell/unix-compat/Manifest b/dev-haskell/unix-compat/Manifest
index a9ae93104360..a8d26b41146f 100644
--- a/dev-haskell/unix-compat/Manifest
+++ b/dev-haskell/unix-compat/Manifest
@@ -1 +1,2 @@
DIST unix-compat-0.5.2.tar.gz 13281 BLAKE2B 617e916badf79b76959ffcd542ad6fa1f1ea04c0bc741faace7614bc9e0fcae0cc34dabb06197fa8686dee26b0d890ee95d3f6e5f6258e543424a9d99498a0cf SHA512 0a0a98e03edb7c6ab4401a022c3e90f7598b24930cb22ba04711c3f57b8f87990c6669d5cda07196b61d36cb6e0fa8b281822fa99b199c3b78cfccd0bc3f70be
+DIST unix-compat-0.7.tar.gz 15210 BLAKE2B ccf771b729d98f29900dc79bd2e832c44ae06e3153eafadcd6aaff9fcb46cd74d78bc414988ef355e16d0d20ed11d5b82a3828c9c295b4d004b56ae4fefb3804 SHA512 2cac851106148a61c6c94742f6bf4862ce3409defd6b5478791ebabe538b53b4da35bdf552eed685117f72adcff2f16a920791705c734a7149d13184cf2ff549
diff --git a/dev-haskell/unix-compat/metadata.xml b/dev-haskell/unix-compat/metadata.xml
index ee9c185ae638..312d969e96a6 100644
--- a/dev-haskell/unix-compat/metadata.xml
+++ b/dev-haskell/unix-compat/metadata.xml
@@ -5,16 +5,11 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- This package provides portable implementations of parts
- of the unix package. This package re-exports the unix
- package when available. When it isn't available,
- portable implementations are used.
- </longdescription>
<use>
<flag name="old-time">build against old-time package</flag>
</use>
<upstream>
- <remote-id type="github">jystic/unix-compat</remote-id>
+ <remote-id type="hackage">unix-compat</remote-id>
+ <remote-id type="github">haskell-pkg-janitors/unix-compat</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-haskell/unix-compat/unix-compat-0.7.ebuild b/dev-haskell/unix-compat/unix-compat-0.7.ebuild
new file mode 100644
index 000000000000..ce0ef908850d
--- /dev/null
+++ b/dev-haskell/unix-compat/unix-compat-0.7.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Portable POSIX-compatibility layer"
+HOMEPAGE="https://github.com/haskell-pkg-janitors/unix-compat"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="old-time"
+
+RDEPEND=">=dev-lang/ghc-8.10.6:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.2.1.0
+ test? ( dev-haskell/extra
+ dev-haskell/hspec
+ dev-haskell/hunit
+ dev-haskell/monad-parallel
+ dev-haskell/temporary )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag old-time old-time)
+}