summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/pool-conduit
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/pool-conduit')
-rw-r--r--dev-haskell/pool-conduit/Manifest2
-rw-r--r--dev-haskell/pool-conduit/metadata.xml8
-rw-r--r--dev-haskell/pool-conduit/pool-conduit-0.1.2.3.ebuild29
-rw-r--r--dev-haskell/pool-conduit/pool-conduit-0.1.2.ebuild29
4 files changed, 68 insertions, 0 deletions
diff --git a/dev-haskell/pool-conduit/Manifest b/dev-haskell/pool-conduit/Manifest
new file mode 100644
index 000000000000..425541b876e7
--- /dev/null
+++ b/dev-haskell/pool-conduit/Manifest
@@ -0,0 +1,2 @@
+DIST pool-conduit-0.1.2.3.tar.gz 2618 SHA256 db2df6c6c9fba57089a6da3e8ea83a1722fe6e0d26b5d4994fa84a00575dd2d7 SHA512 88e5160511287956158b7df1d023023c56f84d244051dd849dca82429a44e7388e4c150893032d42436482e4433b046efb4250f1702f32a5a8cb71ce3f83ded7 WHIRLPOOL e042a332f53c7654e6948eab39b477f532646c7551d7565d3c90f9afa630cd4b16b3ab330453b55b6e2a1da17131203335438d69d89ba12b6f24523ebc9a01df
+DIST pool-conduit-0.1.2.tar.gz 2586 SHA256 68e7c1c510e58116fe3afafd4a1fe50b139f58d838e41c8ba2a4a57951c09b82 SHA512 957b26c202ff490832a76357af388e67f02ab20afd1e095afffbb4517ba90625b7aa3de15a169c9db8a132530e06c1a46a90e4a8fe3774fa48980fc4e115412e WHIRLPOOL d02abbff011c80b1b3a6b9305888568225f2bf4e102c335c961d927864da83fb34a8cb567a67956b1ce6e6b8bfc5759803105ac81b7819464209eb01de6d2447
diff --git a/dev-haskell/pool-conduit/metadata.xml b/dev-haskell/pool-conduit/metadata.xml
new file mode 100644
index 000000000000..e3d45ec69e96
--- /dev/null
+++ b/dev-haskell/pool-conduit/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ Allocate resources from a pool, guaranteeing resource handling via the ResourceT transformer.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/pool-conduit/pool-conduit-0.1.2.3.ebuild b/dev-haskell/pool-conduit/pool-conduit-0.1.2.3.ebuild
new file mode 100644
index 000000000000..f60cdf3997d3
--- /dev/null
+++ b/dev-haskell/pool-conduit/pool-conduit-0.1.2.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Resource pool allocations via ResourceT. (deprecated)"
+HOMEPAGE="http://www.yesodweb.com/book/persistent"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/monad-control:=[profile?]
+ >=dev-haskell/resource-pool-0.2.1:=[profile?] <dev-haskell/resource-pool-0.3:=[profile?]
+ >=dev-haskell/resourcet-0.3:=[profile?] <dev-haskell/resourcet-1.2:=[profile?]
+ >=dev-haskell/transformers-0.2.1:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+"
diff --git a/dev-haskell/pool-conduit/pool-conduit-0.1.2.ebuild b/dev-haskell/pool-conduit/pool-conduit-0.1.2.ebuild
new file mode 100644
index 000000000000..80f1ed292ce7
--- /dev/null
+++ b/dev-haskell/pool-conduit/pool-conduit-0.1.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Resource pool allocations via ResourceT"
+HOMEPAGE="http://www.yesodweb.com/book/persistent"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/monad-control:=[profile?]
+ >=dev-haskell/resource-pool-0.2.1:=[profile?]
+ <dev-haskell/resource-pool-0.3:=[profile?]
+ >=dev-haskell/resourcet-0.3:=[profile?]
+ <dev-haskell/resourcet-0.5:=[profile?]
+ >=dev-haskell/transformers-0.2.1:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8"