summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2023-11-17 09:24:51 +0000
committerPatrick Lauer <patrick@gentoo.org>2023-11-17 09:25:04 +0000
commitea3c10447c351c6b3ed8b9d7e436f32fcb5f09b0 (patch)
tree159105af1023a6d7a18f2c97506b6632c286fcd5 /dev-db/pgrouting
parentwww-apps/nextcloud: drop 25.0.7 (diff)
downloadgentoo-ea3c10447c351c6b3ed8b9d7e436f32fcb5f09b0.tar.gz
gentoo-ea3c10447c351c6b3ed8b9d7e436f32fcb5f09b0.tar.bz2
gentoo-ea3c10447c351c6b3ed8b9d7e436f32fcb5f09b0.zip
dev-db/pgrouting: add 3.5.1
Signed-off-by: Patrick Lauer <patrick@gentoo.org>
Diffstat (limited to 'dev-db/pgrouting')
-rw-r--r--dev-db/pgrouting/Manifest1
-rw-r--r--dev-db/pgrouting/pgrouting-3.5.1.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-db/pgrouting/Manifest b/dev-db/pgrouting/Manifest
index 1126881dcb86..6b9919c41871 100644
--- a/dev-db/pgrouting/Manifest
+++ b/dev-db/pgrouting/Manifest
@@ -1 +1,2 @@
DIST pgrouting-3.2.1.tar.gz 5940439 BLAKE2B 01f4ec19d4cee9165a5aca946935cf4786a42f943602eca99414b536dec11ffe298f960e11aaa8b747c1b9c1839625ac9d3e7f67f1f606e941c9c738b4970479 SHA512 ead51de138950707008a7ea6b1a18cfe4d8b1885bfe92849464c2714e39f8e43ef3dbebd1c68279987a1321705fe33a598efb463078491d52cb90a8d1a0414c7
+DIST pgrouting-3.5.1.tar.gz 3613985 BLAKE2B a0af5d730673b8a9555891998f0c2cf7ff429d48efc5170aa59ae05518deb6be6b898d52f4c9bf6cd24422922a9c27329cead3281db8df7d7c6b679cec7484f2 SHA512 d29871fc55f8bfa1795816c34483dd8b6a02d24f91b111b5848be8cccc4f04916dc76b99c4bb68ccfcb9c0a745e646ec51e0144a3e09c7fb2d16caabb7a62c40
diff --git a/dev-db/pgrouting/pgrouting-3.5.1.ebuild b/dev-db/pgrouting/pgrouting-3.5.1.ebuild
new file mode 100644
index 000000000000..dfac3a1976d6
--- /dev/null
+++ b/dev-db/pgrouting/pgrouting-3.5.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_BUILD_TYPE="Release"
+
+POSTGRES_COMPAT=( {11..16} )
+POSTGRES_USEDEP="server"
+
+inherit cmake postgres-multi
+
+DESCRIPTION="pgRouting extends PostGIS and PostgreSQL with geospatial routing functionality"
+HOMEPAGE="https://pgrouting.org/"
+LICENSE="GPL-2 MIT Boost-1.0"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+SRC_URI="https://github.com/pgRouting/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+IUSE=""
+
+RDEPEND="${POSTGRES_DEP}
+ >=dev-db/postgis-2.0
+ dev-libs/boost
+ sci-mathematics/cgal
+"
+
+DEPEND="${RDEPEND}"
+# Needs a running psql instance, doesn't work out of the box
+RESTRICT="test"
+
+src_prepare() {
+ cmake_src_prepare
+ postgres-multi_src_prepare
+}
+
+my_src_configure() {
+ local mycmakeargs=( -DPOSTGRESQL_BIN="$($PG_CONFIG --bindir)" )
+ cmake_src_configure
+}
+
+src_configure() {
+ postgres-multi_foreach my_src_configure
+}
+
+src_compile() {
+ postgres-multi_foreach cmake_build
+}
+
+src_install() {
+ postgres-multi_foreach cmake_src_install
+}