summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-12 14:36:26 +0100
committerSam James <sam@gentoo.org>2023-04-12 14:36:26 +0100
commit6e342407489fd0bf17768951c1391b81cde22465 (patch)
treefe1085dd62b2ca1bf0f12e3b6e6107245552c1e0 /dev-db/mysql
parentsys-apps/texinfo: Stabilize 7.0.3 x86, #904223 (diff)
downloadgentoo-6e342407489fd0bf17768951c1391b81cde22465.tar.gz
gentoo-6e342407489fd0bf17768951c1391b81cde22465.tar.bz2
gentoo-6e342407489fd0bf17768951c1391b81cde22465.zip
dev-db/mysql: fix build w/ gcc 13
Thanks-to: Alfred Wingate <parona@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-db/mysql')
-rw-r--r--dev-db/mysql/files/mysql-8.0.32-gcc13.patch21
-rw-r--r--dev-db/mysql/mysql-8.0.32-r2.ebuild1
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-db/mysql/files/mysql-8.0.32-gcc13.patch b/dev-db/mysql/files/mysql-8.0.32-gcc13.patch
new file mode 100644
index 000000000000..e7ec0603bbea
--- /dev/null
+++ b/dev-db/mysql/files/mysql-8.0.32-gcc13.patch
@@ -0,0 +1,21 @@
+https://bugs.gentoo.org/895818
+https://github.com/mysql/mysql-server/pull/456
+
+From 2e5614c4ec50c60fbadbd57f213c1c7d6b959be9 Mon Sep 17 00:00:00 2001
+From: Alfred Wingate <parona@protonmail.com>
+Date: Wed, 12 Apr 2023 16:16:13 +0300
+Subject: [PATCH] sql/binlog/group_commit: include header for std::uint64_t
+
+GCC 13 changed default header dependencies for C++ necessitating
+including cstdint explicitly.
+--- a/sql/binlog/group_commit/bgc_ticket.h
++++ b/sql/binlog/group_commit/bgc_ticket.h
+@@ -23,6 +23,7 @@
+ #ifndef BINLOG_BCG_TICKET_H
+ #define BINLOG_BCG_TICKET_H
+
++#include <cstdint>
+ #include <functional>
+ #include <limits>
+ #include <memory>
+
diff --git a/dev-db/mysql/mysql-8.0.32-r2.ebuild b/dev-db/mysql/mysql-8.0.32-r2.ebuild
index db22ee953b44..1a476651a056 100644
--- a/dev-db/mysql/mysql-8.0.32-r2.ebuild
+++ b/dev-db/mysql/mysql-8.0.32-r2.ebuild
@@ -88,6 +88,7 @@ PDEPEND="perl? ( >=dev-perl/DBD-mysql-2.9004 )"
PATCHES=(
"${WORKDIR}"/mysql-patches
+ "${FILESDIR}"/${PN}-8.0.32-gcc13.patch
)
mysql_init_vars() {