summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2022-03-01 15:32:25 +0000
committerMarek Szuba <marecki@gentoo.org>2022-03-01 16:47:24 +0000
commitbc3847a7ab40eb16a7d12039e13809b9af1b78b5 (patch)
treed722d93ba44abde4cd562ace8bc54aca11c1878c /dev-cpp
parentdev-cpp/benchmark: drop 1.5.6, 1.6.0 (diff)
downloadgentoo-bc3847a7ab40eb16a7d12039e13809b9af1b78b5.tar.gz
gentoo-bc3847a7ab40eb16a7d12039e13809b9af1b78b5.tar.bz2
gentoo-bc3847a7ab40eb16a7d12039e13809b9af1b78b5.zip
dev-cpp/prometheus-cpp: drop 0.13.0
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/prometheus-cpp/Manifest1
-rw-r--r--dev-cpp/prometheus-cpp/prometheus-cpp-0.13.0.ebuild41
2 files changed, 0 insertions, 42 deletions
diff --git a/dev-cpp/prometheus-cpp/Manifest b/dev-cpp/prometheus-cpp/Manifest
index eb903509a93e..c9aa7b0d0b18 100644
--- a/dev-cpp/prometheus-cpp/Manifest
+++ b/dev-cpp/prometheus-cpp/Manifest
@@ -1,2 +1 @@
-DIST prometheus-cpp-0.13.0.tar.gz 55448 BLAKE2B 5790e74f5bb783070b6928adf9d850dc59ff8507d580a96549e62a2ea9ca1cf5b5de0fb445dd373bbae6da3fdae59d1dbf2eca5e04dc3d6adb58e5c52da1e666 SHA512 d2c6708047cec1998697931d5e9b420dfa513ade9f298761b08ae87a5526cbe64476ebc56793c21d8c3d741e3a4db5ce8d27af1d39b4ca30a45de34f40fdca67
DIST prometheus-cpp-1.0.0.tar.gz 56244 BLAKE2B 51ff199c0cd09367de873310a835b7a4a5893de11a6115b3de8ef142eb12b326ea7498a8adc155f3bbea6389da41eef91b5ef23cb0227ef1d1ceb64e4d7eac2e SHA512 baeb12725dd47b170e1ac94c23b2b18ba8aa11dedd95af7adee8fdf9ddebaddfca1ef75c30b1d65c94e1cfbcba2c41e0f4686f1a1de66beaba7dcd70ab190164
diff --git a/dev-cpp/prometheus-cpp/prometheus-cpp-0.13.0.ebuild b/dev-cpp/prometheus-cpp/prometheus-cpp-0.13.0.ebuild
deleted file mode 100644
index 07f8033472af..000000000000
--- a/dev-cpp/prometheus-cpp/prometheus-cpp-0.13.0.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-DESCRIPTION="Prometheus Client Library for Modern C++"
-HOMEPAGE="https://github.com/jupp0r/prometheus-cpp"
-SRC_URI="https://github.com/jupp0r/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~riscv ~x86"
-IUSE="test zlib"
-
-RESTRICT="!test? ( test )"
-
-RDEPEND="net-misc/curl
- sys-libs/zlib
- www-servers/civetweb[cxx]"
-DEPEND="${RDEPEND}
- test? (
- dev-cpp/benchmark
- dev-cpp/gtest
- )"
-BDEPEND="virtual/pkgconfig"
-
-src_configure() {
- local mycmakeargs=(
- -DENABLE_PULL=yes
- -DENABLE_PUSH=yes
- -DENABLE_COMPRESSION=$(usex zlib)
- -DENABLE_TESTING=$(usex test)
- -DUSE_THIRDPARTY_LIBRARIES=OFF
- -DGENERATE_PKGCONFIG=ON
- -DRUN_IWYU=OFF
- )
-
- cmake_src_configure
-}