summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Sarnie <sarnex@gentoo.org>2022-03-10 20:04:02 -0500
committerNick Sarnie <sarnex@gentoo.org>2022-03-10 20:04:02 -0500
commit6b57569dc4d44e84a950941e59ea5eedd8476b07 (patch)
tree7e3bc9711dbb41822165356047572fa832079b6c /dev-cpp
parentdev-java/cortado: drop 0.6.0-r2 (diff)
downloadgentoo-6b57569dc4d44e84a950941e59ea5eedd8476b07.tar.gz
gentoo-6b57569dc4d44e84a950941e59ea5eedd8476b07.tar.bz2
gentoo-6b57569dc4d44e84a950941e59ea5eedd8476b07.zip
dev-cpp/robin-hood-hashing: Fix installation directory
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Nick Sarnie <sarnex@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/robin-hood-hashing/robin-hood-hashing-3.11.5-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-cpp/robin-hood-hashing/robin-hood-hashing-3.11.5-r1.ebuild b/dev-cpp/robin-hood-hashing/robin-hood-hashing-3.11.5-r1.ebuild
new file mode 100644
index 000000000000..152d26b69823
--- /dev/null
+++ b/dev-cpp/robin-hood-hashing/robin-hood-hashing-3.11.5-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+SRC_URI="https://github.com/martinus/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+DESCRIPTION="Fast & memory efficient hashtable based on robin hood hashing for C++11/14/17/20"
+HOMEPAGE="https://github.com/martinus/robin-hood-hashing"
+
+LICENSE="MIT"
+SLOT="0"
+
+src_configure() {
+ local mycmakeargs=(
+ -DRH_STANDALONE_PROJECT=OFF
+ -DCMAKE_INSTALL_LIBDIR="${EPREFIX}/usr/share/"
+ )
+ cmake_src_configure
+}