summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-07-30 02:29:13 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-07-30 02:29:32 +0200
commitdde8825898c4f596ac02647461a1cf18afc64b4b (patch)
tree8566551e4007cfcd75bb5c1a6cfa39d28a9dae69 /app-text/aspell
parentnet-misc/gsutil: RESTRICT=test (bug #690796) (diff)
downloadgentoo-dde8825898c4f596ac02647461a1cf18afc64b4b.tar.gz
gentoo-dde8825898c4f596ac02647461a1cf18afc64b4b.tar.bz2
gentoo-dde8825898c4f596ac02647461a1cf18afc64b4b.zip
app-text/aspell: Bump to version 0.60.7
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'app-text/aspell')
-rw-r--r--app-text/aspell/Manifest1
-rw-r--r--app-text/aspell/aspell-0.60.7.ebuild103
2 files changed, 104 insertions, 0 deletions
diff --git a/app-text/aspell/Manifest b/app-text/aspell/Manifest
index d91b0e49b780..3e96b1b2c72a 100644
--- a/app-text/aspell/Manifest
+++ b/app-text/aspell/Manifest
@@ -1,2 +1,3 @@
DIST aspell-0.60.7-rc1.tar.gz 2034916 BLAKE2B 7518660b0bb7f75aa3b659519a97132675b39dac7e8806d5450d43f40d62683e4c4a41a8c18cd08b6ab9ca53911caeb87e0898eb04ad9d2f98185e2bb6033d5c SHA512 e13240d78b8afd74d8a8cfd5fc7fe2081de85b33621e86543cdf942ed601d36c4e0cbf38a54be083e951127fa9435677cec2997387cb0e7b51a5597386e7e8d1
DIST aspell-0.60.7-rc2.tar.gz 2064871 BLAKE2B 74760cc10804d964bd7d7ee0097198ab26026e0bca2987223b7b58e67491e2d0914c7e24d63cb5540764017dc15358c023e1a3cf6240d5feec8d1dd25ddf6450 SHA512 f9f81efaaeaac4d2bc5b3018fe2cef9ed2406f2c648298465d983a012cf8ba3e25a46593c9833ac5d8b4c8cfca2ac3b76b476a4893ba880e4753770d134bead3
+DIST aspell-0.60.7.tar.gz 2071890 BLAKE2B d0c8780179cca304361b9d58be667f3dd99d9319cbcffd92a0cc69c65c3a40410b10f6953471ddd9d6df355b557761ffff71ccb5bc6995a57de69a9adb07db66 SHA512 6f5fcd1c29164ee18f205594b66f382b51d19b17686293a931ca92c1442d3f7228627ca7d604d860551d0d367ac34dfb2ae34170a844f51e84e390fb1edc4535
diff --git a/app-text/aspell/aspell-0.60.7.ebuild b/app-text/aspell/aspell-0.60.7.ebuild
new file mode 100644
index 000000000000..676475350502
--- /dev/null
+++ b/app-text/aspell/aspell-0.60.7.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic libtool toolchain-funcs
+
+MY_P="${P/_/-}"
+
+DESCRIPTION="A spell checker replacement for ispell"
+HOMEPAGE="http://aspell.net/"
+if [[ "${PV}" = *_rc* ]] ; then
+ SRC_URI="mirror://gnu-alpha/aspell/${MY_P}.tar.gz"
+else
+ SRC_URI="mirror://gnu/aspell/${MY_P}.tar.gz"
+fi
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="nls unicode"
+
+PDEPEND="app-dicts/aspell-en"
+LANGS="af be bg br ca cs cy da de de-1901 el en eo es et fi fo fr ga gl he hr
+hu hy is it la lt nl no pl pt pt-BR ro ru sk sl sr sv uk vi"
+for lang in ${LANGS}; do
+ IUSE+=" l10n_${lang}"
+ case ${lang} in
+ de-1901) dict="de-alt" ;;
+ pt-BR) dict="pt-br" ;;
+ *) dict="${lang}" ;;
+ esac
+ PDEPEND+=" l10n_${lang}? ( app-dicts/aspell-${dict} )"
+done
+unset dict lang LANGS
+
+# English dictionary 0.5 is incompatible with aspell-0.6
+RDEPEND="
+ sys-libs/ncurses:0=[unicode?]
+ nls? ( virtual/libintl )
+ !=app-dicts/aspell-en-0.5*
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+HTML_DOCS=( manual/aspell{,-dev}.html )
+PATCHES=(
+ "${FILESDIR}/${PN}-0.60.5-nls.patch"
+ "${FILESDIR}/${PN}-0.60.5-solaris.patch"
+ "${FILESDIR}/${PN}-0.60.6-darwin-bundles.patch"
+ "${FILESDIR}/${PN}-0.60.6.1-clang.patch"
+ # includes fix for bug #467602
+ "${FILESDIR}/${PN}-0.60.6.1-unicode.patch"
+)
+
+src_prepare() {
+ default
+
+ rm m4/lt* m4/libtool.m4 || die
+ eautoreconf
+ elibtoolize --reverse-deps
+
+ # Parallel install of libtool libraries doesn't always work.
+ # https://lists.gnu.org/archive/html/libtool/2011-03/msg00003.html
+ # This has to be after automake has run so that we don't clobber
+ # the default target that automake creates for us.
+ echo 'install-filterLTLIBRARIES: install-libLTLIBRARIES' >> Makefile.in || die
+
+ # unicode patch breaks on Darwin, NCURSES_WIDECHAR won't get set
+ # any more. Fix this.
+ [[ ${CHOST} == *-darwin* ]] || [[ ${CHOST} == *-musl* ]] && use unicode && \
+ append-cppflags -DNCURSES_WIDECHAR=1
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable nls)
+ $(use_enable unicode)
+ --disable-static
+ --sysconfdir="${EPREFIX}"/etc/aspell
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ docinto examples
+ dodoc "${S}"/examples/*.c
+
+ # install ispell/aspell compatibility scripts
+ newbin scripts/ispell ispell-aspell
+ newbin scripts/spell spell-aspell
+
+ # we explicitly pass '--disable-static' to econf,
+ # hence we can delete .la files unconditionally
+ find "${ED}" -type f -name '*.la' -delete || die
+}