summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-24 14:53:25 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-25 18:18:21 +0100
commit5b40258105458ba53428c83a23ea0c940460b8a6 (patch)
tree00e4676654b010c210520aa65432034d7f9af879 /app-shells
parentapp-editors/retext: Use pypi.eclass (diff)
downloadgentoo-5b40258105458ba53428c83a23ea0c940460b8a6.tar.gz
gentoo-5b40258105458ba53428c83a23ea0c940460b8a6.tar.bz2
gentoo-5b40258105458ba53428c83a23ea0c940460b8a6.zip
app-shells/powerline: Use pypi.eclass
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/powerline/powerline-2.7-r2.ebuild5
-rw-r--r--app-shells/powerline/powerline-9999.ebuild8
2 files changed, 7 insertions, 6 deletions
diff --git a/app-shells/powerline/powerline-2.7-r2.ebuild b/app-shells/powerline/powerline-2.7-r2.ebuild
index 4871eb7525a6..1a13ef03b3d6 100644
--- a/app-shells/powerline/powerline-2.7-r2.ebuild
+++ b/app-shells/powerline/powerline-2.7-r2.ebuild
@@ -4,6 +4,8 @@
EAPI=7
PYTHON_COMPAT=( python3_{9..11} )
+PYPI_NO_NORMALIZE=1
+PYPI_PN="powerline-status"
inherit distutils-r1
DESCRIPTION="The ultimate statusline/prompt utility"
@@ -13,10 +15,9 @@ if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/powerline/powerline"
EGIT_BRANCH="develop"
else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}-status/${PN}-status-${PV}.tar.gz"
+ inherit pypi
KEYWORDS="~amd64 ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux"
fi
-S="${WORKDIR}/${PN}-status-${PV}"
LICENSE="Apache-2.0"
SLOT="0"
diff --git a/app-shells/powerline/powerline-9999.ebuild b/app-shells/powerline/powerline-9999.ebuild
index adefeb71d5ae..5e179f45c6a3 100644
--- a/app-shells/powerline/powerline-9999.ebuild
+++ b/app-shells/powerline/powerline-9999.ebuild
@@ -4,6 +4,8 @@
EAPI=8
PYTHON_COMPAT=( python3_{9..11} )
+PYPI_NO_NORMALIZE=1
+PYPI_PN="powerline-status"
inherit distutils-r1
DESCRIPTION="The ultimate statusline/prompt utility"
@@ -12,11 +14,9 @@ if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/powerline/powerline"
EGIT_BRANCH="develop"
- S="${WORKDIR}/powerline-${PV}"
else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}-status/${PN}-status-${PV}.tar.gz"
- S="${WORKDIR}/${PN}-status-${PV}"
- KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+ inherit pypi
+ KEYWORDS="~amd64 ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux"
fi
LICENSE="Apache-2.0"