summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-08-31 22:44:10 +0100
committerSam James <sam@gentoo.org>2022-08-31 22:45:19 +0100
commitac8e15beacefb21f215f9f25e282da204e4ef435 (patch)
tree8e58ffaac4bd9109ee10ce93ac20aea197572b6b /app-office
parentdev-util/git-delta: add 0.14.0 (diff)
downloadgentoo-ac8e15beacefb21f215f9f25e282da204e4ef435.tar.gz
gentoo-ac8e15beacefb21f215f9f25e282da204e4ef435.tar.bz2
gentoo-ac8e15beacefb21f215f9f25e282da204e4ef435.zip
app-office/libreoffice: use upstream gpgme 1.18.0 patch
At least for 7.3.x. Closes: https://bugs.gentoo.org/865321 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/libreoffice/files/libreoffice-7.3.5.2-gpgme-1.18.0.patch48
-rw-r--r--app-office/libreoffice/libreoffice-7.3.5.2.ebuild6
-rw-r--r--app-office/libreoffice/libreoffice-7.3.9999.ebuild6
-rw-r--r--app-office/libreoffice/libreoffice-9999.ebuild3
4 files changed, 54 insertions, 9 deletions
diff --git a/app-office/libreoffice/files/libreoffice-7.3.5.2-gpgme-1.18.0.patch b/app-office/libreoffice/files/libreoffice-7.3.5.2-gpgme-1.18.0.patch
new file mode 100644
index 000000000000..d8dae52d9b09
--- /dev/null
+++ b/app-office/libreoffice/files/libreoffice-7.3.5.2-gpgme-1.18.0.patch
@@ -0,0 +1,48 @@
+https://bugs.gentoo.org/865321
+https://lists.freedesktop.org/archives/libreoffice/2022-August/089261.html
+https://github.com/LibreOffice/core/commit/aa0b2b756c17d43d2e8c828a909ee2815e332377
+
+From: Rene Engelhard <rene@debian.org>
+Date: Wed, 24 Aug 2022 09:55:33 +0200
+Subject: [PATCH] Make configure work with gpgme >= 1.18
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Sam James wrote:
+> gpgme-1.18.0 dropped a bunch of internal symbols,
+> including progress_callback (see e.g. callbacks.h
+> which has a comment at the top saying it's internal).
+
+Plausibly the workaround to not link against older KDE-specific distro
+packages is not needed anymore.
+
+Check for main as a workaround as we do for other C++ libraries, too.
+
+Change-Id: I57065a5b5b23b9eadb73b01e4f3a289552c3bde4
+Reviewed-on: https://gerrit.libreoffice.org/c/core/+/138667
+Tested-by: Jenkins
+Reviewed-by: Sam James <sam@gentoo.org>
+Reviewed-by: René Engelhard <rene@debian.org>
+(cherry picked from commit b4a94d681a99a6a3eeb6aaa4d2f4dfab8f7c000b)
+Reviewed-on: https://gerrit.libreoffice.org/c/core/+/138553
+Tested-by: René Engelhard <rene@debian.org>
+--- a/configure.ac
++++ b/configure.ac
+@@ -12537,12 +12537,11 @@ elif test \( \( "$_os" = "Linux" -o "$_os" = "Darwin" \) -a "$ENABLE_NSS" = TRUE
+ # C++ library doesn't come with fancy gpgmepp-config, check for headers the old-fashioned way
+ AC_CHECK_HEADER(gpgme++/gpgmepp_version.h, [ GPGMEPP_CFLAGS=-I/usr/include/gpgme++ ],
+ [AC_MSG_ERROR([gpgmepp headers not found, install gpgmepp >= 1.14 development package])], [])
+- # progress_callback is the only func with plain C linkage
+- # checking for it also filters out older, KDE-dependent libgpgmepp versions
+- AC_CHECK_LIB(gpgmepp, progress_callback, [ GPGMEPP_LIBS=-lgpgmepp ],
+- [AC_MSG_ERROR(gpgmepp not found or not functional)], [])
+ AC_CHECK_HEADER(gpgme.h, [],
+ [AC_MSG_ERROR([gpgme headers not found, install gpgme development package])], [])
++ AC_CHECK_LIB(gpgmepp, main, [],
++ [AC_MSG_ERROR(gpgmepp not found or not functional)], [])
++ GPGMEPP_LIBS=-lgpgmepp
+ else
+ AC_MSG_RESULT([internal])
+ BUILD_TYPE="$BUILD_TYPE LIBGPGERROR LIBASSUAN GPGMEPP"
+
diff --git a/app-office/libreoffice/libreoffice-7.3.5.2.ebuild b/app-office/libreoffice/libreoffice-7.3.5.2.ebuild
index 26b88244df96..d45c3048f25c 100644
--- a/app-office/libreoffice/libreoffice-7.3.5.2.ebuild
+++ b/app-office/libreoffice/libreoffice-7.3.5.2.ebuild
@@ -293,6 +293,9 @@ PATCHES=(
"${FILESDIR}/${PN}-5.3.4.2-kioclient5.patch"
"${FILESDIR}/${PN}-6.1-nomancompress.patch"
"${FILESDIR}/${PN}-7.2.0.4-qt5detect.patch"
+
+ # Upstream
+ "${FILESDIR}/${PN}-7.3.5.2-gpgme-1.18.0.patch"
)
S="${WORKDIR}/${PN}-${MY_PV}"
@@ -565,9 +568,6 @@ src_configure() {
myeconfargs+=( --with-rhino-jar=$(java-pkg_getjar rhino-1.6 rhino.jar) )
fi
- # Workaround to fix build w/ gpgme 1.18.0, bug #865321
- export ac_cv_lib_gpgmepp_progress_callback=yes
-
is-flagq "-flto*" && myeconfargs+=( --enable-lto )
MARIADBCONFIG="$(type -p $(usex mariadb mariadb mysql)_config)" \
diff --git a/app-office/libreoffice/libreoffice-7.3.9999.ebuild b/app-office/libreoffice/libreoffice-7.3.9999.ebuild
index dd4c5cd297b3..4969bd6b6a3e 100644
--- a/app-office/libreoffice/libreoffice-7.3.9999.ebuild
+++ b/app-office/libreoffice/libreoffice-7.3.9999.ebuild
@@ -293,6 +293,9 @@ PATCHES=(
"${FILESDIR}/${PN}-5.3.4.2-kioclient5.patch"
"${FILESDIR}/${PN}-6.1-nomancompress.patch"
"${FILESDIR}/${PN}-7.2.0.4-qt5detect.patch"
+
+ # Upstream
+ "${FILESDIR}/${PN}-7.3.5.2-gpgme-1.18.0.patch"
)
S="${WORKDIR}/${PN}-${MY_PV}"
@@ -565,9 +568,6 @@ src_configure() {
myeconfargs+=( --with-rhino-jar=$(java-pkg_getjar rhino-1.6 rhino.jar) )
fi
- # Workaround to fix build w/ gpgme 1.18.0, bug #865321
- export ac_cv_lib_gpgmepp_progress_callback=yes
-
is-flagq "-flto*" && myeconfargs+=( --enable-lto )
MARIADBCONFIG="$(type -p $(usex mariadb mariadb mysql)_config)" \
diff --git a/app-office/libreoffice/libreoffice-9999.ebuild b/app-office/libreoffice/libreoffice-9999.ebuild
index 6c215e444452..f791cbf01383 100644
--- a/app-office/libreoffice/libreoffice-9999.ebuild
+++ b/app-office/libreoffice/libreoffice-9999.ebuild
@@ -565,9 +565,6 @@ src_configure() {
myeconfargs+=( --with-rhino-jar=$(java-pkg_getjar rhino-1.6 rhino.jar) )
fi
- # Workaround to fix build w/ gpgme 1.18.0, bug #865321
- export ac_cv_lib_gpgmepp_progress_callback=yes
-
is-flagq "-flto*" && myeconfargs+=( --enable-lto )
MARIADBCONFIG="$(type -p $(usex mariadb mariadb mysql)_config)" \