summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZoltan Puskas <zoltan@sinustrom.info>2024-02-18 20:30:34 -0800
committerYixun Lan <dlan@gentoo.org>2024-02-28 12:16:38 +0000
commit6a0592c0e8d43d5b1b1303a7f1e635f05ee60951 (patch)
tree6df202897481723149e1c20ab4cd8b669f1594d0 /app-misc
parentprofiles/releases/23.0/package.use: re-enable USE=cli on mpv (diff)
downloadgentoo-6a0592c0e8d43d5b1b1303a7f1e635f05ee60951.tar.gz
gentoo-6a0592c0e8d43d5b1b1303a7f1e635f05ee60951.tar.bz2
gentoo-6a0592c0e8d43d5b1b1303a7f1e635f05ee60951.zip
app-misc/trash-cli: add 0.23.11.10
Signed-off-by: Zoltan Puskas <zoltan@sinustrom.info> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/trash-cli/Manifest1
-rw-r--r--app-misc/trash-cli/trash-cli-0.23.11.10.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/app-misc/trash-cli/Manifest b/app-misc/trash-cli/Manifest
index 65afc3568e75..a68d9605fef1 100644
--- a/app-misc/trash-cli/Manifest
+++ b/app-misc/trash-cli/Manifest
@@ -1,2 +1,3 @@
+DIST trash-cli-0.23.11.10.gh.tar.gz 123296 BLAKE2B d4acb0a2fb900ef3109ddd8f2a763e124ec3d8cd1cdd707b0724d45d57ee739613f803052b18dbcff5c94c1d0e47f34e89538fceaa3c5ca4a49182cb5faeed71 SHA512 2352f68ee0679c632b2d46f302e5a6ea9f370477e8df4dbc8b12bd555652dd322688d3309da7845c08c6e6c7acf4ceb7482410c25331c5ccedfea7649f1214f5
DIST trash-cli-0.23.2.13.2.gh.tar.gz 104006 BLAKE2B c4187faff6618c54be3fcda2fca799d16ff614e5db2a47912aa796d72385bac8dab188977f635372372eae3f6e7d0faaea9405ac93edcd06962f6ffc2bd4694d SHA512 3894d852c01f5e3096bc5bf95220c35cfaa28e2fa555716983ad8203ce7d2206127394cdfbf3f08f0922abdbbfdb4f1a6c1db3fb0bcbda9d936612a2c7d6a7e8
DIST trash-cli-0.23.9.23.gh.tar.gz 119568 BLAKE2B 58329ccde4ec8bbe1577b13949964766ea49ce943d6e80f7d97c6c54d38ca87297dba5197599cf52d0dd3cd02b00a6e5ddf6b3aab525b9e47bde1473c5550acd SHA512 9af243b1c7a7caa2ac303f343b425b8437f72c5b4d461badde56f46940f2c2c997fad622fa7d44dfc16c97e09044837544f2295d5df3adc96e4eb2b50efdd9c9
diff --git a/app-misc/trash-cli/trash-cli-0.23.11.10.ebuild b/app-misc/trash-cli/trash-cli-0.23.11.10.ebuild
new file mode 100644
index 000000000000..2f53edfa3b27
--- /dev/null
+++ b/app-misc/trash-cli/trash-cli-0.23.11.10.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..12} )
+inherit distutils-r1
+
+DESCRIPTION="Python scripts to manipulate trash cans via the command line"
+HOMEPAGE="https://github.com/andreafrancia/trash-cli"
+SRC_URI="https://github.com/andreafrancia/${PN}/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/flexmock[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ local -x COLUMNS=80
+ distutils-r1_src_test
+}